Results 1 to 4 of 4

Thread: Setting Fonts in Konsole Terminal Window

  1. #1

    Default Setting Fonts in Konsole Terminal Window

    Does anybody know where to setup the font and font size in a Konsole terminal window?

    Even though I have a 22' screen and modest 1024 x 768 screen setting, the text is so small I can barely read it. Text quality is poor too like a badly scaled font with no kerning so some letters are illegible.
    Grateful for some help here please.
    Budgie2

  2. #2

    Default Re: Setting Fonts in Konsole Terminal Window

    Quote Originally Posted by Budgie2 View Post
    Does anybody know where to setup the font and font size in a Konsole terminal window?

    Even though I have a 22' screen and modest 1024 x 768 screen setting, the text is so small I can barely read it. Text quality is poor too like a badly scaled font with no kerning so some letters are illegible.
    Grateful for some help here please.
    Budgie2
    Not kerning, anti aliasing I think would be a better description. Further research indicates

    1. Board integrated graphic chip is ATI
    2. There is a history of anti aliasing problems with some ATI drivers.

    So in addition to my first question, what driver is used with normal Opensuse installation? Is it manufacturers proprietary driver or clone?
    Should I try and find and load manufacturers driver?

    Budgie2

  3. #3

    Default Re: Setting Fonts in Konsole Terminal Window

    I can't answer your question about drivers and anti-aliasing settings, but with Opensuse 11.0, KDE 3.5.9, Konsole 1.6.6, this method to change the font works for me:

    From Konsole's menu bar select "Settings > Font" and then either "Enlarge Font" or "Select..." The latter choice allows you to choose a different font and size.

    To make the change permanent, use "Settings > Save as Default." The font setting is then saved in /home/<user>/.kde/share/config/konsolerc. After looking through bug reports at kde.org, Konsole does appear to be sometimes buggy about remembering settings.

    If your current font selection for Konsole is Monospace, this is another "feature." Monospace doesn't exist and is an alias. Monospace often defaults to Andale Mono and that doesn't work very well in KDE for me. To check if this is the case try the command,

    Code:
    fc-match Monospace

  4. #4

    Default Re: Setting Fonts in Konsole Terminal Window

    Quote Originally Posted by thisoldman View Post
    I can't answer your question about drivers and anti-aliasing settings, but with Opensuse 11.0, KDE 3.5.9, Konsole 1.6.6, this method to change the font works for me:

    From Konsole's menu bar select "Settings > Font" and then either "Enlarge Font" or "Select..." The latter choice allows you to choose a different font and size.

    To make the change permanent, use "Settings > Save as Default." The font setting is then saved in /home/<user>/.kde/share/config/konsolerc. After looking through bug reports at kde.org, Konsole does appear to be sometimes buggy about remembering settings.

    If your current font selection for Konsole is Monospace, this is another "feature." Monospace doesn't exist and is an alias. Monospace often defaults to Andale Mono and that doesn't work very well in KDE for me. To check if this is the case try the command,

    Code:
    fc-match Monospace
    Hi and many thanks for the detailed reply. I don't have Settings > Font but I do have Settings > Edit Current Profile and I can change the font there.

    There is no option to save as default but it seems to retain the setting selected.

    You are correct re the Monospace being Andale Mono but this is OK for me if I increase the size to 12 pt.

    However, having sorted out the Konsole window I still have a problem with the fonts elsewhere; for example the size of the fonts in the Konsole window border (eg: budgie:bash) and menus.

    At the moment my biggest problem however is the text in Control Centre Windows. When I do an on line update for example, the addresses of repo sites being refreshed and most of the text is illegible because it is too small and I believe there is no antialiasing. Where is this font size set up please?

    Many thanks for your help.

    Regards,
    Budgie2

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •