We use a piece of proprietary software that allows users to schedule jobs, however it also attempts to read from /var/spool/atjobs to get the status of the job and to see a list of scheduled tasks. There is not an option of telling it to do something else so my only choice is to make the /var/spool/atjobs directory readable. The problem is that as soon as i change it to 744 it just puts it back to 700.

Thoughts?