Results 1 to 8 of 8

Thread: Gotta fix YaST FaST...

Hybrid View

  1. #1

    Default Gotta fix YaST FaST...

    Well here's a fine howdy-do... I installed openSUSE 11.1 KDE last night and was having a pretty care-free ride until I tried to open the installer. When I did, I got this error pretty much as soon as Autorefresh started: "Download (curl) error for http://download.opensuse.org/debug/d...ntent....Error code: connection failed...Error Message: Couldn't resolve host download.opensuse.org"

    I'm guessing the English translation of all that is my YaST internet setting was never set up, and since my web browsers don't seem quite as dead, it's an easy fix. I tried poking around myself, but being a Linux rookie you could say I was...AGHaST by all the config possibilities. Can someone update me on what might be wrong with the setup? My firefox is also slower than Konqueror, and people say that's a IPv6 or DNS thing.




    And "hello," by the way.

  2. #2
    Join Date
    Oct 2008
    Location
    Sunny Arizona
    Posts
    251

    Default Re: Gotta fix YaST FaST...

    Usually this just means that Yast couldn't connect to the online repository. 90% of the time you can just hit "retry" and it will connect.

  3. #3

    Default Re: Gotta fix YaST FaST...

    Nah, this happened today and yesterday. Even when I skip the errors, there's another one not far behind. Any ideas?

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,371
    Blog Entries
    1

    Default Re: Gotta fix YaST FaST...

    Hi DigiTan. Do you have internet connectivity? Can you use browser ok? If all this is ok, then open a terminal window (console) and enter these commands:

    su (to become root user, enter root password when prompted)

    zypper up (zypper CLI update tool)

    See how that goes.

    If network is not working for you, can you post output of these commands:

    /usr/sbin/hwinfo --network
    /sbin/ifconfig
    route

  5. #5

    Default Re: Gotta fix YaST FaST...

    Yeah the net works. It's just YaST and Firefox to a lesser extent having the issues. When I ran Zypper it said: "Please check if the URIs defined for this repository are pointing to a valid repository." I also get a few errors that pop up a few minutes after startup that basically say the same thing.

    HWInfo output:
    Code:
    green@linux-2v48:~> /usr/sbin/hwinfo --network
    24: None 00.0: 10700 Loopback                                   
      [Created at net.124]                                          
      Unique ID: ZsBS.GQNx
      SysFS ID: /class/net/lo                                       
      Hardware Class: network interface                             
      Model: "Loopback network interface"                           
      Device File: lo                                               
      Link detected: yes                                            
      Config Status: cfg=new, avail=yes, need=no, active=unknown    
    
    25: None 00.0: 10701 Ethernet
      [Created at net.124]       
      Unique ID: usDW.ndpeuxxxx
      Parent ID: rBUF.jRtzOxxxx
      SysFS ID: /class/net/eth0  
      SysFS Device Link: /devices/pci0000:00/0000:00:0a.0
      Hardware Class: network interface
      Model: "Ethernet network interface"
      Driver: "forcedeth"
      Driver Modules: "forcedeth"
      Device File: eth0
      HW Address: 00:19:21:xx:xx:xx
      Link detected: yes
      Config Status: cfg=new, avail=yes, need=no, active=unknown
      Attached to: #11 (Ethernet controller)
    IFConfig output:
    Code:
    green@linux-2v48:~> /sbin/ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:19:21:xx:xx:xx  
              inet addr:68.xxx.xxx.xxx Bcast:68.xxx.xxx.xxx  Mask:255.255.254.0    
              UP BROADCAST RUNNING MULTICAST  MTU:576  Metric:1                     
              RX packets:9202 errors:0 dropped:0 overruns:0 frame:0                 
              TX packets:1241 errors:0 dropped:0 overruns:0 carrier:0               
              collisions:0 txqueuelen:1000                                          
              RX bytes:971489 (948.7 Kb)  TX bytes:125750 (122.8 Kb)
              Interrupt:23 Base address:0xe000
    
    lo        Link encap:Local Loopback
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:122 errors:0 dropped:0 overruns:0 frame:0
              TX packets:122 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:8420 (8.2 Kb)  TX bytes:8420 (8.2 Kb)
    Route Output:
    Code:
    green@linux-2v48:~> /sbin/route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    68-xxx-xxx-xxx.dh *               255.255.254.0   U     1      0        0 eth0
    loopback        *               255.0.0.0       U     0      0        0 lo
    default         68-xxx-xxx-xxx.dh 0.0.0.0         UG    0      0        0 eth0

  6. #6
    Join Date
    Jan 2008
    Location
    U.K East Anglia
    Posts
    2,581

    Default Re: Gotta fix YaST FaST...

    Have you tried disabling ipv6 ? if not go to YaST- network devices - network settings,click on global & disable.May require a re-boot.Also check your firewall

    Andy
    To be is to do = Immanuel Kant
    To do is to be = Descartes.
    Do be do be do = Frank Sinatra

    SuSE user since 7.0,Linux user since 1994

  7. #7
    duo NNTP User

    Default Re: Gotta fix YaST FaST...

    > When I ran Zypper it said: "Please check if the URIs
    > defined for this repository are pointing to a valid repository."


    to me it sound like you need to do what is says to do...another way to
    say what is going on is:

    you need to set up the repositories to use..
    you can do that in YaST or zypper..

    info on how to do that in either system is easy to find if you start
    here in your browser:

    file:///usr/share/doc/manual/opensuse-manual_en/manual/index.html
    (bookmark that Documentation)

    and look down to section 3..

    the recommended FOUR repositories you need to set up are found in the
    thread here:
    http://forums.opensuse.org/install-b...ease-read.html
    [a thread if you have not yet discovered is just FULL of great info
    and links you NEED]

    the four repositories to include are are OSS, Non-OSS, Update, and
    Packman...none others until you get things smooth..

    --
    duo

  8. #8

    Default Re: Gotta fix YaST FaST...

    It was the IPv6 checkbox. Looks like unchecking it also fixed Firefox. I'd wager Konqueror defaults to IPv4 or detects the right setting since it never had any problems.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •