Results 1 to 4 of 4

Thread: Can't set English as system language. Everything is in Thai

  1. #1
    jimih NNTP User

    Exclamation Can't set English as system language. Everything is in Thai

    Hi,

    First of all, I am a OpenSuse beginner, so please bear with me if you think I am missing something obvious.

    I installed OpenSuse 11.1 with KDE on my laptop a few days ago, and one of the things I have been struggling with is to make it show and input Thai text correctly (I study Thai at a beginner level). I wasn't able to get it the way I wanted, and when I tried different things in the locale part of the System settings I somehow managed to make Thai the default system language.

    A restart later, basically everything is in Thai. Menus, buttons, etc. After a while I managed to find myself back to the locale settings place only to find that I can't set it back to english. In the "Languages" field the Thai language is the only language, and in the "Add language" dropdown Thai is the only available language. I tried the Reset button, but Thai is still the only language available.

    Screenshot:

    http://img8.imageshack.us/img8/3847/...screenshot.png

    Can someone please help me fix this? I would be very greatful.

    Regards
    /Jimi

  2. #2
    jimih NNTP User

    Default Re: Can't set English as system language. Everything is in T

    ok, a small update now. I managed to fix this, well sort of... under Yast -> System -> Languages. I noticed that Thai was the only language with a check box, even though I never unchecked the English and Swedish checkboxes. Anyhow, I checked The english-uk and swedish and installed them, then I was able to add english-uk and swedish as languages in the locale settings (In the order English-uk, Swedish, Thai). After a restart now some text is in english, some in swedish and some in thai. See the screenshot. Notice especially the bottom right.

    http://img150.imageshack.us/img150/3...screenshot.png

    Can someone explain what is going on here? Is this some bug? Why don't I get everything in English? And why can't I choose English-us in the locale when I have English-us as main language in Yast -> System -> Languages?

    Just to explain what I really want:
    -All OS and program text (buttons, messages, errors) in English (preferably US)
    -Possibility to read websites and documents with thai text (like thai-language.com) and it should not look strange.
    -Possibillity to switch between english-us, swedish and thai keyboard input

    Regards
    /Jimi

  3. #3
    Join Date
    Dec 2008
    Location
    Hamburg
    Posts
    458

    Default Re: Can't set English as system language. Everything is in T

    Hi,

    first some basics:

    There is a difference inbetween basic language setting, additional languages, language which use the user, languages you can read and languages you can write. To make it more complicated you also have to customize some programs to the wanted language.

    The basic or default system language is used for new users. This is set in Yast. Also you can set there additional languages which can be chosen by the user. So your main fault was to set Thai as default language. Bad mistake for beginner level.

    For reading a language you only need the fonts and charsets to do so. So if you cannot read Thai you have to install a Thai font. That's all.

    To write in Thai or Swedish you need an additional keyboard layout. Those you find in the personal settings. Don't choose the setup of the region but the one for keyboard layout. There you can select as many additional keyboards you want. After doing so you should have an icon near the clock in the control bar. It shows the flag and the international abbreviation of the active keyboard. Clicking on this icon you can switch inbetween them.

    I think what you want is the following:

    GUI and console in English (or swedish). So make English (or Swedish) your default language.

    Reading and writing Swedish and Thai. So install Thai fonts and select swedish and thai keyboards as additional ones. I recommend to select "with dead keys" which means that it is easier to add accents to the letters like or . The accent keys are called "dead" cause without hitting another key nothing happens.

    The best way to do all this I think is to add a new user with default settings. I think it is a bug in 11.1 that the language settings are not done well after switching the users language. I also have some things here in English and some in German. Well, that's not to bad but having them in Thai would drive me crazy.

    hth

    Bye

    Erik

  4. #4

    Default Re: Can't set English as system language. Everything is in T

    Hi there, I installed Japanese, if it is non Latin alphabet, install it first and make sure you hit the F2 key in the beginning, after that you can use the GNOME , KDE to add more! If you install Latin based alphabet language like English, be a tough job o get the cursive scripted ones going! In my experience Japanese is the worst to install, if you install Thai first the keyboard icon appears, and you can choose all of the keyboard, if you install English first, the choice is limited to 3 keyboards !

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •