Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Eclipse 3.4.0 and plugins

  1. #1

    Default Eclipse 3.4.0 and plugins

    Hi

    I have just upgrade to 11.1 and installed Eclipse 3.4.0 through software management. I am using Sun Java 1.6.0.

    Eclipse starts up fine, but I am unable to add new plugins to it. I would like to add PHPEclipse and and subclipse.

    I do it through Help > Software updates > Find and Install > Search for new... (and so on)

    Like this one says: Installation - PHPEclipse - Trac

    But when I have checked "PHPEclipse 1.2.x" it says

    The current configuration contains errors and this operation can have unpredictable results.
    Resulting configuration does not contain the platform.

    Can anyone help me?

    /Sune

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Eclipse 3.4.0 and plugins

    Quote Originally Posted by sunetjensen View Post
    Hi

    I have just upgrade to 11.1 and installed Eclipse 3.4.0 through software management. I am using Sun Java 1.6.0.

    Eclipse starts up fine, but I am unable to add new plugins to it. I would like to add PHPEclipse and and subclipse.

    I do it through Help > Software updates > Find and Install > Search for new... (and so on)

    Like this one says: Installation - PHPEclipse - Trac

    But when I have checked "PHPEclipse 1.2.x" it says

    The current configuration contains errors and this operation can have unpredictable results.
    Resulting configuration does not contain the platform.

    Can anyone help me?

    /Sune
    If you are installed it from the repositories, then it's Eclipse GANYMEDE. Update repository for this version:
    http://download.eclipse.org/releases/ganymede/
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3

    Default Re: Eclipse 3.4.0 and plugins

    Hi

    It is Eclipse GANYMEDE.

    I am unable to find either PHPEclipse and subclipse in the update repository http://download.eclipse.org/releases/ganymede/

    Furthermore, if I try to check one of the plugins from the repository it gives the same error.

    So there might be something wrong with my eclipse. But I just installed it from the opensuse repo?

    /Sune

  4. #4
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Eclipse 3.4.0 and plugins

    Quote Originally Posted by sunetjensen View Post
    Hi

    It is Eclipse GANYMEDE.

    I am unable to find either PHPEclipse and subclipse in the update repository http://download.eclipse.org/releases/ganymede/

    Furthermore, if I try to check one of the plugins from the repository it gives the same error.

    So there might be something wrong with my eclipse. But I just installed it from the opensuse repo?

    /Sune
    The PHPEclipse have it's own repository - install it from that one. You need the update site to avoid the missing dependencies (they giving the error:
    The current configuration contains errors and this operation can have unpredictable results.
    Resulting configuration does not contain the platform.
    ).
    So, use these repositories together.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  5. #5

    Default Re: Eclipse 3.4.0 and plugins

    Hi

    I have just uninstalled all eclipse related stuff, so I will try to install it again.

    But before that, I have installed java-1_5_0-sun. Is that correct, or should it be java-1_6_0-sun?

    Thanks for the help.

    /Sune

  6. #6

    Default Re: Eclipse 3.4.0 and plugins

    Quote Originally Posted by sunetjensen View Post
    But before that, I have installed java-1_5_0-sun. Is that correct, or should it be java-1_6_0-sun?
    I was unable to get it running on java-1_5_0-sun. Seems to be something about eclipse not being compiled for that version (?)

    But with java-1_6_0-sun it starts up, and I am able to get to the workbench.

    But when I click on Help > Software updates i get the following message: "Cannot launch the Update UI. The installation has not been configured properly for Software Updates"

    What can I do about this?

    /Sune

  7. #7
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Eclipse 3.4.0 and plugins

    Quote Originally Posted by sunetjensen View Post
    I was unable to get it running on java-1_5_0-sun. Seems to be something about eclipse not being compiled for that version (?)

    But with java-1_6_0-sun it starts up, and I am able to get to the workbench.

    But when I click on Help > Software updates i get the following message: "Cannot launch the Update UI. The installation has not been configured properly for Software Updates"

    What can I do about this?

    /Sune
    Try to start eclipse from the terminal with command:
    Code:
    eclipse -clean
    If still doesn't work, open the Window > Preferences menu and in Install/Update check out the box:
    Show only the latest ...
    Also paste here the output of command:
    Code:
    rpm -qa | grep eclipse
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  8. #8

    Default Re: Eclipse 3.4.0 and plugins

    Quote Originally Posted by ram88 View Post
    Try to start eclipse from the terminal with command:
    Code:
    eclipse -clean
    If still doesn't work, open the Window > Preferences menu and in Install/Update check out the box:
    Show only the latest ...
    Also paste here the output of command:
    Code:
    rpm -qa | grep eclipse
    Hi again

    eclipse -clean did not do any difference.

    "Show only the latest ..." was already checked, and I tried selecting "Show all version of selected software". That didnt' help either.

    # rpm -qa | grep eclipse gives:
    eclipse-3.4-6.2
    eclipse-archdep-platform-3.4-6.2
    eclipse-platform-3.4-6.2

    Thank you for beeing persistant on this one.

    Best regards
    Sune

  9. #9

    Default Re: Eclipse 3.4.0 and plugins

    I came a little closer now.

    I added the repo Index of /repositories/Java:/packages/openSUSE_11.1

    and was able to update Eclipse, so it now is version

    #rpm -qa | grep eclipse
    eclipse-archdep-platform-3.4-226.7
    eclipse-3.4-226.9
    eclipse-platform-3.4-226.9

    It enables the update manager, and I was able to add the GANYMED and subclipse repo in eclipse.

    But when I tried to install subclipse, i first got the following error:

    /usr/share/eclipse/eclipse.ini: Permission denied

    So I gave write access to it (chmod o+w eclipse.ini).

    Then when I tried again, I get the following error:

    An error occurred while collecting items to be installed
    java.lang.NullPointerException

    Any idea?

    Best regards
    Sune

  10. #10

    Default Re: Eclipse 3.4.0 and plugins

    A little more progress again.

    Removed entire eclipse (once more) and installed a fresh from the java repo.

    Then I ran eclispe as root, and was able to install the subclipse addon.

Page 1 of 3 123 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •