Results 1 to 6 of 6

Thread: Googleearth 5 font problem??

  1. #1

    Default Googleearth 5 font problem??

    Just wondering...does anyone know which font the UI of Google-earth 5 is looking for?

    The program runs fine, except that it is using a font that is barely readable. I assume it is looking for a specific font, and when it can't be found it is using something else instead.

  2. #2

    Default Re: Googleearth 5 font problem??

    Try this, I found it in another forum and it worked for me. Lousy font display in Google Earth 5 beta seems to be the following four Google libraries used for Qt display:
    libQtCore.so.4, libQtGui.so.4, libQtNetwork.so.4. and libQtWebKit.so.4* These libraries are in /usr/local/google-earth (the default install directory on my system) or wherever the google-earth folder is on your system.

    In a terminal window, cd to your google-earth folder using:

    you@yourcomp:$ cd /usr/local/google-earth

    Then rename the four offending Qt library files:

    you@yourcomp:/usr/local/google-earth$* mv libQtCore.so.4 libQtCore.so.4.bak
    you@yourcomp:/usr/local/google-earth$* mv libQtGui.so.4 libQtGui.so.4.bak
    you@yourcomp:/usr/local/google-earth$* mv libQtNetwork.so.4 libQtNetwork.so.4.bak
    you@yourcomp:/usr/local/google-earth$* mv libQtWebKit.so.4 libQtWebKit.so.4.bak

    Then find your system libraries libQtCore.so.4.x.x, libQtGui.so.4.x.x, libQtNetwork.so.4.x.x and libQtWebKit.so.4.x.x, where the 4.x.x was 4.4.3 on my Ubuntu 8.10 system. These libraries are usually in /usr/lib. They will be named libqt4-core, libqt4-gui, libqt4-network and libqt4-webkit. We are now going to create symbolic links to these system libraries in the google-earth folder:

    you@yourcomp:/usr/local/google-earth$* ln -s /usr/lib/libQtCore.so.4.4.3* libQtCore.so.4
    you@yourcomp:/usr/local/google-earth$* ln -s /usr/lib/libQtGui.so.4.4.3* libQtGui.so.4
    you@yourcomp:/usr/local/google-earth$* ln -s /usr/lib/libQtNetwork.so.4.4.3* libQtNetwork.so.4
    you@yourcomp:/usr/local/google-earth$* ln -s /usr/lib/libQtWebKit.so.4.4.3* libQtWebKit.so.4

    Now you are done! Fire up Google Earth 5 beta and enjoy readable, clean fonts. The Google Earth extra features and web functions seem to work but I haven't tested all of them so there may be some surprises.

  3. #3
    Join Date
    Jun 2008
    Location
    Wales, MA
    Posts
    486

    Default Re: Googleearth 5 font problem??

    Inhaler, That is outstanding, and works great. I modified your instructions so that they have the paths where google earth is in openSUSE.

    In a terminal window, cd to your google-earth folder using:

    you@yourcomp:$ cd /opt/google-earth

    Then rename the four offending Qt library files:

    you@yourcomp:/opt/google-earth$* mv libQtCore.so.4 libQtCore.so.4.bak
    you@yourcomp:/opt/google-earth$* mv libQtGui.so.4 libQtGui.so.4.bak
    you@yourcomp:/opt/google-earth$* mv libQtNetwork.so.4 libQtNetwork.so.4.bak
    you@yourcomp:/opt/google-earth$* mv libQtWebKit.so.4 libQtWebKit.so.4.bak

    Then find your system libraries libQtCore.so.4.x.x, libQtGui.so.4.x.x, libQtNetwork.so.4.x.x and libQtWebKit.so.4.x.x, where the 4.x.x was 4.4.3 on my openSUSE 11.1 system. These libraries are usually in /usr/lib. They will be named libqt4-core, libqt4-gui, libqt4-network and libqt4-webkit. We are now going to create symbolic links to these system libraries in the google-earth folder:

    you@yourcomp:/opt/google-earth$* ln -s /usr/lib/libQtCore.so.4.4.3* libQtCore.so.4
    you@yourcomp:/opt/google-earth$* ln -s /usr/lib/libQtGui.so.4.4.3* libQtGui.so.4
    you@yourcomp:/opt/google-earth$* ln -s /usr/lib/libQtNetwork.so.4.4.3* libQtNetwork.so.4
    you@yourcomp:/opt/google-earth$* ln -s /usr/lib/libQtWebKit.so.4.4.3* libQtWebKit.so.4

    Now you are done! Fire up Google Earth 5 beta and enjoy readable, clean fonts. The Google Earth extra features and web functions seem to work but I haven't tested all of them so there may be some surprises.

  4. #4

    Default Re: Googleearth 5 font problem??

    That was easy! Excellent, and thanks a lot!

    Everything seems to work, although the pop-up descriptions of sites are a bit wonky (but may not be related to this). Wonky as in: sometimes, but very rarely, the text flows slightly out of the pop-up. The images in the pop-ups are not downloaded either.

  5. #5
    RobschX NNTP User

    Default Re: Googleearth 5 font problem??

    For the 64 Bit version it is also possible, but not much fun.

    I've tried to link the google libs as explained to the 64Bit versions, but without success.

    Then I have copied the 32Bit rpms (libqt4-4.x.y.i586.rpm, libqt4x11-4.x.y.rpm, libQtWebKit4-4.x.y.rpm) to the home directory. Now it is necessary to extract the libs from the rpm files.
    e.g. by

    rpm2cpio libqt4-x11-4.5.3-2.4.2.i586.rpm | cpio -idmv
    rpm2cpio libqt4-4.5.3-2.4.2.i586.rpm | cpio -idmv
    etc.

    The files can now be found at ~/usr/lib/, copy them to the google earth directory (make a backup of the original ones first) and at least at my computer... it works! Good fonts at google earth.

    Greetings,
    Robsch

  6. #6
    Join Date
    Aug 2009
    Location
    Poland, Cracov
    Posts
    55

    Default Re: Googleearth 5 font problem??

    i have changed these Qt libraries according to these instructions, now the interface doesnt show any pictures and other pop-up content, just question-marks. The font is fine then, but the pictures and content was more important. After going back to the default setting (libQt stuff they provided) = again i have the ugly unreadable font and again there are pictures shown within the Google Earth gui.

    Did you chedck , whether the pretty/readable font workaroud lets you afterwards see pictures?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •