Results 1 to 5 of 5

Thread: Problems with external hard disk

  1. #1
    rohit_z2k NNTP User

    Default Problems with external hard disk

    I think i accidentally copied an .iso file onto my external device

    cp x2.iso /dev/sdb1
    cp x2.iso /dev/sdb1/

    now whenever i mount the disk all i see is the content of the iso and not my actual files. Also the disk capacity displayed is of the iso not the HDD. what should i do? I really want the files on the external drive.
    The drive was NTFS formatted

  2. #2
    Join Date
    Sep 2008
    Location
    Dubai
    Posts
    1,770

    Default Re: Problems with external hard disk

    I don't think, you will see the content inside the ISO file if you simply copy the ISO file to an external hard disk.

    Can you post the output of the "mount" command? (Simply type mount from the command line and post the output here).

  3. #3
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,002

    Default Re: Problems with external hard disk

    Quote Originally Posted by rohit_z2k View Post
    I think i accidentally copied an .iso file onto my external device

    cp x2.iso /dev/sdb1
    cp x2.iso /dev/sdb1/

    now whenever i mount the disk all i see is the content of the iso and not my actual files. Also the disk capacity displayed is of the iso not the HDD. what should i do? I really want the files on the external drive.
    The drive was NTFS formatted
    You were root doing this???????????????????
    Henk van Velden

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,802
    Blog Entries
    14

    Default Re: Problems with external hard disk

    You copied the iso to the linux device, instead of to a folder on that mounted device. To explain: /dev/sdb is physical disk, /dev/sdb1 is the first partition on that disk.

    mount /dev/sdb1 /mnt
    cp X2.iso /mnt
    would have done the job, more elegant would have been:
    mount /dev/sdb1 /mnt
    mkdir /mnt/X2
    cp X2.iso /mnt/X2
    This way you would have copied the X2.iso to a folder X2 on the harddisk

    Since the ISO is a disk image, what you did is working. But you want the ISO on the drive, so you accomplished something you didn't want.
    Repartition the drive, then copy as described above. Or use the GUI.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: Problems with external hard disk

    You're not going to like this news, but you have overwritten the previous contents of your external drive. In effect you have turned that drive into an ISO9660 filesystem. I hope you had a backup.

    Well that should make you think twice before messing with raw disk device files, and or blithely working as root. You should hardly ever need to do I/O to raw disk device files. As mentioned in the last post, you really wanted the mounted directory to be the destination. Perhaps you were influenced by the DOS legacy of C:, D: etc still evident in Windows.

    If you were not root when you did this, another explanation is that you added yourself to the "disk" group. As I have mentioned before in the forum, I regard this popular workaround for lack of access to the CD or DVD devices due to bugs in the policykit package as somewhat risky.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •