Results 1 to 4 of 4

Thread: Alsa update: alsa-info.sh problem

  1. #1
    Join Date
    Jul 2008
    Location
    India
    Posts
    162

    Default Alsa update: alsa-info.sh problem

    Hi,
    I am using openSUSE 11.0 gnome. Based on a thread: http://forums.opensuse.org/looking-s...-packages.html i decided to go in for an Alsa update. Since i have alsa-1.0.16-39.1 i needed to execute as root:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh
    But i got the error:
    Error parsing proxy URL http://:8080/: Invalid host name.
    So i navigated to the url: http://www.alsa-project.org/alsa-info.sh and copied the script in /usr/sbin. The as root i executed:
    Code:
    /usr/sbin/alsa-info.sh
    which finally gave me:
    Newer version detected:
    To view the ChangeLog, please visit git.alsa-project.org Git - alsa-driver.git/history - utils/alsa-info.sh
    ALSA-Info script has been updated to v
    Please re-run the script
    But re-running the script did not work as the script had become empty !! I tried a couple of times and the same stuff happens. What is wrong?

  2. #2
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: Alsa update: alsa-info.sh problem

    Quote Originally Posted by samrat_rao View Post
    I am using openSUSE 11.0 gnome. Based on a thread: Easy and simple way to install and update packages - openSUSE Forums i decided to go in for an Alsa update.
    I do not understand. What in that thead made you decide you need an update? Does your sound work? If it works, then you do not need an update.

    Quote Originally Posted by samrat_rao View Post
    Since i have alsa-1.0.16-39.1 i needed to execute as root:
    Code:
    wget http://www.alsa-project.org/alsa-info.sh
    No, that is not correct. Typing " wget http://www.alsa-project.org/alsa-info.sh " only downloads the file. It does not run the script. Also, you do not need to be root to download the file.

    I only ask users to run the file as root when the file is stored under /usr/sbin which requires root permissions to change the file, if it is stored in that directory.

    Quote Originally Posted by samrat_rao View Post
    So i navigated to the url: http://www.alsa-project.org/alsa-info.sh and copied the script in /usr/sbin.
    There is no need for you, running openSUSE-11.0, to have to copy the script into /usr/sbin. That happens to be the location where the file is located for openSUSE-11.1 users, but it is not needed for openSUSE-11.0 users. You can run the script from any location on your path.

    Quote Originally Posted by samrat_rao View Post
    Then as root i executed:
    Code:
    /usr/sbin/alsa-info.sh
    which finally gave me:
    Code:
    Newer version detected:
    To view the ChangeLog, please visit git.alsa-project.org Git - alsa-driver.git/history - utils/alsa-info.sh
    ALSA-Info script has been updated to v
    Please re-run the script
    But re-running the script did not work as the script had become empty !! I tried a couple of times and the same stuff happens. What is wrong?
    I have no idea. I'm confused by what you are trying to do.

    Note:
    • just typing "wget some-url" without the options necessary, will not run the script. It will only download it and you do not need to be root to do that.
    • you do not need to copy the script into /usr/sbin to run it as an openSUSE-11.0 user
    • how do you know the script is empty? Did you open it with a text editor to confirm it is empty?

    If you really want to run the script, then as a REGULAR user, NOT as root, copy and paste the following, per the audio troubleshooting guide that IS referenced in the thread that you referenced:
    Code:
    wget -O alsa-info.sh http://www.alsa-project.org/alsa-info.sh && bash alsa-info.sh

  3. #3
    Join Date
    Jul 2008
    Location
    India
    Posts
    162

    Default Re: Alsa update: alsa-info.sh problem

    I do not understand. What in that thead made you decide you need an update? Does your sound work? If it works, then you do not need an update.
    Yes my sound works but my Alsa driver is not the latest. So i wish to get the latest one.
    No, that is not correct. Typing " wget http://www.alsa-project.org/alsa-info.sh " only downloads the file. It does not run the script. Also, you do not need to be root to download the file.
    Ya, i know that. But typing wget http://www.alsa-project.org/alsa-info.sh gives the error:
    Error parsing proxy URL http://:8080/: Invalid host name.
    So i had to go to http://www.alsa-project.org/alsa-info.sh and download the script.
    I have no idea. I'm confused by what you are trying to do.
    After downloading the script i tried to run it from wherever it was saved. But after the 1st couple of steps of answering in the affirmative, i get:
    Newer version detected:
    To view the ChangeLog, please visit git.alsa-project.org Git - alsa-driver.git/history - utils/alsa-info.sh
    ALSA-Info script has been updated to v
    Please re-run the script
    Now i see (of course with a text editor) that the contents of the script have been erased totally.

    I think that it may just be a wiser option to directly add the alsa repo, update the alsa driver and then disable the repo.

  4. #4
    Join Date
    Mar 2008
    Location
    Phuket, Thailand
    Posts
    26,517
    Blog Entries
    37

    Default Re: Alsa update: alsa-info.sh problem

    Quote Originally Posted by samrat_rao View Post
    Yes my sound works but my Alsa driver is not the latest. So i wish to get the latest one
    Just a note of caution ... sometimes bugs are introduced by software updates. If one has an application that is running well, then IMHO updating with no real reason (other than there is an update available) is not the best approach. In particular, this applies to alsa updates. ....

    Just my 2 cents.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •