Results 1 to 3 of 3

Thread: Bad disc I/O Performance, no DMA?

  1. #1
    Dilligent NNTP User

    Question Bad disc I/O Performance, no DMA?

    Hey folks, im a student of computer science and have been using openSuSe for a while now. I do have a very fast system:

    CPU: Intel Core 2 Quad Q6600 (4x 2.66GHz)
    Mainboard: Asus P5Q Pro
    RAM: 4GB DDR2 800

    DISCS:
    200 GB Sata2
    400 GB Sata2

    nVidia Geforce 8800GT

    Everytime i copy files, no matter if it is across hard discs, onto an USB-device or if i just copy a file from on partition onto another on the same HDD i suffer from poor system responsiveness in general. My CPU usage goes very high, and i experience high latency from time to time when i try to do other things (even the mouse stutters sometimes), applications take very long to start. It's very disturbing, because browsing the web becomes very sluggish as well.

    I'm running OpenSUSE 11.1 with KDE 4.2.1, always updated to the latest revisions. But it does not matter, because the same thing happens when i use "cp" in a shell.

    I have always had this problem, even when using Gnome in OpenSUSE 11.0. Could it be that DMA is not enabled and all the work for copying files is done by the CPU? And why is it that actually browsing the web while copying one large file is becoming so sluggish. I believe there is a high latency when accessing the hard drive during file transfers, some latency is to be expected, of course, but not at this level. I do not mean to advertise or anything, i do use windows xp for games, and i don't experience it there.

    I'd be happy for any help, suggestions or ideas
    Thanks in advance, Dennis

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,985
    Blog Entries
    14

    Default Re: Bad disc I/O Performance, no DMA?

    Take a look, in a terminal, at 'man hdparm'. This not only allows you to view parameters of your hdds but also to set them. It's a long time since i've dealt with hdparm, but some option should solve this.

    BTW, have you tried other distro's? If yes, did you get the same result?

    Could you also post the BIOS settings for both disks? I know XP doesn't care to much, but linux does.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Dilligent NNTP User

    Default Re: Bad disc I/O Performance, no DMA?

    I have stumbled upen some things i forgot to mention:

    linux-1f7y:/home/dennis # hdparm -d /dev/sda

    /dev/sda:
    HDIO_GET_DMA failed: Inappropriate ioctl for device
    linux-1f7y:/home/dennis #
    linux-1f7y:/home/dennis # hdparm -d /dev/sdb

    /dev/sdb:
    HDIO_GET_DMA failed: Inappropriate ioctl for device
    linux-1f7y:/home/dennis #

    linux-1f7y:/home/dennis # hdparm -Tt /dev/sda

    /dev/sda:
    Timing cached reads: 6744 MB in 2.00 seconds = 3374.92 MB/sec
    Timing buffered disk reads: 176 MB in 3.02 seconds = 58.29 MB/sec
    linux-1f7y:/home/dennis # hdparm -Tt /dev/sdb

    /dev/sdb:
    Timing cached reads: 6840 MB in 2.00 seconds = 3422.33 MB/sec
    Timing buffered disk reads: 200 MB in 3.03 seconds = 66.07 MB/sec
    I'll look into the BIOS now... maybe there is something i have overlooked.

    Edit:
    "Sata Configuration: Enhanced [Enhanced | Compatible | Something else i forgot but it was less desirabled..]
    "Configure Sata as: IDE [IDE | AHCI | RAID]"

    I switched this to AHCI now and i believe it has gotten a little bit better but i can't tell yet. I also believe my windows installation might fail to boot (because microsoft hadn't made it out of the stone age yet.. they still expect me to have a floppy for SATA drivers during installation.. meh..)

    I will keep this in mind, but thanks for the tip

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •