Results 1 to 6 of 6

Thread: screen gone blank

  1. #1

    Unhappy screen gone blank

    hello every1,
    im runnin openSUSE 11.1 gnome. while i was enabling desktop effects, my screen has gone bizzare. All i see is a white screen and sometimes it logs me out itself. I can still login as root. I've tried failsafe settings without any luck. Is there a config file i could edit or remove to get things back on track!

  2. #2
    Join Date
    Jun 2008
    Groningen, Netherlands
    Blog Entries

    Default Re: screen gone blank

    I don't know enought about your machine but i can make a guess:

    You do not have Composite enabled, whilst trying to run a composite windowmanager. In language: for the desktop effects you need to have the Composite option for your X-server, the graphic display server, enabled.

    In the folder /etc/X11 you find the xorg.conf file. The last three lines have to be:

    Section "Extensions"
    Option "Composite" "on"

    You can do that by logging in as root (should not be done, but you don't have any other quick option now) and editing the file /etc/X11/xorg.conf
    After having done so, logout as root. Login with normal username and you should be OK.

    If this does not solve it, get back to us

    Please let us know if this solved the
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

  3. #3

    Default Re: screen gone blank

    thanx for the reply!
    bt i think the composite is on. i already had some of the effects on and the end of the Xorg.conf file is as u mentioned. i opened up another account frm root and hav special effects on on dat one and its doing fine. I desperately deleted xorg.conf and restarted. dat was a bad idea. :S
    I;m running intel pentium 4 CPU 3.00 Ghz wid 1 GB ram.
    Kernel Linux
    Gnome 2.24.1

  4. #4

    Default Re: screen gone blank

    I hope I'm not hijacking here. I have the same problem, but it was invoked by me on a brand new installation as soon as I enabled "Screen effects". The screen goes all white, except I can see the mouse cursor, and I suspect that everything is actually working fine in the background ot these whiteout conditions. So what I am wanting is a way to navigate to a command line where I might then manually undo whatever it was I did.

    As an aside, one of the installations I tried yesterday was Novell's SLED 11 CD and its very first desktop looked the same way, so I suspect that it got installed with these "screen effects" enabled.

    Apologies if this leads shresthanoz away from a different fix if his/her problem is different.


  5. #5

    Default Re: screen gone blank

    I also need to add that I have no obvious way into this machine anymore. I can't get to any prompt where I can login as root.

  6. #6

    Default Re: screen gone blank

    As Emily Litella (RIP) might say, "Never mind."

    I learned how to launch in runlevel 3 and then was able to login as root, navigate to /home/admin/.config/compiz/ and delete the compiz-enable file.

    Then, rebooting or launching into runlevel 5 brought the desktop back. Someday, I'll try figuring out why my laptop doesn't like compiz, but until then, I can live without desktop effects, thank you very much.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts