I've tried everything that I can find, but my laptop screen still goes into powersave whether it's plugged in or not.

I've gone into Configure Desktop > Display > Power Control and disabled it in there. I've gone into Configure Desktop > Advanced Tab > Power Management and unchecked "Let PowerDevil manage screen powersaving"

I've even tried editing the profiles with no luck.

If I go into SaX2 I don't have any powersaving or screensaver options. Can anybody shed some light on this for me? It can't be this difficult and I must be overlooking something obvious. Any help is appreciated.