Results 1 to 9 of 9

Thread: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it working?

  1. #1
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Unhappy Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it working?

    I found some issues with Groupwise client and Opensuse ( thanks mother Novell ).

    Groupwise Client 703HP1 - openSUSE Forums

    groupwise 7.03 on opensuse 11 - openSUSE Forums

    Groupwise Hang On Opensuse 10.2 - openSUSE Forums

    Sadly, these links are of no use.

    I tried changing and mixing latest versions of java-sun in the groupwise directory (/opt/novell/groupwise/client), both 32bit and 64bit, both 1.5.0 and 1.6.0.
    I installed separately and not and in various combinations openmotif, openmotif22, libstdc++33 (both 32bit and 64bit).

    No good news!

    At the best, the Groupwise client starts, I can change the fonts in use, i can open mail, send mail, but I can't take a look at the properties of mails, I can't exit cleanly (need to kill -9 two instances if I want to reopen the client), and probably much more (i stopped testing, being the clean exit a must!).

    Launching the client from command line, gives these messages:
    Code:
    ERROR: ld.so: object '/usr/lib64/libv4l/v4l2convert.so' from /etc/ld.so.preload cannot be preloaded: ignored.
    ace@m2300:/opt/novell/groupwise/client/bin> Error: Failed to load /home/ace/.novell/groupwise/.webrenderer/linux/corecomponents/libgtksuperwin.so
    Error: Failed to load /home/ace/.novell/groupwise/.webrenderer/linux/corecomponents/libgtkxtbin.so
    Error: Failed to load /home/ace/.novell/groupwise/.webrenderer/linux/corecomponents/libgtkembedmoz.so
    Error: Failed to load /home/ace/.novell/groupwise/.webrenderer/linux/corecomponents/libgtkxtbin.so
    Error: Failed to load.
    Exception in thread "ControlQueue" java.lang.UnsatisfiedLinkError: setMozPath
            at com.webrenderer.linux.NativeMozillaLibrary.setMozPath(Native Method)
            at com.webrenderer.linux.NativeMozillaLibrary.a(NativeMozillaLibrary.java)
            at com.webrenderer.linux.k.task(k.java)
            at com.webrenderer.linux.ControlQueue.run(ControlQueue.java)
    Is there someone who really uses this client in an OpenSuse environment?

    Thanks in advance if someone has some valid clues.

    Bye, bye.

  2. #2
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    108

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    well gw 8 client is working fine under 11.1 i386 (to bad the backend is having some problems), do you have compiz ? I remember on 7.0.3 running 11.1 and compiz (had all kinds of issues, wa unbearable really) ended up running evolution with SOAP to connect to gw poa (better client anyways imho, pgp dont email without it )

    about the ld.so error maybe this will help ?

    ld.so Error - openSUSE Forums

  3. #3
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    Thanks Heremod,
    I'm abroad now, so I'll do some more work in April.

    The link is surely helpfull (I use sPackman repository), but the error should not be blocking (I think it's a warning).

    Regarding Compiz ... bad news. I installed Opensuse 11.1 because of Compiz !!! (I want the bells and whistles ...).

    What a pity, GroupWise 6.5 worked perfectly ...
    Can Groupwise 8 client be used with Groupwise 7.0.3 server? I don't think so, but i'll give it a try.

    I'll let you know.

    Bye. Thank you very much!

  4. #4
    Join Date
    Feb 2009
    Location
    Finland
    Posts
    108

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    acez yeah I feel you their too , Im also running compiz fusion , like I said I ended up using soap with evolution to connect to gw.

    afaik you can connect with the gw 8 client to a 7 backend you just cant use all the new features that come with the new client. Also I think there in Console One their is a setting to allow Version X of Clients to the backend . Dont Quote me on this Verbatim its been awhile since I have done any GW Administration stuff .

    Good Luck !

  5. #5
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    I did some more unsuccessful homework.

    Now I'm quite happy with the webaccess interface of Groupwise 7.0.3.
    It's really better than before, even if not perfect. Great problems if you need to attach not only files but also e-mails, anyway at least i can work decently.

    Thanks to you all, now I'm waiting for the upgrade to the 8.x version ... (my organization will not upgrade so fast unfortunately... ).

    Bye, bye.

  6. #6

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    I JUST solved this. You need:
    GTK
    OpenMotif-22 (32b and 64b)
    GLIB22 (?)
    GTK-GLAREA (?)

    I don't know the RPM names, it should be sufficient to ensure you have 32bit GTK, 32bit OpenMotif-22, and the rest get picked up as dependencies.

  7. #7
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    Quote Originally Posted by jknarr View Post
    I JUST solved this. You need:
    GTK
    OpenMotif-22 (32b and 64b)
    GLIB22 (?)
    GTK-GLAREA (?)

    I don't know the RPM names, it should be sufficient to ensure you have 32bit GTK, 32bit OpenMotif-22, and the rest get picked up as dependencies.
    I have these on my system:
    openmotif 2.3.1-2.9
    openmotif22-libs 2.2.4-137.72
    openmotif22-libs-32bit 2.2.4-137.72
    openmotif-libs 2.3.1-2.9
    openmotif-libs-32bit 2.3.1-2.8
    gtk 1.2.10-1084.3
    gtk2 2.14.4-8.6.2
    gtk2-32bit 2.14.4-8.6.2
    gtk2-branding-openSUSE 11.1-1.12
    gtk2-engines 2.16.1-4.1
    gtk2-engines-32bit 2.16.1-4.1
    gtk2-theme-openSUSE 11.1-1.12


    No idea how to get or who provides glib22 and glarea (searched with yast tools).

    Client GW-7.0.3 NOT working (it starts, but is absolutely unusable!).

    Thank for your help, anyway! Still working with webaccess interface.

    Bye, bye.

  8. #8
    Join Date
    Dec 2008
    Location
    Italy
    Posts
    132

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    Wanna smile?

    I installed e fresh SLED 11 in a virtualbox (Sun), just the minimum, selecting KDE and deselecting Gnome, upgraded completely at end of installation (regularly registered with Novell registration code, etc.), downloaded the last GW-7.0.3HP2 linux client, installed it with the "install" file provided (by the way, libstdc++.so.5 is a prerequisite, so got the libstd++33 rpm package).

    So what's up?

    Everything's OK (or so it says): got the icon on the desktop, click on it, entered the mail system, clicked on a mail (wow!), opened the mail, clicked on the "properties" tab: GW client got FROZEN !!!



    Client's not for me .... let's stay with the webaccess ....




    Bye, bye (I'll look for something more on SLED forums, if something gets better, I'll post a follow up)

  9. #9
    saxa NNTP User

    Default Re: Groupwise 7.0.3 and Opensuse 11.1 (x86_64): is it workin

    I have the same problem with any SuSE version in X86_64.

    I think it's a problem related to the HTML parser.

    If you try to open a rich tect mail then you get "hanged"!

    Any suggestion?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •