Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Xinerama and Gnome

  1. #1

    Question Xinerama and Gnome

    Hi all,

    I am currently having some issues with xinerama and GNOME. When i first boot up and login non of my desktop icons appear but, everything else works fine.

    I get the following error:
    Code:
    Xlib:  extension "RANDR" missing on display ":0.0".
    I used the handy nvidia settings manager to configure my xorg. If i restart GNOME and log back in my icons show up fine. All help/suggestion welcome.

    Thanks,
    sloter

    xorg.conf:
    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildmeister@builder62)  Thu Feb  5 00:09:30 PST 2009
    
    # /.../
    # SaX generated X11 config file
    # Created on: 2009-03-17T17:39:53-0400.
    #
    # Version: 8.1
    # Contact: Marcus Schaefer <sax@suse.de>, 2005
    # Contact: SaX-User list <https://lists.berlios.de/mailman/listinfo/sax-users>
    #
    # Automatically generated by [ISaX] (8.1)
    # PLEASE DO NOT EDIT THIS FILE!
    #
    
    Section "ServerLayout"
        Identifier     "Layout[all]"
        Screen      0  "Screen0" 1680 1050
        Screen      1  "Screen1" 1680 0
        Screen      2  "Screen2" 0 0
        Screen      3  "Screen3" 0 1050
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse1" "CorePointer"
        Option         "Clone" "off"
        Option         "Xinerama" "1"
    EndSection
    
    Section "Files"
        InputDevices      "/dev/gpmdata"
        InputDevices      "/dev/input/mice"
        FontPath        "/usr/share/fonts/misc:unscaled"
        FontPath        "/usr/share/fonts/local"
        FontPath        "/usr/share/fonts/75dpi:unscaled"
        FontPath        "/usr/share/fonts/100dpi:unscaled"
        FontPath        "/usr/share/fonts/Type1"
        FontPath        "/usr/share/fonts/URW"
        FontPath        "/usr/share/fonts/Speedo"
        FontPath        "/usr/share/fonts/PEX"
        FontPath        "/usr/share/fonts/cyrillic"
        FontPath        "/usr/share/fonts/latin2/misc:unscaled"
        FontPath        "/usr/share/fonts/latin2/75dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/100dpi:unscaled"
        FontPath        "/usr/share/fonts/latin2/Type1"
        FontPath        "/usr/share/fonts/latin7/75dpi:unscaled"
        FontPath        "/usr/share/fonts/baekmuk:unscaled"
        FontPath        "/usr/share/fonts/japanese:unscaled"
        FontPath        "/usr/share/fonts/kwintv"
        FontPath        "/usr/share/fonts/truetype"
        FontPath        "/usr/share/fonts/uni:unscaled"
        FontPath        "/usr/share/fonts/CID"
        FontPath        "/usr/share/fonts/ucs/misc:unscaled"
        FontPath        "/usr/share/fonts/ucs/75dpi:unscaled"
        FontPath        "/usr/share/fonts/ucs/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/misc:unscaled"
        FontPath        "/usr/share/fonts/hellas/75dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/100dpi:unscaled"
        FontPath        "/usr/share/fonts/hellas/Type1"
        FontPath        "/usr/share/fonts/misc/sgi:unscaled"
        FontPath        "/usr/share/fonts/xtest"
        FontPath        "/opt/kde3/share/fonts"
    EndSection
    
    Section "Module"
        Load           "dri"
        Load           "dbe"
        Load           "freetype"
        Load           "extmod"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "AllowMouseOpenFail" "on"
        Option         "ZapWarning" "on"
        Option         "Xinerama" "1"
    EndSection
    
    Section "InputDevice"
        Identifier     "Keyboard0"
        Driver         "kbd"
        Option         "Protocol" "Standard"
        Option         "XkbLayout" "us"
        Option         "XkbModel" "microsoftpro"
        Option         "XkbRules" "xfree86"
    EndSection
    
    Section "InputDevice"
        Identifier     "Mouse1"
        Driver         "mouse"
        Option         "Buttons" "12"
        Option         "Device" "/dev/input/mice"
        Option         "Name" "Logitech USB Gaming Mouse"
        Option         "Protocol" "explorerps/2"
        Option         "Vendor" "Sysp"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 82.0
        VertRefresh     48.0 - 76.0
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 82.0
        VertRefresh     48.0 - 76.0
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor3"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 82.0
        VertRefresh     48.0 - 76.0
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor2"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 83.0
        VertRefresh     48.0 - 76.0
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:5:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device3"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Device"
        Identifier     "Device2"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:5:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "DFP-0: NULL, DFP-1: 1680x1050 +0+0"
    # Removed Option "TwinView" "1"
    # Removed Option "metamodes" "DFP-0: 1680x1050 +1680+0, DFP-1: 1680x1050 +0+0"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinViewXineramaInfoOrder" "DFP-1"
        Option         "TwinView" "0"
        Option         "metamodes" "DFP-0: 1680x1050 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
    
    # Removed Option "metamodes" "DFP-0: nvidia-auto-select +0+0, DFP-1: nvidia-auto-select +1680+0"
    # Removed Option "TwinView" "1"
    # Removed Option "metamodes" "DFP-0: nvidia-auto-select +1680+0, DFP-1: nvidia-auto-select +0+0"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen3"
        Device         "Device3"
        Monitor        "Monitor3"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "DFP-1"
        Option         "metamodes" "DFP-1: 1680x1050 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen2"
        Device         "Device2"
        Monitor        "Monitor2"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Extensions"
        Option         "Composite" "on"
        Option         "RANDR" "on"
    EndSection

  2. #2

    Default Re: Xinerama and Gnome

    Anyone have any ideas?

    James

  3. #3
    MultiplePersonality NNTP User

    Default Re: Xinerama and Gnome

    jgeboski wrote:
    > Anyone have any ideas?


    in your first post you say "I used the handy nvidia settings manager
    to configure my xorg. If i restart GNOME and log back in my icons
    show up fine."

    which sounds like you fixed your problem...are you now saying that if
    you reboot that fix does not persist?

    --
    solo

  4. #4

    Default Re: Xinerama and Gnome

    Quote Originally Posted by MultiplePersonality View Post
    jgeboski wrote:
    > Anyone have any ideas?


    in your first post you say "I used the handy nvidia settings manager
    to configure my xorg. If i restart GNOME and log back in my icons
    show up fine."

    which sounds like you fixed your problem...are you now saying that if
    you reboot that fix does not persist?

    --
    solo
    Great Question!

    What i mean is when i first boot up and login non of the desktop icons start. If i restart GNOME(ctrl + alt + bcksp) without rebooting the pc it will work. It is just an inconvenience to restart gnome.

    Thank again,
    James

  5. #5
    MultiplePersonality NNTP User

    Default Re: Xinerama and Gnome

    jgeboski wrote:
    > MultiplePersonality;1961384 Wrote:
    >> jgeboski wrote:
    >>> Anyone have any ideas?

    >> in your first post you say "I used the handy nvidia settings manager
    >> to configure my xorg. If i restart GNOME and log back in my icons
    >> show up fine."
    >>
    >> which sounds like you fixed your problem...are you now saying that if
    >> you reboot that fix does not persist?
    >>
    >> --
    >> solo

    >
    > Great Question!
    >
    > What i mean is when i first boot up and login non of the desktop icons
    > start. If i restart GNOME(ctrl + alt + bcksp) without rebooting the pc
    > it will work. It is just an inconvenience to restart gnome.


    AH! well, now that i understand your problem i wish i knew the way to
    fix it...

    hmmmm...i've not used Gnome in years but, if you right click on an
    empty spot on the desktop, does the resulting menu offer "Refresh
    Desktop" or something similar....if you do that do the icons pop up?
    does ANYthing change.

    how about if you go from one desktop to another?

    have you enabled desktop effects or compiz? what happens if you
    disable them?

    have you used the forum's advanced search and looked for "extension
    "RANDR" missing on display" *or* just RANDR and done that
    reading/understanding..

    when you entered
    suse "extension RANDR missing on display"
    into a google search, did you learn anything useful from the 1,240
    (english) hits?

    sorry i can't help more...but, by the way i don't even know what
    xinerama IS, so i obviously haven't had this problems and don't plan
    to read all those hits for you...but, maybe you will read enough that
    you understand enough to help yourself..

    for SURE you should read the 6 of the 7 hits from (one is yours, and
    you don't need to read it):
    suse xinerama "extension RANDR missing on display"

    good luck!!

    --
    solo

  6. #6

    Default Re: Xinerama and Gnome

    Quote Originally Posted by MultiplePersonality View Post
    jgeboski wrote:
    > MultiplePersonality;1961384 Wrote:
    >> jgeboski wrote:
    >>> Anyone have any ideas?

    >> in your first post you say "I used the handy nvidia settings manager
    >> to configure my xorg. If i restart GNOME and log back in my icons
    >> show up fine."
    >>
    >> which sounds like you fixed your problem...are you now saying that if
    >> you reboot that fix does not persist?
    >>
    >> --
    >> solo

    >
    > Great Question!
    >
    > What i mean is when i first boot up and login non of the desktop icons
    > start. If i restart GNOME(ctrl + alt + bcksp) without rebooting the pc
    > it will work. It is just an inconvenience to restart gnome.


    AH! well, now that i understand your problem i wish i knew the way to
    fix it...

    hmmmm...i've not used Gnome in years but, if you right click on an
    empty spot on the desktop, does the resulting menu offer "Refresh
    Desktop" or something similar....if you do that do the icons pop up?
    does ANYthing change.

    how about if you go from one desktop to another?

    have you enabled desktop effects or compiz? what happens if you
    disable them?

    have you used the forum's advanced search and looked for "extension
    "RANDR" missing on display" *or* just RANDR and done that
    reading/understanding..

    when you entered
    suse "extension RANDR missing on display"
    into a google search, did you learn anything useful from the 1,240
    (english) hits?

    sorry i can't help more...but, by the way i don't even know what
    xinerama IS, so i obviously haven't had this problems and don't plan
    to read all those hits for you...but, maybe you will read enough that
    you understand enough to help yourself..

    for SURE you should read the 6 of the 7 hits from (one is yours, and
    you don't need to read it):
    suse xinerama "extension RANDR missing on display"

    good luck!!

    --
    solo
    Nothing happens if i right click on the desktop. It is as if it is frozen almost. No desktop effects or compiz. I have searched around before. I have not found the working solution yet. I will and have have continued to search around and/or hopefully someone post the solution here.

    Thanks again for your very useful input!

    James

  7. #7

    Default Re: Xinerama and Gnome

    Strange question but do you have 4 monitors?

    I ask this because your xorg has 4 monitors and most of this errors are caused by xinerama.

  8. #8

    Default Re: Xinerama and Gnome

    Quote Originally Posted by alexandremrj View Post
    Strange question but do you have 4 monitors?

    I ask this because your xorg has 4 monitors and most of this errors are caused by xinerama.
    Yes i do. My apologizes for not stating that. I am also running 2x 8800 Ultras.

    Thanks,
    James

  9. #9

    Default Re: Xinerama and Gnome

    I don't know if you already did it but I recommend two separate things:

    1. Run nvidia settings and when saving to X configuration file remove the check on "Merge with existing file" - do a backup of your Xorg config file. - That way you will have a clean xorg

    2. Remove the RANDR extension on your xorg - it will prevent the changing of resolution on the fly but at least we can try to see if the problem persists.

    All the best

    Alex

  10. #10

    Default Re: Xinerama and Gnome

    1. Tired that many times but, tries it again and still no go.

    2. I removed the X RandR parts from my x config file and still no go.

    When i type xrandr in xrandr in terminal it says:

    Code:
    Xlib:  extension "RANDR" missing on display ":0.0".
    RandR extension missing
    Alex thanks for your suggests and help

    James

    Latest xorg:

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildmeister@builder62)  Thu Feb  5 00:09:30 PST 2009
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 1680 1050
        Screen      1  "Screen1" 1680 0
        Screen      2  "Screen2" 0 0
        Screen      3  "Screen3" 0 1050
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
    EndSection
    
    Section "Files"
    EndSection
    
    Section "Module"
        Load           "dbe"
        Load           "extmod"
        Load           "type1"
        Load           "freetype"
        Load           "glx"
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "1"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 82.0
        VertRefresh     48.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor3"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 82.0
        VertRefresh     48.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 82.0
        VertRefresh     48.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Monitor"
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor2"
        VendorName     "Unknown"
        ModelName      "HP w2207"
        HorizSync       24.0 - 83.0
        VertRefresh     48.0 - 76.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:1:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device3"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:1:0:0"
        Screen          1
    EndSection
    
    Section "Device"
        Identifier     "Device1"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:5:0:0"
        Screen          0
    EndSection
    
    Section "Device"
        Identifier     "Device2"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8800 Ultra"
        BusID          "PCI:5:0:0"
        Screen          1
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP-0: 1680x1050 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen3"
        Device         "Device3"
        Monitor        "Monitor3"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "DFP-1"
        Option         "metamodes" "DFP-1: 1680x1050 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen1"
        Device         "Device1"
        Monitor        "Monitor1"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP-0: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    
    Section "Screen"
        Identifier     "Screen2"
        Device         "Device2"
        Monitor        "Monitor2"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "metamodes" "DFP-1: nvidia-auto-select +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •