Results 1 to 5 of 5

Thread: Help needed to install moto4lin

  1. #1
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Help needed to install moto4lin

    I'm trying to install moto4lin under opensuse 11.1 64bit but it complains about libusb, it needs v >=0.1.8.

    I used the one-click from the opensuse page, and tried several versions. Then tried to manually install it but all hell broke loose with missing stuff!

    Any help really appreciated, thanks

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Help needed to install moto4lin

    Are you doing manual install or from
    Webpin
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Help needed to install moto4lin

    Thanks for the reply caf.

    Sorry, I was in a bit of a rush this morning, hence the rather scant amount of information I gave!

    I tried to install it by using several one-clicks that I found at Software.openSUSE.org

    Then I simply downloaded the .rpm file (from several of those links) and tried to install it manually.

    Still the same errors.

    I tried each of those one-clicks on the page you gave me, and still get the error about libusb.

    I have included the following screenshots (hopefully!) that show what's going on.....


    Free Image Hosting by ImageBam.com

    After I get the first error message, I can only select "do not install", and then click on OK. Then the next box pops up asking to install those kernel modules. I cancel at that stage because I don't really know what those modules will do, and am a bit worried about messing with wireless modules as my wireless works really well as it is.

    I also searched in Yast2 for any packages with libusb in them, and tis is what I got......

    S | Name | Summary | Type
    --+---------------------+-------------------------------------------------+--------
    i | libusb-0_1-4 | USB Libraries | package
    i | libusb-0_1-4-32bit | USB Libraries | package
    | libusb-0_1-5 | libusb-1.0 Compatibility Library for libusb-0.1 | package
    i | libusb-1_0-0 | USB Library | package
    | libusb-1_0-0-32bit | USB Library | package
    | libusb-1_0-devel | USB Library | package
    | libusb-compat-devel | libusb-1.0 Compatibility Layer for libusb-0.1 | package
    | libusb-devel | USB Libraries | package
    | libusbpp-0_1-4 | USB Libraries | package
    | libusbprog0 | Programmer for the USBprog hardware | package


    Not too sure where to go from here though.

    Thanks

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Help needed to install moto4lin

    Did you check here for info - Otherwise I'm not sure.
    Main Page - Moto4Lin
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Jun 2008
    Location
    Kln, Deutschland
    Posts
    1,054

    Default Re: Help needed to install moto4lin

    Solved

    I simply installed in this order from the command line:

    sudo su
    rpm -i libp2kmoto0-0.1.svn20071112-11.4.x86_64.rpm
    rpm -i p2kmoto-0.1.svn20071112-11.4.x86_64.rpm
    rpm -i --nodeps moto4lin-0.3.svn20070127-18.1.un.x86_64.rpm


    That cured it

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •