Results 1 to 2 of 2

Thread: Need old glibc version

  1. #1

    Default Need old glibc version

    I'm installing an older application (Kohan from Loki) and it was developed for glibc 2.1. I've found information about updating it to the latest version and that all worked. However, it hangs while starting up. The solution people recommend is installing compat-glibc in a non-standard location, then launch the game pointing to that version of glibc.

    I'm running SUSE 11.1 (64-bit), and I'm wondering if there is another way around this problem. If so, how do I go about it? If not, how the heck do I install compat-glibc (I've found an RPM on rpmfind, but it's a .src.rpm, and I don't know how to do that.)?

  2. #2

    Default Re: Need old glibc version

    Here's the link to the source rpms I've found:
    RPM resource compat-glibc I've been trying to use the compat-glibc-6.2-2.1.3.2.src.rpm (1 from the bottom).

    When I try to rebuild it using "rpmbuild --rebuild compat-glibc-6.2-2.1.3.2.src.rpm", I get an error saying, "error: Legacy syntax is unsupported: copyright". So a bit of Googling led me to a link saying that I just need to change the word "copyright" in the SPECS file to "license". I did that, but now when I try to compile it using "rpmbuild -ba compat-glibc.spec", I get an error saying, "error: Architecture is not included: x86_64". Ok. I can fix that. I put x86_64 in the SPECS file under ExclusiveArch: section. No go. Apparently, glibc isn't set up to handle 64-bit. Ok. Next I added i586 to the ExclusiveArch: section.

    That went better. Using "linux32 rpmbuild -ba compat-glibc.spec" it started to compile, but then I got:
    Code:
    configure: error:
    *** Some critical program is missing or too old.
    *** Check the INSTALL file for required versions.
    error: Bad exit status from /var/tmp/rpm-tmp.14400 (%build)
    
    
    RPM build errors:
        Bad exit status from /var/tmp/rpm-tmp.14400 (%build)
    So now I'm stuck. I looked at the INSTALL file, but that didn't really give me any clues. I did find something saying that it is looking for kernel 2.2 headers. However, the way it is written, I don't know if they're talking about kernel 2.2 as if it's the latest and greatest thing at the time of the writing of the document (and thus a need to have newer headers than the kernel that is running on the reader's machine), or if they're talking about kernel 2.2 as if it is old (and thus a need to have those older headers running on the reader's machine that has a newer kernel). The difference that I can see is that perhaps it's looking for kernel 2.2 OR NEWER rather than specifically kernel 2.2.

    Anybody have any suggestions on how I can get more information on this error? It still baffles me how backwards compatibility is so hard to build in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •