I'm installing an older application (Kohan from Loki) and it was developed for glibc 2.1. I've found information about updating it to the latest version and that all worked. However, it hangs while starting up. The solution people recommend is installing compat-glibc in a non-standard location, then launch the game pointing to that version of glibc.

I'm running SUSE 11.1 (64-bit), and I'm wondering if there is another way around this problem. If so, how do I go about it? If not, how the heck do I install compat-glibc (I've found an RPM on rpmfind, but it's a .src.rpm, and I don't know how to do that.)?