Results 1 to 3 of 3

Thread: umbrello 4.2.1-47.11 won't start

  1. #1

    Default umbrello 4.2.1-47.11 won't start

    Hello there.

    After of installation of kde4-umbrello package from repository: Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1

    I can't open umbrello... So I try to see what is the output if I run it from shell:
    Code:
    umbrello(18054): Attempt to use QAction "edit_undo" with KXMLGUIFactory!
    umbrello(18054): Attempt to use QAction "edit_redo" with KXMLGUIFactory!
    umbrello(18054) UMLListView::findView: returning 0 at UMLListView::findView
    umbrello(18054) UMLListView::findView: returning 0 at UMLListView::findView
    I don't understand what those lines stands for... Does this have something to do with a KDE4? Should I report this as a bug?

  2. #2

    Default Re: umbrello 4.2.1-47.11 won't start

    So I've removed this version and installed

    v | kde4-umbrello | package | 4.2.1-47.14 | i586 | KDE:KDE4:Factoryesktop
    i | kde4-umbrello | package | 4.1.3-2.8 | i586 | openSUSE-11.1-Oss

    QT version is still 4.3.3

    umbrello -v
    Code:
    Qt: 4.4.3
    KDE: 4.2.1 (KDE 4.2.1) "release 103"
    Umbrello UML Modeller: 2.2.1
    Now the output is similar than previous one but program won't start:
    Code:
    umbrello(6043): Attempt to use QAction "edit_undo" with KXMLGUIFactory!
    umbrello(6043): Attempt to use QAction "edit_redo" with KXMLGUIFactory!
    umbrello(6043): Shortcut for KAction  "delete_selected" "Delete &Selected" set with QShortcut::setShortcut()! See KAction documentation.
    umbrello(6043): Shortcut for KAction  "move_tab_left" "&Move Tab Left" set with QShortcut::setShortcut()! See KAction documentation.
    umbrello(6043): Shortcut for KAction  "move_tab_right" "&Move Tab Right" set with QShortcut::setShortcut()! See KAction documentation.
    umbrello(6043): Shortcut for KAction  "previous_tab" "Select Diagram on Left" set with QShortcut::setShortcut()! See KAction documentation.
    umbrello(6043): Shortcut for KAction  "next_tab" "Select Diagram on Right" set with QShortcut::setShortcut()! See KAction documentation.
    umbrello(6043) UMLListView::findView: returning 0 at UMLListView::findView
    umbrello(6043) UMLListView::findView: returning 0 at UMLListView::findView
    Please help if you have any ideas since I really need this program

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: umbrello 4.2.1-47.11 won't start

    Try updating your qt packages. I got umbrello working fine.

    This is my output for umbrello -v

    Code:
    ian@linux-w78a:~> umbrello -v
    Qt: 4.5.0
    KDE: 4.2.1 (KDE 4.2.1) "release 108"
    Umbrello UML Modeller: 2.2.1
    Make sure you have the qt repository

    Index of /repositories/KDE:/Qt/openSUSE_11.1

    I know in my repositories it's not set up to auto-refresh so go to your software repositories and click Refresh>Refresh all enabled

    Then in Software Management click packages>all packages>Update if newer version available.

    Hope this helps!
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •