Results 1 to 7 of 7

Thread: Plasma Crash during game

  1. #1
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Unhappy Plasma Crash during game

    Well, I was playing that Blood Frontier game and I was getting frame rates of 40-50 fps.

    All of a sudden my screen just went pink and there were bars and stuff all over the screen.

    My laptop was nonresponsive so I shut it down by holding the power button down.

    Now whenever I try to use KDE 4.2.1 it tells me that plasma crashed. I can still use krunner and other programs but the screen is black and I have no background or panel.



    Since I have no panel my knetwork widget is gone so I can't connect to the internet. I'm using xfce right now.

    Any suggestions on how to fix this?
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  2. #2
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Plasma Crash during game

    replaced .kde folder...probably not the best solution but I kind of need this laptop for working right now.

    It really sucks that an install of KDE can be tanked as easily as playing a game. I wasn't messing around with anything, just playing a game. Oh well. You live and learn
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  3. #3
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Plasma Crash during game

    So..it happened again. I'm just not going to play games. At all. I'll use my windows side for that.

    Anyways, this is the output of trying to start plasma again.

    Code:
    ian@linux-w78a:~> plasma
    QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
    plasma(24444)/kdecore (KService) KServicePrivate::init: The desktop entry file  "/usr/share/kde4/services/sysinfo.protocol"  has Type= "Application"  but no Exec line                                                                          
    
    Object::connect: Attempt to bind non-signal TaskManager::TaskGroup::editRequest()                                                                               
    Object::connect: Attempt to bind non-signal TaskManager::TaskGroup::editRequest()                                                                               
    QCoreApplication::postEvent: Unexpected null receiver                           
    plasma(24444)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 25)                                                                               
    plasma(24444)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)                                                                                
    plasma(24444)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 25)                                                                               
    plasma(24444)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
    QGraphicsGridLayout::itemAt: invalid index 0
    QGraphicsGridLayout::itemAt: invalid index 2
    QGraphicsGridLayout::itemAt: invalid index 7
    KCrash: Application 'plasma' crashing...
    sock_file=/home/ian/.kde4/socket-linux-w78a/kdeinit4__0
    plasma(24443): Communication problem with  "plasma" , it probably crashed.
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "
    
    ian@linux-w78a:~> QLayout: Attempting to add QLayout "" to QWidget "", which already has a layout
    plasma(24469)/kdecore (KService) KServicePrivate::init: The desktop entry file"/usr/share/kde4/services/sysinfo.protocol"  has Type= "Application"  but no Exec line
    
    Object::connect: Attempt to bind non-signal TaskManager::TaskGroup::editRequest()
    Object::connect: Attempt to bind non-signal TaskManager::TaskGroup::editRequest()
    QCoreApplication::postEvent: Unexpected null receiver
    plasma(24469)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 25)
    plasma(24469)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
    plasma(24469)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 25)
    plasma(24469)/libplasma Plasma::FrameSvg::resizeFrame: Invalid size QSizeF(0, 0)
    QGraphicsGridLayout::itemAt: invalid index 0
    QGraphicsGridLayout::itemAt: invalid index 2
    QGraphicsGridLayout::itemAt: invalid index 7
    plasma(24465): Communication problem with  "plasma" , it probably crashed.
    Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "
    I would file a bug report, but the KDE Crash Handler says it's unable to create a backtrace.

    Now to kill .kde again...

    Any help would be appreciated.
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  4. #4

    Default Re: Plasma Crash during game

    I've got similar issue while ago. As you did, i've create a new .kde4 directory (in fact, you can achieve the same result by deleting plasma configuration file.)
    I suspected some new widgets to be the root cause of these crashes.
    So, you can start investigating this path: try to add widget one by one, play around with your computer some hours, delete the widget from your desktop and add another. This process could make you find the guilty widget (if your crashes are widget's related off course).
    Let us know if it helps.

    ps: my new desktop with minimalistic set of widgets do not crash anymore.

  5. #5
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Plasma Crash during game

    What is the path to the plasma configuration file?
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,163
    Blog Entries
    1

    Default Re: Plasma Crash during game

    The plasma applet file located here

    ~/.kde4/share/config/plasma-appletsrc

    I know others have removed this file, restarted the X-server with Ctrl+Alt+Backspace and all was well again.

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,723
    Blog Entries
    20

    Default Re: Plasma Crash during game

    You could try disabling desktop effects and see if the same happens.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •