I'm trying to compile Xulrunner with Python support, since the version in the repos doesn't seem to support it. I'm follow this guide. When I run 'make -f client.mk build' in step 4, I get the following message:

Code:
Adding client.mk options from /home2/lan_messenger/mozilla/.mozconfig:
    MOZ_OBJDIR=/home2/lan_messenger/mozilla/obj-xulrunner
    MOZ_BUILD_PROJECTS=xulrunner
    MOZ_CO_PROJECT=xulrunner
set -e; \
        for app in xulrunner; do \
          make -f /home2/lan_messenger/mozilla/client.mk build MOZ_CURRENT_PROJECT=$app; \
        done
make[1]: Entering directory `/home2/lan_messenger/mozilla'
Adding client.mk options from /home2/lan_messenger/mozilla/.mozconfig:
    MOZ_OBJDIR=/home2/lan_messenger/mozilla/obj-xulrunner
    MOZ_BUILD_PROJECTS=xulrunner
    MOZ_CO_PROJECT=xulrunner
make[2]: Entering directory `/home2/lan_messenger/mozilla'
cd /home2/lan_messenger/mozilla/obj-xulrunner/xulrunner
/home2/lan_messenger/mozilla/configure
Adding configure options from /home2/lan_messenger/mozilla/.mozconfig:
  disable-optimize
  enable-debug
  enable-application=xulrunner
  enable-default-toolkit=cairo-gtk2
  disable-javaxpcom
  enable-extensions=python,default
  enable-svg
  enable-xft
  disable-tests
configure: warning: disable-optimize: invalid host type
configure: warning: enable-debug: invalid host type
configure: error: can only configure for one host and one target at a time
*** Fix above errors and then restart with               "make -f client.mk build"
make[2]: *** [configure] Error 1
make[2]: Leaving directory `/home2/lan_messenger/mozilla'
make[1]: *** [/home2/lan_messenger/mozilla/obj-xulrunner/xulrunner/Makefile] Error 2
make[1]: Leaving directory `/home2/lan_messenger/mozilla'
make: *** [build] Error 2
I've done some searching, but I can't seem to find a solution. Any idea what I'm doing wrong here?

My ultimate goal is to build PyXPCOM, because the "python-xpcom190" package in the repo seems broken (I can't import xpcom.) All of the guides I've looked say/imply that a version of Xulrunner with Python support is needed to build it. (here and here)