Results 1 to 7 of 7

Thread: ffmpeg library problems

  1. #1

    Default ffmpeg library problems

    trying to install ffmpeg from packman on a 10.3 box. after wrestling with several library issues, i have one i can't resolve.

    ffmpeg -L
    ffmpeg: symbol lookup error: usr/lib64/libschroedinger-1.0.so.0: undefined symbol: oil_function_class_ptr_multiply_and_acc_8xn_s16_u8

    libschroedinger is installed.
    /usr/lib64> ls -l libschroedinger*
    lrwxrwxrwx 1 root root 28 2009-03-14 10:12 libschroedinger-1.0.so.0 -> libschroedinger-1.0.so.0.1.0
    -rwxr-xr-x 1 root root 531048 2008-10-05 09:48 libschroedinger-1.0.so.0.1.0

    any suggestions?

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: ffmpeg library problems

    Are you installing this manually or via Yast?

    What is the output of:

    zypper lr
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: ffmpeg library problems

    yast.

    zypper lr
    # | Enabled | Refresh | Type | Alias | Name
    --+---------+---------+--------+---------------------------------------------------------------------+--------------------------
    1 | Yes | Yes | yast2 | http://download.opensuse.org/reposit....3/standard/_1 | Main Repository (OSS)
    2 | No | No | yast2 | openSUSE-10.3-DVD 10.3 | openSUSE-10.3-DVD 10.3
    3 | No | No | rpm-md | Index of /pub/packman/suse/10.3 | Packman Repository
    4 | No | Yes | yast2 | Index of /distribution/10.3/repo/oss | Main Repository (OSS)
    5 | No | Yes | rpm-md | Index of /pub/videolan/vlc/SuSE/10.3/ | VideoLan Repository
    6 | Yes | Yes | rpm-md | Index of /update/10.3 | Main Update Repository
    7 | Yes | Yes | rpm-md | http://ftp.skynet.be/pub/packman/suse/10.3/_1 | Packman Repository
    8 | Yes | Yes | rpm-md | Index of /distribution/10.3/repo/src-oss/suse | Main Repository (Sources)

  4. #4
    Join Date
    Jun 2008
    Location
    Germany
    Posts
    301

    Default Re: ffmpeg library problems

    Hi,

    you also have to install liboil from packman repo (called liboil_03 or so).

    Hope this helps

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: ffmpeg library problems

    Check the versions tab in Packman



    You may need the Package I show there too.
    liboil, should come in automatically.

    Alway helpful to do 'update all unconditionally' in Packman.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6
    Join Date
    Jun 2008
    Location
    Frisco, TX
    Posts
    1,233

    Default Re: ffmpeg library problems

    ewhite20 wrote:
    > trying to install ffmpeg from packman on a 10.3 box. after wrestling
    > with several library issues, i have one i can't resolve.


    I know that under 11.1 packman ffmpeg has really bad dependencies... that is,
    it installs without what is needed. But eventually with clicking
    here and there... everything eventually worked for me.

  7. #7

    Default Re: ffmpeg library problems

    after running the 'update all' as caf4926 suggested and including videolan repo it is mostly working. some flash enabled sites that used to work now don't.
    the conversion from .flv to .mpg is very pixelated and jerky. so, there are some things still wrong.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •