Results 1 to 8 of 8

Thread: KDE4 turns 3D acceleration off

  1. #1

    Default KDE4 turns 3D acceleration off

    I've got a very strange problem. Recently I installed KDE 4.2 from the KDE4:Factory repository. I have the Nvidia 6600GT video card and Nvidia's drivers for it (version 180.29). When I log into KDE4 session all 3D applications work like there is no video card driver (extremely slow). glxgears gives ~2fps only! While in xfce4 it gives hundreds of fps (~800 with maximized window). KDE allows to turn desktop effects on and they work (not very smooth though). All other opengl applications are unusable. I have the same KDE packages installed on another machine with some integrated video card (intel?) and there's no such problem. Can someone tell me, what the hell is going on?

    BTW: I have opensuse 11.0 upgraded to 11.1.

  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: KDE4 turns 3D acceleration off

    Quote Originally Posted by knuckster View Post
    I've got a very strange problem. Recently I installed KDE 4.2 from the KDE4:Factory repository. I have the Nvidia 6600GT video card and Nvidia's drivers for it (version 180.29). When I log into KDE4 session all 3D applications work like there is no video card driver (extremely slow). glxgears gives ~2fps only! While in xfce4 it gives hundreds of fps (~800 with maximized window). KDE allows to turn desktop effects on and they work (not very smooth though). All other opengl applications are unusable. I have the same KDE packages installed on another machine with some integrated video card (intel?) and there's no such problem. Can someone tell me, what the hell is going on?

    BTW: I have opensuse 11.0 upgraded to 11.1.
    So, the nvidia driver was installed on 11.0. Did you recompile this driver, after updating to 11.1?
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3

    Default Re: KDE4 turns 3D acceleration off

    Quote Originally Posted by ram88 View Post
    So, the nvidia driver was installed on 11.0. Did you recompile this driver, after updating to 11.1?
    I installed (and then updated) this driver from Nvidia's repository as RPM package, so no (re)compilation is needed. The repository URL is http://download.nvidia.com/opensuse/11.1.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,396
    Blog Entries
    1

    Default Re: KDE4 turns 3D acceleration off

    So its all ok now?

  5. #5

    Default Re: KDE4 turns 3D acceleration off

    No! I installed the driver a long time ago, it worked and it works now (the driver itself). But every opengl application is very slow, when KDE is running. When running xfce for example, there's no such effect.
    PS: sorry for the emotions, I guess I didn't explained the situation clear enough (english is not my native language).

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,396
    Blog Entries
    1

    Default Re: KDE4 turns 3D acceleration off

    I don't have a definitive answer to this problem, but some answers to these questions may yield clues or enable others to help. Are you using compiz or kwin window manager? What version of KDE 4 are you using?

    FYI, I have an ATI graphics chipset with fglrx driver installed, and I find KDE 4.2 with compiz sluggish. I have reverted to kwin.

    Anyone else able to help here?

  7. #7

    Default Re: KDE4 turns 3D acceleration off

    I use kwin. KDE version is 4.2.1 (from KDE:Factory repository), qt 4.4.3 (4.5.0 had some problems with non-latin characters in file paths, when I tried it a week ago). The same packages on another machine work just fine. The only difference is a video adapter.

  8. #8
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,396
    Blog Entries
    1

    Default Re: KDE4 turns 3D acceleration off

    Similar thread:

    [kubuntu] Slow KDE With pathetic compatibility with Nvidia 8800 GT and Compiz [Archive] - Ubuntu Forums

    You may need to search outside of forum for more info. There may be a specific nvidia driver version that offers better results.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •