Results 1 to 8 of 8

Thread: Cannot activate emerald

  1. #1
    Join Date
    Dec 2008
    Location
    Houston
    Posts
    57

    Default Cannot activate emerald

    I am running 11.1 and compiz is running well, but I can't get emerald to activate. The only thing I have read on the subject is to be sure that it's set as your window decorator but there isn't anything distro specific. Any advice would be greatly appreciated.

  2. #2

    Default Re: Cannot activate emerald

    How about running it in a terminal with the command,
    emerald --replace, have you already tried it?
    People who do not break things first will never learn to create anything

  3. #3
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,005
    Blog Entries
    1

    Default Re: Cannot activate emerald

    I am running 11.1 and compiz is running well, but I can't get emerald to activate. The only thing I have read on the subject is to be sure that it's set as your window decorator but there isn't anything distro specific. Any advice would be greatly appreciated.
    I recently upgraded to KDE 4.2.1 desktop with openSUSE11.0 and briefly tried compiz with emerald (window decorator) enabled. Although the end-result looked nice, I couldn't get it to stick. Everytime I restarted the DE, I need to re-enable emerald.

    I have also heard that support for emerald has stopped, so in the end I decided to live without it and removed the emerald packages. I also reverted to kwin window manager. I'm not sure that compiz provides any advantages over kwin with respect to KDE 4 environment. Maybe others can enlighten me here.

  4. #4
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Default Re: Cannot activate emerald

    In order to get emerald to work with my computer (KDE 4.2.1 "108") I had to use the fusion-icon to change my window manager to Compiz and then change the window decorator to Emerald.

    I did this first.

    Then I would go into Configure Desktop (Personal Settings) and under Personal click Default Applications. Then choose Windows Manager and switch it to Compiz.

    If I didn't enable emerald with the fusion-icon first then when I chose Compiz through Default Applications only compiz would load, not emerald.

    I didn't have to do this everytime though, only the first time to set it up. It works fine on my computer now.

    Hope this helps!
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,005
    Blog Entries
    1

    Default Re: Cannot activate emerald

    Thats the process I followed, but for some reason I needed re-enable it each time.

  6. #6

    Default Re: Cannot activate emerald

    I think the fusion icon has to be set to autostart in kde 4.x. that's what I did before when I was using it if memory serves, but since the kde 4.x kwin is capable of doing almost the same as compiz if not 100% but stable I stop using compiz. I prefer to not auto-start those effects, I just create a luncher in the panel and use it whenever I feel using it.
    People who do not break things first will never learn to create anything

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,005
    Blog Entries
    1

    Default Re: Cannot activate emerald

    but since the kde 4.x kwin is capable of doing almost the same as compiz if not 100% but stable I stop using compiz.
    Thats the way I feel too. However, I hope that the kde-window-decorator is developed a little more. I like the Oxygen theme (with default colours and fonts), but I would like to set the colour of the title-bar only (similar to crimson colour of beryl-default). I haven't found a way to do this yet.

  8. #8
    Join Date
    Dec 2008
    Location
    Houston
    Posts
    57

    Default Re: Cannot activate emerald

    Something I forgot to mention is that I have Gnome instead of KDE which has pretty boring window deocrations. I tried adding the fusion icon but that didn't do much for me and when I run emerald from a terminal, it either does nothing or removes all window borders completely until I logout and go back in.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •