I'm using kde 4.1.3 on openSUSE 11.1 64 bits on a laptop. Since last week, the session randomly locks (the screen become black and I need to insert my user password to un-lock it) with a notification from the power manager saying that the screen is locked.
I tried removing the kde4 folder and for some days everything went ok, but everything restarted again. Someone suggest me to stop krunner, and doing so the lock stop, but I still get the notifications. Looking another thread with plasma problems on kde forums, I issued the following commands:
kquitapp krunner
ps aux | grep krunner
krunner &

and this is the result:
kquitapp krunner
~> ps aux | grep krunner
myuser 6831 0.1 1.4 415944 29964 ? Sl 13:22 0:03 krunner
myuser 7224 0.0 0.0 16116 1000 pts/2 S+ 14:17 0:00 grep krunner
~> krunner &
[1] 7227
[here it is when the problem occurs]~> X Error: BadAccess (attempt to access private resource denied) 10
Major opcode: 2 (X_ChangeWindowAttributes)
Resource id: 0x4200006
krunner_lock(7240) KxkbCore::settingsRead: Kxkb is disabled, exiting...


If I run a program using krunner (in this case, kwrite), I get

findServiceByDesktopPath: not found
Object::connect: No such slot PowerDevilRunner::updateStatus()()
Object::connect: (sender name: 'KDirWatch-2')
Object::connect: (receiver name: 'PowerDevil')
Object::connect: No such slot PowerDevilRunner::updateStatus()()
Object::connect: (sender name: 'KDirWatch-2')
Object::connect: (receiver name: 'PowerDevil')
Object::connect: No such slot PowerDevilRunner::updateStatus()()
Object::connect: (sender name: 'KDirWatch-2')
Object::connect: (receiver name: 'PowerDevil')
findServiceByDesktopPath: not found


When the problem occurs again (and again, and again... only the Resource id change):

[1]+ Done krunner
~>
~> X Error: BadAccess (attempt to access private resource denied) 10
Major opcode: 2 (X_ChangeWindowAttributes)
Resource id: 0x4400006
krunner_lock(7262) KxkbCore::settingsRead: Kxkb is disabled, exiting...


It does not happens all the time. Some days everything is ok but other days is almost impossible to work, specially when running with batteries: instead of a locked screen, I get a warning that suspend to ram will be performed in 10 seconds... something is wrong with the openSUSE's powerdevil backport, I guess... but everything went without problems for two months! Why all this mess now?
Need I upgrade to kde 4.2.1? I don't like factory repos...
Thanks