Results 1 to 7 of 7

Thread: LyX 1.6 PDF generation fails

  1. #1
    catlord17 NNTP User

    Default LyX 1.6 PDF generation fails

    Hi, everybody, I am a new user to openSUSE but long time linux user. I used to be the "under the hood geek" type, and then I started a business and ever since I have been more interested in getting work done. I am fairly knowledgeable about linux, but no expert.

    I was on PCLinuxOS since their 0.92 release, and it was great except the 2008 to 2009 release has things in a bit of a catch 22 for me regarding getting my CD burner to work, which I need for business, so I started looking at other distros and openSUSE seems the best choice for long term viability. So here I am. This is the first time I have ever tried any SUSE really.

    I have managed to figure out everything different so far, but I am setting up for work and have the problem that after installing LyX (in which I write books), I can generate a DVI, but not PDF or PS. I used the package manager to be able to install LyX, naturally, and I of course did a search for answers before posting here on the forum, but what little I found did not answer my questions. I had this same problem once with the 1.5.x series but the solution suggested in the second to last post in this thread fixed it; no such luck with 1.6.

    lyx 1.6 support - openSUSE Forums

    This is a simple problem, I'm sure, but a showstopper for me if I can't get this fixed. I need to be able to generate .pdf files of my book manuscripts.

    I appreciate whatever help you can give me, and thank you in advance.

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,431

    Default Re: LyX 1.6 PDF generation fails

    Check that pdflatex is installed on your system (it should be). Then try and display something short using pdflatex and select Documents>LaTeX log and see if you can find a clue there.

    Try File>Export>PDF (pdflatex) and do the same
    Last edited by john_hudson; 09-Mar-2009 at 15:46. Reason: Additional comment

  3. #3
    catlord17 NNTP User

    Default Re: LyX 1.6 PDF generation fails

    Quote Originally Posted by john_hudson View Post
    Check that pdflatex is installed on your system (it should be). Then try and display something short using pdflatex and select Documents>LaTeX log and see if you can find a clue there.

    Try File>Export>PDF (pdflatex) and do the same
    Thanks for your reply.

    I am in the software installation tool and a search for "pdflatex" turns up no results...

    Searching for "latex" results in a nice list, but nothing indicating "pdflatex"...

    and searching for "pdf" also returns a nice list of programs, but nothing about "pdflatex".

    That seems to make perfect sense for why it's not producing PDF output! This is from the software manager... I suppose this means I am missing repositories or something? Not sure how to proceed from here... I'm used to Synaptic.

  4. #4
    catlord17 NNTP User

    Default Re: LyX 1.6 PDF generation fails

    I have added community repositories that seemed to make sense to add, but still pdflatex is not showing.

  5. #5
    Join Date
    Oct 2008
    Location
    mexico cityx
    Posts
    81

    Default Re: LyX 1.6 PDF generation fails

    Type in a terminal

    Code:
    whereis pdflatex
    and see if it finds it (this will work only if you have /usr/bin in your PATH, but I think it is by default). If you find it, then that's obviously not the problem...

    Have you installed all the latex packages? That might be the problem, although I'm not sure whether you would be able to make a dvi without these, so its unclear if that's the problem.

    My advice: uninstall Lyx, and compile it yourself. That way you will make sure that everything needed gets installed (otherwise you won't be able to compile it).

    I just checked the Latex packages I have installed: texlive-bin-latex and texlive-latex. Do you have these installed?

    I'm a huge Lyx fan by the way
    why do people open source?

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,431

    Default Re: LyX 1.6 PDF generation fails

    As pdflatex is a standard part of texlive, did you install LyX using YaST because it would have made sure you had everything you needed?

    As I recently installed everything on a new machine, I know that simply entering LyX in YaST gets you everything you need (all 850Mb of it).

  7. #7
    catlord17 NNTP User

    Default Re: LyX 1.6 PDF generation fails

    469.17 mb of data gets installed when I select LyX. I had a friend suggest that I the problem is that there is no viewer installed, or that it is not set to a valid viewer... he runs Mint, and said that it defaults to kpdf, but he had to install xpdf and xpdf-tools, and then set it from a viewer of kpdf to xpdf.

    This is supported by the following:

    Code:
    shannon@linux-ugfk:~> whereis pdflatex
    pdflatex: /usr/bin/pdflatex /usr/bin/X11/pdflatex /usr/share/man/man1/pdflatex.1.gz
    shannon@linux-ugfk:~>
    Upon attempting to install xpdf or xpdf-tools, I get a package conflict with poppler and poppler-tools. I tried using "poppler" instead of "kpdf" in the viewer specifcation, but still no dice... then I did a search for "pdf" using the software manager and searched through the file lists for various programs installed with LyX, finding no file named "poppler"...

    So, I looked through various packages that were not installed, and the package for kdegraphics3-pdf had kpdf in it and very few dependencies. I installed it, and voila. Problem solved.

    In any event, thanks for the help. I am running the 64 bit version, maybe that accounts for the little snag?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •