Results 1 to 4 of 4

Thread: gcc 4.3 on opensuse 10.3

  1. #1
    peachh NNTP User

    Default gcc 4.3 on opensuse 10.3

    Is it possible to install gcc 4.3 on opensuse 10.3? From the 10.3 software repository i can download only gcc 4.2.
    I also tried to set up the 11.1 software repository in yast because in the 11.1 repo there is the newest gcc, but it gives an error message and I can not access to the repo. So is it possible to download files from a newer repository (11.1)if I have an older distribution (10.3)? As I see there is different repositories for different distributions but I do not understand why is this needed.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,286
    Blog Entries
    15

    Default Re: gcc 4.3 on opensuse 10.3

    Quote Originally Posted by peachh
    Is it possible to install gcc 4.3 on opensuse 10.3? From the 10.3
    software repository i can download only gcc 4.2.
    I also tried to set up the 11.1 software repository in yast because in
    the 11.1 repo there is the newest gcc, but it gives an error message and
    I can not access to the repo. So is it possible to download files from a
    newer repository (11.1)if I have an older distribution (10.3)? As I see
    there is different repositories for different distributions but I do not
    understand why is this needed.
    Hi
    Have a look at adding this repository;
    <http://download.opensuse.org/repositories/devel:/gcc/openSUSE_10.3>

    You can always search here as well;
    Get It

    --
    Cheers Malcolm (Linux Counter #276890)
    SUSE Linux Enterprise Desktop 11 (i586) Kernel 2.6.27.15-2-default
    up 2 days 21:20, 1 user, load average: 0.49, 0.34, 0.20
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.35


  3. #3
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,431

    Default Re: gcc 4.3 on opensuse 10.3

    Quote Originally Posted by peachh View Post
    As I see there is different repositories for different distributions but I do not understand why is this needed.
    Because the kernel and the libraries are updated between each distribution.

  4. #4
    peachh NNTP User

    Default Re: gcc 4.3 on opensuse 10.3

    Thank you, this works!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •