Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Amarok 2 installation asking for a lot to be downgraded

  1. #1

    Default Amarok 2 installation asking for a lot to be downgraded

    I have recently installed KDE4.2. After that when I try to install Amarok 2, Yast is asking for a lot of packages to be downgraded. Can any one tell me what will that mean?

    Any help will greatly appreciated...



  2. #2
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    Quote Originally Posted by vendetta18 View Post
    I have recently installed KDE4.2. After that when I try to install Amarok 2, Yast is asking for a lot of packages to be downgraded. Can any one tell me what will that mean?

    Any help will greatly appreciated...


    As the installer says, Amarok needs older version of kdebase4-runtime, and if you downgrade this package, the other kde4 packages will be also downgraded.
    The latest amarok in the factory repo
    Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1/i586
    is kde4-amarok-2.0.2-24.2.i586.rpm. If you are using factory repositories, then run
    Code:
    sudo zypper refresh
    in terminal, and after try to upgrade your Amarok.
    Good luck.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  3. #3

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    Quote Originally Posted by ram88 View Post
    As the installer says, Amarok needs older version of kdebase4-runtime, and if you downgrade this package, the other kde4 packages will be also downgraded.
    The latest amarok in the factory repo
    Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1/i586
    is kde4-amarok-2.0.2-24.2.i586.rpm. If you are using factory repositories, then run
    Code:
    sudo zypper refresh
    in terminal, and after try to upgrade your Amarok.
    Good luck.
    I have already added that rep in Yast. Did a refresh but still the problem is there. Am I the only one who is facing this?

  4. #4

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    Actually, I am having the same problem with installation of KDE4-K3B. Am I missing something....

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,583
    Blog Entries
    14

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    In the software-installer you have the option to check the version numbers. You probably try to install the Amarok/k3B versions meant for KDE4 4.1.3. If you pick the proper version in the software-installer, it'll set the status of the package concerned to "update", download the package and install it.
    IMHO this should not have to happen. KDE4-packages update fine using version numbers, Amarok is not following the KDE-numbering, so once in a while packages for older KDE versions seem to be upgrades........
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,719
    Blog Entries
    20

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    Quote Originally Posted by vendetta18 View Post
    I have recently installed KDE4.2. After that when I try to install Amarok 2, Yast is asking for a lot of packages to be downgraded. Can any one tell me what will that mean?

    Any help will greatly appreciated...


    I can't see all the dependency error from this shot, save it to file from the expert button in the error window. And post here.
    Leap 15_KDE
    My Articles Was I any help? If yes: Click the star below

  7. #7

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    #### YaST2 conflicts list - generated 2009-03-09 20:07:14 ####

    kde4-amarok-2.0.1.1-2.1.1.i586 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    uninstallable providers: kdebase4-runtime-4.1.3-72.11.i586[KDE4Desktop]
    kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
    [ ] do not install kde4-amarok-2.0.1.1-2.1.1.i586

    [ ] Following actions will be done:
    downgrade of kdebase4-runtime-4.2.1-82.2.i586 to kdebase4-runtime-4.1.3-72.11.i586
    downgrade of kdebase4-workspace-4.2.1-3.2.i586 to kdebase4-workspace-4.1.3-172.3.i586
    downgrade of kdenetwork4-filesharing-4.2.1-63.6.i586 to kdenetwork4-filesharing-4.1.3-49.7.i586
    downgrade of kde4-kget-4.2.1-63.6.i586 to kde4-kget-4.1.3-49.7.i586
    downgrade of kde4-akregator-4.2.1-97.2.i586 to kde4-akregator-4.1.3-86.10.i586
    downgrade of kde4-gwenview-4.2.1-78.4.i586 to kde4-gwenview-4.1.3-62.12.i586
    downgrade of kde4-ark-4.2.1-50.10.i586 to kde4-ark-4.1.3-35.25.i586
    downgrade of kde4-dolphin-4.2.1-74.4.i586 to kde4-dolphin-4.1.3-62.15.i586
    downgrade of kde4-kcalc-4.2.1-50.10.i586 to kde4-kcalc-4.1.3-35.25.i586
    downgrade of kde4-kcolorchooser-4.2.1-78.4.i586 to kde4-kcolorchooser-4.1.3-62.12.i586
    downgrade of kde4-kdepasswd-4.2.1-74.4.i586 to kde4-kdepasswd-4.1.3-62.15.i586
    downgrade of kde4-kdialog-4.2.1-74.4.i586 to kde4-kdialog-4.1.3-62.15.i586
    downgrade of kde4-kdnssd-4.2.1-63.6.i586 to kde4-kdnssd-4.1.3-49.7.i586
    downgrade of kde4-keditbookmarks-4.2.1-74.4.i586 to kde4-keditbookmarks-4.1.3-62.15.i586
    downgrade of kde4-kerry-0.2.90-8.46.i586 to kde4-kerry-0.2.90-1.21.i586
    downgrade of kde4-kfind-4.2.1-74.4.i586 to kde4-kfind-4.1.3-62.15.i586
    downgrade of kde4-kgamma-4.2.1-78.4.i586 to kde4-kgamma-4.1.3-62.12.i586
    downgrade of kde4-kgpg-4.2.1-50.10.i586 to kde4-kgpg-4.1.3-35.25.i586
    downgrade of kde4-kgreeter-plugins-4.2.1-3.2.i586 to kde4-kgreeter-plugins-4.1.3-172.3.i586
    downgrade of kde4-kio_kamera-4.2.1-78.4.i586 to kde4-kio_kamera-4.1.3-62.12.i586
    downgrade of kde4-kio_sysinfo-11.1.1-68.29.i586 to kde4-kio_sysinfo-11.1-83.13.i586
    downgrade of kde4-kmix-4.2.1-43.4.i586 to kde4-kmix-4.1.3-37.24.i586
    downgrade of kde4-knotes-4.2.1-97.2.i586 to kde4-knotes-4.1.3-86.10.i586
    downgrade of kde4-konqueror-plugins-4.2.0-39.40.i586 to kde4-konqueror-plugins-4.1.3-28.34.i586
    downgrade of kde4-konqueror-4.2.1-74.4.i586 to kde4-konqueror-4.1.3-62.15.i586
    downgrade of kde4-konsole-4.2.1-74.4.i586 to kde4-konsole-4.1.3-62.15.i586
    downgrade of kde4-marble-4.2.1-53.2.i586 to kde4-marble-4.1.3-38.33.i586
    downgrade of kde4-kwrite-4.2.1-74.4.i586 to kde4-kwrite-4.1.3-62.15.i586
    downgrade of kde4-kwalletmanager-4.2.1-50.10.i586 to kde4-kwalletmanager-4.1.3-35.25.i586
    downgrade of kde4-kwin-4.2.1-3.2.i586 to kde4-kwin-4.1.3-172.3.i586
    downgrade of kde4-okular-4.2.1-78.4.i586 to kde4-okular-4.1.3-62.12.i586
    downgrade of kde4-plasma-addons-4.2.1-57.5.i586 to kde4-plasma-addons-4.1.3-42.37.i586
    downgrade of kdebase4-4.2.1-74.4.i586 to kdebase4-4.1.3-62.15.i586
    downgrade of kdebase4-session-4.2.1-32.9.i586 to kdebase4-session-4.1.3-26.4.i586
    downgrade of kdebase4-nsplugin-4.2.1-74.4.i586 to kdebase4-nsplugin-4.1.3-62.15.i586
    downgrade of kdebase4-libkonq-4.2.1-74.4.i586 to kdebase4-libkonq-4.1.3-62.15.i586
    downgrade of kdepimlibs4-4.2.1-70.2.i586 to kdepimlibs4-4.1.3-13.12.i586
    downgrade of libakonadi4-4.2.1-70.2.i586 to libakonadi4-4.1.3-13.12.i586
    downgrade of libkdepim4-4.2.1-97.2.i586 to libkdepim4-4.1.3-86.10.i586
    downgrade of libkdepimlibs4-4.2.1-70.2.i586 to libkdepimlibs4-4.1.3-13.12.i586
    downgrade of libkonq5-4.2.1-74.4.i586 to libkonq5-4.1.3-62.15.i586
    [ ] Ignore some dependencies of kde4-amarok




    #### YaST2 conflicts list END ###
    ------------------------------------------------------------------------------------------------
    Hope this will help...

  8. #8

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    Quote Originally Posted by Knurpht View Post
    In the software-installer you have the option to check the version numbers. You probably try to install the Amarok/k3B versions meant for KDE4 4.1.3. If you pick the proper version in the software-installer, it'll set the status of the package concerned to "update", download the package and install it.
    IMHO this should not have to happen. KDE4-packages update fine using version numbers, Amarok is not following the KDE-numbering, so once in a while packages for older KDE versions seem to be upgrades........
    I am installing
    kde4-amarok-2.0.1.1-2.1.1, and I think it is meant for KDE4.2

    Actually I am facing a lot of problems with Amarok2. It is not installing properly,When it does it is not working at all. I am not that much of a techie to debug it on my own so hoping that someone will come and rescue me, like every time I face a problem

  9. #9

    Default Re: Amarok 2 installation asking for a lot to be downgraded

    <snip>I am not that much of a techie to debug it on my own <snip>

    May I ask why you're playing with factory then?

    From the looks of things amarok depends on < 4.1.60
    kdebase4-runtime-4.1.3-72.11.i586[KDE4Desktop] has this one,
    kdebase4-runtime-4.1.3-4.1.i586[repo-oss] has this one.

    Now you have installed, kdebase4-runtime-4.2.1-82.2.i586 which is greater < 4.1.60

    For what ever reason it seems to it isn't detecting that you have a later version now I suspect it is either a mess of a repo list(Too many added with out thought)

    Or factory is in a state of flux, that is the problem with enabling development repo's things change quickly, things get fixed, things get broken, and things may even be being changed as you try to update.
    Man first, have a try at Info, have a look at Wiki, if all that fails Scroogle!!!!!
    If I've helped click on the Rep button I don't know what it does but it sounds cool.

  10. #10
    Join Date
    Jan 2009
    Location
    USA Pennsylvania
    Posts
    1,287

    Smile Re: Amarok 2 installation asking for a lot to be downgraded

    As stated before, when you're in Yast Software Management, you'll need to choose Amarok from the KDE4 factory repos (kde4-amarok-2.0.2-24.2-i586)



    The version you are installing (kde4-amarok-2.0.1.1-2.1.1) is from the update repos and is for KDE 4.1.3. Hence, you get all those dependency issues telling you to downgrade.

    Hope this helps!
    Laptop: Dell Inspiron E1505 | OpenSUSE 12.1/Windows Vista | KDE | Intel CPU T2050 1.6 GHz | Intel 945GM | 3.2GB RAM
    Box: OpenSUSE 12.1/Windows 7 | KDE | Intel Core 2 Quad 8300 2.5GHz/core | nVidia Geforce 9500GT 1GB| 4 GB RAM

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •