Results 1 to 4 of 4

Thread: Linux kernel update conflict: ati-fglrx and kernel(pae:mm)

  1. #1

    Unhappy Linux kernel update conflict: ati-fglrx and kernel(pae:mm)

    I'm running an ATI HD 3650 AGP (RV 635 3596) (3D has been working fine) with a 2.6.27.7-9-pae kernel, and recently upgraded to KDE 4.2.1.

    For at least the last few days the Online Updater has been asking to install a kernel patch, which is described as:

    "This update fixes several security issues and hundreds of bugs in the openSUSE 11.1 kernel. The kernel was also updated to the stable version 2.6.27.19 and is now the same kernel as we are planning to ship with SUSE Linux Enterprise 11. This introduces kABI changes, so all kernel module packages also need to be rebuilt and reapplied. Following security issues are fixed:" CVE-2009-0029, CVE-2008-5079, and CVE-2009-0028.

    Agreeing to this, I get the following conflict:

    #### YaST2 conflicts list - generated 2009-03-07 09:43:46 ####

    ati-fglrxG01-kmp-pae-8.561_2.6.27.7_9.1-1.1.i586 requires kernel(pae:mm) = b853ab28d43f4e8e, but this requirement cannot be provided

    [ ] Following actions will be done:
    deinstallation of ati-fglrxG01-kmp-pae-8.561_2.6.27.7_9.1-1.1.i586
    deinstallation of x11-video-fglrxG01-8.561-1.1.i586
    [ ] do not install patch:kernel-559.noarch

    [ ] Ignore some dependencies of ati-fglrxG01-kmp-pae

    #### YaST2 conflicts list END ###

    Since it's the kernel, I have been deferring the patch. But does anyone know whether I should accept any one of these options?

    If not, what should I do to resolve this?

    The potentially relevant forum posts seem to indicate that manually installing the ATI (non-openSUSE) driver would be the answer, but other posts suggest that bot the ati and x11 drivers are part of the patch and that I should select "deinstall" in order to proceed with the patch.

    Please advise,
    intelligo

  2. #2

    Default Re: Linux kernel update conflict: ati-fglrx and kernel(pae:m

    Well first you should go to ati's site and get the ati driver.

    Next install the kernel update ignoring dependencies.

    Next install the ati driver ( the dri module has to be rebuilt because the kernel has changed). As you are already running the ati driver there should be no need to configure it.

    You should be good to go now.

  3. #3
    XuebiX NNTP User

    Default Re: Linux kernel update conflict: ati-fglrx and kernel(pae:m

    cool, ill give this a go, ive only just installed 11.1, and have been doing the updates after install then trying to do the 1click ati install but it was installing the debug kernel.

    so 3 reinstalls later i find this thanks

  4. #4
    XuebiX NNTP User

    Default Re: Linux kernel update conflict: ati-fglrx and kernel(pae:m

    works, but i didnt have all the required packages installed,
    so i ended up with the driver not compiling, just make sure you have the following packages installed:

    * kernel-source
    * qt3
    * compat
    * libstdc++
    * libstdc++-devel
    * libgcc
    * xorg-x11-libs
    * xorg-x11-devel
    * Mesa
    * Mesa-devel
    * fontconfig
    * fontconfig-devel
    * expat
    * freetype
    * freetype2
    * freetype2-devel
    * zlib
    * zlib-devel
    * gcc
    * patch
    #source:ATI - openSUSE

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •