Results 1 to 8 of 8

Thread: OpenOffice updates

  1. #1

    Default OpenOffice updates

    Hi: Are the KDE extensions for 3.0.9 now included in the latest OO updates or have they simply not been updated to the latest versions? They won't install on the the latest OO - dependencies I guess. Regards, John

  2. #2
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,537

    Default Re: OpenOffice updates

    According to the list from the 3.0.1 repository, there are KDE extensions for this version.

    They aren't installed with 1-click install but they are listed in Software Management after you have installed.

    I suggest you remove as much of the earlier version as possible before installing 3.0.1 which is based on the Go-OO version.

  3. #3

    Default Re: OpenOffice updates

    Thanks for your reply. When updating using yast, I notice that although I have 3.0.1.2-3.6 installed, the extensions, for example, Impress extensions, are at 3.0.0.9-1.11 and of course these do not install on the 3.0.1 version. So where do I actually find the updated extensions using yast? I'm using the following url: Index of /repositories/OpenOffice.org:/STABLE/openSUSE_Factory

    Appreciate the help. John

  4. #4
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,537

    Default Re: OpenOffice updates

    Before installing any 3.0.1 packages, I deleted all 3.0.0.9 packages as they come from a different development stream.

  5. #5

    Default Re: OpenOffice updates

    Hi: thanks for your reply. However, I didn't install 3.0.0.9 in the first place. When I first installed openSUSE 11.1, I didn't check openOffice so it shouldn't have installed. I then went straight to the repositories in order to get the latest stable version (3.0.1.2). 3.0.0.9 shows as available but not installed.

    The latest extensions (3.0.1.2) tell me they need version 3.0.0.9 of OO so I'm a little confused - should I uninstall 3.0.1.2 and start over with 3.0.0.9? Many thanks. John

  6. #6
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,537

    Default Re: OpenOffice updates

    I'm slightly puzzled because I have checked what has been installed on my setup and not a single 3.0.0.9 file has been installed; they all have either 3.0.1 or an earlier number; the 3.0.0.9 files are there but when I selected the base 3.0.1 components, writer, calc, impress, base plus localisation, I wasn't told I needed any of the 3.0.0.9 files as well.

    I'm not aware that I'm missing anything.

  7. #7

    Default Re: OpenOffice updates

    Thanks again. Just so I'm clear, I'm updating using yast via the openSUSE repositories relating to OO. Is there another repository for OO I should be using?

    As a final thought, would it be useful to simply uninstall my present OO setup and reinstall from the repositories - I've made no customisations or anything so it wouldn't be a big problem. If that seems like a reasonable course of action, what is the key repo I should be using for OO - again, just so I'm sure?

    Sorry to flog this a bit but I do appreciate your help. John

  8. #8
    Join Date
    Jun 2008
    Location
    West Yorkshire, UK
    Posts
    3,537

    Default Re: OpenOffice updates

    I used Software Management to delete all the existing OO packages. As you have to click through Update to get to Delete you tend to get warning messages which I just cancelled and, of course, you get warning messages every time you Delete something from OO on which something else you have yet to delete relies. At the end there were a couple of libraries that it insisted I had to keep which I did.

    I then went to Online update and opened the OO repository from which I selected the 3.0.1 packages I wanted and it added the other ones I needed.

    It all took some time but I thought it was worthwhile as 3.0.1 comes from Go-OO rather than Sun and so I wanted to avoid potential conflicts. Whether I was being too cautious I don't know but it worked for me!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •