Results 1 to 9 of 9

Thread: A fix for Start Numlock on KDE startup in 4.2.1 release108

  1. #1
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,162

    Default A fix for Start Numlock on KDE startup in 4.2.1 release108

    The latest update for KDE4.2.1 release108 has eliminated the Start Numlock on KDE start up in the Configure desktop Keyboard and Mouse.
    If you like to have your Num Lock on at start up here'e a how to:
    1. Kmenu>Configure Desktop>Advanced Tab
    2.Click Autostart
    3.Click the Add Script Button Then click the icon to the right of script bar
    4.There will be a box with all your folders show up under the places pane select Root
    5.Open the usr folder, then open the bin folder find then select numlockx
    6.Click OK then another box will come up Click OK on that one
    If all has gone well in the Autostart System Settings You should have a line that will look like this:

    See the line
    numlockx /usr/bin/n...
    That's what you should have if all went well. Now if you shutdown your PC at night or day as the case maybe. When you turn your PC back on your Num Lock will start up when KDE does.
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  2. #2
    Join Date
    Sep 2008
    Location
    Germany
    Posts
    7

    Default Re: A fix for Start Numlock on KDE startup in 4.2.1 release1

    thank you for this workaround it works great.
    openSUSE 11.1 (x86_64)Linux 2.6.27.19-3.2-default x86_64 4.2.1 (KDE 4.2.1) "release 103"
    Mainboard: Intel DP43TF Intel(R) Core(TM)2 Duo CPU E8400 @ 3.00GHz 2x2GB PC 800
    ATI Radeon HD 4800 Series Driver: 2.1.8494 Release
    Sound: HDA Intel, USB Audio

  3. #3
    Join Date
    Mar 2008
    Location
    Oz
    Posts
    11,727
    Blog Entries
    2

    Default Re: A fix for Start Numlock on KDE startup in 4.2.1 release1

    Good one Sagemta
    Leap 42.3 & 15.1(Beta) &KDE
    FYIs from the days of yore

  4. #4
    Join Date
    Jun 2008
    Location
    relative
    Posts
    1,172

    Default Re: A fix for Start Numlock on KDE startup in 4.2.1 release1

    Thank you!
    I liked it to my thread in KDE forums.
    http://mydailyhash.wordpress.com/
    http://yami.googlecode.com/

  5. #5
    Join Date
    Jun 2008
    Location
    where I am is where I am
    Posts
    1,162

    Default Re: A fix for Start Numlock on KDE startup in 4.2.1 release1

    Thanks swerdna,ram88,
    That means a lot to me.
    We are what we think.
    All that we are arises with our thoughts.
    With our thoughts we make the world.

    My 64 bit: Gateway 5670 UPDATED | RADEON RX 570 |CPU AMD - Ryzen 5 1600
    Opensuse Tumbleweed Plasma 5

  6. #6
    Join Date
    Jun 2008
    Location
    Cluj, Romania
    Posts
    77

    Default Re: A fix for Start Numlock on KDE startup in 4.2.1 release1

    Finally someone came up with this too!!! Thank you this was a much needed fix.
    Respect the penguin!

  7. #7

    Smile Re: A fix for Start Numlock on KDE startup in 4.2.1 release108

    I too was used to the Num Lock being on at bootup. This fix is great.
    Thank you.

  8. #8
    Join Date
    Jul 2008
    Location
    Santa Cruz, CA
    Posts
    253

    Default Re: A fix for Start Numlock on KDE startup in 4.2.1 release108

    For some reason, I've always had numlock on. Up until I just installed 12.1. Now it won't go on and the names for the menus have changed, so I cannot find the entries you are referring to. Why doesn't searching "Configure Desktop" aka "Personal Settings" aka "System Settings" yield the info? Why so many names for the same thing?

  9. #9
    Join Date
    Jan 2012
    Location
    rural MD, USA
    Posts
    1

    Default Re: A fix for Start Numlock on KDE startup in 4.2.1 release108

    In recent KDE history, this is in the systemsettings (menu item Configure Desktop - it's in your favorites unless you've changes things). Click Input Devices and it'll be obvious from there. If for some reason this doesn't work, there is a way to autostart numlockx that's more involved, but on openSUSE that's never been necessary for me (only on Arch and Kororaa).

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •