Results 1 to 10 of 10

Thread: KDE4 screen lock problem

  1. #1
    holgerschlegel NNTP User

    Arrow KDE4 screen lock problem

    On my opensuse 11.1 x64 running the current factory kde4 (4.2.1) I have one BIG problem that makes the installation nearly unusable.

    Often the screen lock is activated while I'm using my system. It happens even while typing (for example it happens 3 times during writing this post). Others time it does not happen for hours.

    Looking into the kde4 settings, the screen saver is set to get active after 10 minutes without locking the screen. I've tried disabling the screen saver, but that didn't helped.
    Some other posts in this forum pointing to the energy settings in the advanced tab. I do not see any option in that area with a name that points to screen locking.

    Any idea what causes this and how to solve it?

    One secondary question: Where can I see which is the current active power management profile?

  2. #2
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: KDE4 screen lock problem

    At least on KDE 4.1.3, under Power Management in the advanced tab, General Settings, I see an option that says "Lock screen on resume". I'm not sure if it is in 4.2, but I would be surprised if it is not. I would try that.

    I believe that if you are on a laptop, clicking on the battery icon in the system tray should tell you which profile you are in. On desktops the battery icon is not there by default. To add it, right click on the bottom bar and choose "Add Widgets" and add the battery monitor. Since you are on a desktop and have no battery, it will have an icon that just says "n/a". Click on it and it will tell you what profile you are in.

    Hope that helps.

  3. #3
    holgerschlegel NNTP User

    Default Re: KDE4 screen lock problem

    The option "Lock screen on resume" is still there. I'll deactivated it, logged out, logged in again and ... there problem is still there. Again the screen is locked while typing (this message).

    If that happens, a message titled with "Energy Management" shows up in the bottom right corner telling me that the screen is going to be locked.

    At least I found out what the current profile is. It is "Performance", the once to choose if the power cord is plugged in (as it usually is for desktop computers ). Thx.

    Btw.: The locking problem is there since I updated the kde from 4.1.x (opensuse 11.1 default) to 4.2.0.

    Any more ideas?

  4. #4
    holgerschlegel NNTP User

    Default Re: KDE4 screen lock problem [solved]

    It looks like the problem has been caused by some corrupt kde4 configuration files.
    After deleting and replacing files in .kde4/share/config based on files of a newly created account that logged into kde4 only once the problem is solved.
    Sadly I don't know the excapt file causing the problem.

    Btw., that also solves some other minor glitches I had with kde4

  5. #5
    sunar NNTP User

    Default Re: KDE4 screen lock problem

    Hello,

    I have exactly the same problem. For example, yesterday evening this had happened for several times. Today it haven't happened so far. I didn't find no obvious reason for this behavior in any screensaver or power management settings.

    I'm running KDE 4.2.0 right now, but it used to happen even with 4.1.x, both on OpenSUSE 11.1 running on Lenovo R500 laptop.

    Can anybody help?

  6. #6
    krdvg NNTP User

    Default Re: KDE4 screen lock problem

    Hi,

    I reached this topic while googling for this problem. I am having the same issues as the previous poster on my laptop. The screen locks with a popup on powermanagement saying that the screen will lock now, and its very random. It happened once as I was typing this message.

    Thanks!

  7. #7
    MultiplePersonality NNTP User

    Default Re: KDE4 screen lock problem

    HELLO sunar and krdvg,

    'holgerschlegel' gave the solution in his second 03/07/2009 post..

    and, i suggest the three of you collaborate to make the bug
    report...otherwise, it will probably be in the next KDE4 release, ALSO!

    --
    MultiplePersonality

  8. #8

    Default Re: KDE4 screen lock problem

    Under 'Configure Desktop' -> 'Power Management' -> Edit Profiles there's an option 'when the system is idle for more than' which was set to lock screen after 15 minutes for me, which caused the screen to lock while playing back videos using VLC. The problem didn't happen until I applied some update patches for 11.1 (not factory, just update mirror), so it seems somehow this setting got changed. I've disabled that setting and the problem has gone.
    Gigabyte GA-MA770-UD3 r1.0 F9E|AMD Athlon II X4 635|6 GB 667MHz DDR2|XFX Radeon HD 6750|LG GSA-H30N|Netgear WG311T| opensuse 12.2 x86_64 (Intel 330, X-18M)|LG IPS236V 1920x1080 DVI|Logitech MX3000 & MX Air|Freecom USB DVB-T 25452| JBL Spot|Logitech C310

  9. #9

    Default Re: KDE4 screen lock problem

    Please, add a comment / vote to this issue:
    Powerdevil locks the screen without need
    The "solution" (I mean, work-around) is to modify the powerdevil profiles as rjwilmsi commented.

  10. #10

    Default Re: KDE4 screen lock problem

    rjwilmsi's recommendation solved this issue for me. I've been hunting all over for this "feature" so I could get rid of the screen locking in the middle of using MythTV. Thanks!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •