Results 1 to 10 of 10

Thread: KDE Issues after update

  1. #1

    Default KDE Issues after update

    Sorry for the double post. I put this in the Install/Boot/Login section by accident. My apologies.

    Anyone having this issue or ideas on a fix?

    I updated KDE 4.2 from the Factory repo tonight (updated to 4.2.0-73.2, I don't remember what revision I was on before, but it was about a week old).

    After updating, I went to log out, but nothing happened after confirming my desire to do so. I restarted X, logged in, and after opening up one or two applications, KDE exhibited the same behavior. Clicking on icons or apps off launder or anything on kicker... all yielded no results. The only thing that did work, was hitting Alt-F2 for the run box, then I could start NON-KDE apps, KDE apps still did nothing.

    I restarted X again, and opened Konsole before KDE stopped responding again. Requesting a process list showed a ton of defunct processes (mostly nepomukserver and nepomukservices, but also 1 for each app I had starting in the tray which is just KMix and KCheckGMail).

    I'd downgrade back out, but not sure what I would downgrade to since the previous revision isn't up there of course.

    Advice very appreciated.

    Thanks.

  2. #2
    Join Date
    Jun 2008
    Location
    USA
    Posts
    1,128

    Default Re: KDE Issues after update

    I don't have any idea what the problem is, but thanks for the warning.

    I updated this morning and have no problems. Checking the repos this evening, only QT changed. But I didn't update. Maybe you should try updating again. It can't get any worse.
    Any sufficiently advanced technology is indistinguishable from magic. - Arthur C. Clarke

  3. #3
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: KDE Issues after update

    Check your version. See my Laptop Sig:

    There have been no updates for over a week and the next ones will bring in 4.2.1 (sometime this week, maybe today)
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  4. #4

    Default Re: KDE Issues after update

    Yeah, I have "102" as well and no new updates... Hrm Part of the issue seems that KDE is trying to start things up twice. the ksmserver RC file is recording theat KMix (for example) is running at logoff, then on login trying to start it twice.

    I think maybe it was something changing in my homedir, so I renamed .kde4 and let a new one get made. Same thing, though, first login was fine, subsequent ones were not.

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,734
    Blog Entries
    20

    Default Re: KDE Issues after update

    Sorry. But I'm not experiencing any issues at the moment. (Actually, I'm happy about that).

    You could try creating a New user account (it can easily be deleted). If you still get the problem then, at least we have narrowed down the issue.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: KDE Issues after update

    Tried a new user as well and even after today's revisions KDE is still performing as described. The only way to make it behave normally (and I have to do this before every login) is to delete the ksmserverrc file from ~/.kde4/share/config


  7. #7
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    570

    Default Re: KDE Issues after update

    when you rename the .kde4 folder are you doing it in kde4 or logging out and into some other desktop?
    if your doing it in kde4 then it is just remaking a new .kde4 folder and keeping some of the settings
    try logging out and logging into some other DE then rename the .kde4 fold then logging back into kde4

  8. #8

    Default Re: KDE Issues after update

    Yeah, I am logging out and then into another term, no DE, to rename it.

  9. #9
    Join Date
    Jun 2008
    Location
    Kansas City, MO
    Posts
    570

    Default Re: KDE Issues after update

    ok it was just a thought cause i had a problem renameing .kde4 while being in kde4 lol

  10. #10

    Default Re: KDE Issues after update

    I really appreciate peoples interest in helping... thank you.

    I FIXED IT! It was the last thing I thought to try, but at the same time that I patched, updated, etc... I also updated my nvidia driver. In a final attempt to fix things, I downgraded to the second most resent (which has actually become the latest Stable release again, they marked the newer one as a Pre-Release since yesterday).

    So... avoid nvidia driver 180.35, lol

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •