For the past several days, security upgrade downloads have been offered, but when downloaded, they produce this error message:

PackageKit Error dep-resolution-failed: ati-fglrxG01-kmp-default-8.561_2.6.27.7_9.1-1.1.i586 requires kernel(default:mm) = d2046c7a7e90ef6a, but this requirement cannot be provided.

What is the correct method to correct this problem?

Thanks - MD