Results 1 to 9 of 9

Thread: NTP client

  1. #1
    MarkD NNTP User

    Default NTP client

    How do you set update intervals for NTP client?

    I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    loosing time particulary after applying certain Suse updates.

    -MD



  2. #2

    Default Re: NTP client

    On 2009-02-24, MarkD <mdnc@boreal.org> wrote:
    > How do you set update intervals for NTP client?
    >
    > I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    > loosing time particulary after applying certain Suse updates.


    You should just run ntpd (set up via YaST / ntp client) and let it all take
    care of itself. With ntpd continually adjusting the interval is irrelevant.

    kind regards,
    Andreas Stieger

  3. #3
    Join Date
    Jun 2008
    Location
    UTC+10
    Posts
    9,686
    Blog Entries
    4

    Default Re: NTP client

    You run the ntpd service to track public time servers, or you run ntpd in one-shot mode to set the time (11.1), or you run ntpdate to set the time (< 11.1).

  4. #4
    MarkD NNTP User

    Default Re: NTP client

    Andreas Stieger wrote:

    > On 2009-02-24, MarkD <mdnc@boreal.org> wrote:
    >> How do you set update intervals for NTP client?
    >>
    >> I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    >> loosing time particulary after applying certain Suse updates.

    >
    > You should just run ntpd (set up via YaST / ntp client) and let it all
    > take care of itself. With ntpd continually adjusting the interval is
    > irrelevant.
    >
    > kind regards,
    > Andreas Stieger



    Several times I have gone into yast and clicked use ntp using the default
    time servers.

    Is there a console command that will display the dafault update interval?

    -MD

  5. #5

    Default Re: NTP client

    On 2009-02-24, MarkD <mdnc@boreal.org> wrote:
    > Andreas Stieger wrote:
    >
    >> On 2009-02-24, MarkD <mdnc@boreal.org> wrote:
    >>> How do you set update intervals for NTP client?
    >>>
    >>> I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    >>> loosing time particulary after applying certain Suse updates.

    >>
    >> You should just run ntpd (set up via YaST / ntp client) and let it all
    >> take care of itself. With ntpd continually adjusting the interval is
    >> irrelevant.

    >
    > Several times I have gone into yast and clicked use ntp using the default
    > time servers.
    >
    > Is there a console command that will display the dafault update interval?


    yourfavouriteeditor /etc/ntp.conf
    Again, the interval is irrelevant (and I don't even think it's constant).
    You seem to have the notion that the clock runs at some speed and at some
    regular intervals is set back/forward to the correct time. What it really
    does is adjust the speed of the kernel clock _between_ the ntp queries with
    it's upstream and peer servers, so the clock is _always_ as correct as
    possible.
    Check your ntp configuration (/etc/ntp.conf, /etc/sysconfig/ntp) and whether
    ntpd is running properly and can reach the servers specified.

    Kind regards,
    Andreas Stieger

  6. #6
    Tilman Schmidt NNTP User

    Default Re: NTP client

    MarkD schrieb:
    > How do you set update intervals for NTP client?


    You don't. NTP is an adaptive algorithm. It changes the poll interval
    dynamically as needed. And it's called "poll interval", not "update
    interval", because NTP does not "update" the client's clock to the
    value received from a server; it adjusts the clock speed to achieve
    long-term synchronization.

    That said, you can set the minimum and maximum poll intervals with
    the "minpoll" and "maxpoll" parameters of the "server" command in
    the configuration file /etc/ntp.conf. These are given as log2 of the
    desired interval. You can specify minpoll between 4 (meaning 16 secs)
    and 6 (64 secs), and maxpoll between 10 (1024 secs) and 17 (131072
    secs, or 36.4 hours). But you should leave them at their defaults
    unless you have a very good reason to change them.

    > I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    > loosing time particulary after applying certain Suse updates.


    Timekeeping in virtualized hosts is a complex topic. I doubt
    very much that you'll be able to improve it by fiddling with
    polling intervals.

    HTH
    T.

  7. #7
    MarkD NNTP User

    Default Re: NTP client

    MarkD wrote:

    > How do you set update intervals for NTP client?
    >
    > I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    > loosing time particulary after applying certain Suse updates.
    >
    > -MD



    To all that responded thank you.

    From looking at /var/log/ntp, I found an 10 hour gap where no updates
    transacted until a reboot today. I will apply the security patches waiting
    and check sleep mode settings.

    -MD


  8. #8
    MarkD NNTP User

    Default Re: NTP client

    MarkD wrote:

    > MarkD wrote:
    >
    >> How do you set update intervals for NTP client?
    >>
    >> I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    >> loosing time particulary after applying certain Suse updates.
    >>
    >> -MD

    >
    >
    > To all that responded thank you.
    >
    > From looking at /var/log/ntp, I found an 10 hour gap where no updates
    > transacted until a reboot today. I will apply the security patches
    > waiting and check sleep mode settings.
    >
    > -MD


    I went to desktop configuration-display settings-power control and disabled
    display power management. This morning the clock is off by two hours. I
    checked /var/log/ntp and it shows no updates taking place for about the
    time the clock is off.

    Any ideas?

    Should I start this as a new thread?

    -MD


  9. #9
    Tilman Schmidt NNTP User

    Default Re: NTP client

    MarkD schrieb:
    >>>
    >>> I am running Suse 11.1 under Virtual PC 2007. I have the problem of Suse
    >>> loosing time particulary after applying certain Suse updates.

    [...]
    > I went to desktop configuration-display settings-power control and disabled
    > display power management. This morning the clock is off by two hours. I
    > checked /var/log/ntp and it shows no updates taking place for about the
    > time the clock is off.
    >
    > Any ideas?


    As I said, timekeeping in virtual machines is a complicated topic.
    I have no experience with Virtual PC. What mechanisms does it have
    to synchronize the clocks of its clients?

    > Should I start this as a new thread?


    I think that would be a good idea. It may also help to mention "Virtual PC"
    in the subject line.

    HTH
    T.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •