Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Unlocking screen - unlocking failed.

  1. #1
    Join Date
    Jan 2009
    Location
    PARADISE
    Posts
    929

    Thumbs down Unlocking screen - unlocking failed.

    GUYS... Id love to report at least something good: Its spring soon!

    Well, and heres just another smaller problem that Ive been experiencing lately: After not touching my computer for more than 20 minutes (by that time my screensaver did already pop in), I cant UNLOCK my screen.

    Now to clarify that point: Its probably not an issue with the screenaver. I tested letting pop up the screensaver, moving mouse - everything back to normal. But after a longer period of time, the screen locks (everything keeps working in background) and the mentioned error message pops up. The only way to get back to the dektop is to either reboot or manually switching to runlevel 3 and later on to runlevel 5 again.

    AWESOME. Any help is (as always) much appreciated, guys.

    TheMask.
    CHECK OUT THESE GitHub PROJECTS!

    https://secupwn.github.io/Android-IMSI-Catcher-Detector/
    https://github.com/SecUpwN/Spotify-AdKiller

  2. #2
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: Unlocking screen - unlocking failed.

    Since you didn't say which desktop manager you are using, it is kind of hard to diagnose. Also, I'm not sure if you want it to not lock at all, or to fix it so that unlocking works.

    For the sake of doing something constructive, I am going to assume you are using KDE4 with automatic login, and you want the locking turned off. If you are looking for something different, reply back.

    The locking by default does not start immediately when the screen saver starts, it waits a minute or so just in case you are there, not active on the screen, but don't want it to lock. To turn off this behavior, click on the K-menu->Configure Desktop, then under Look & Feel, select Desktop-> Screen Saver. At the bottom here will be an option that says "Require password to stop". If you uncheck this, locking will be disabled.

    If you want the locking to happen, but want to fix it so your password works, it sounds like you are probably just entering your password wrong. To test, select log-out, and try logging back in, if this works with the same password you are trying with the unlocking, you may have a much more serious problem.

    Note that if you are using KDE3 or Gnome, there should be a similar way to disable the locking.

    Good luck.

  3. #3
    Join Date
    Jan 2009
    Location
    PARADISE
    Posts
    929

    Default Re: Unlocking screen - unlocking failed.

    elserj, thanks for your reply.

    I am currently using KDE 4.1.3 without automatic login (means username as well as passoword must be typed).
    Now as I said before: I dont consider this to be an issue with the screensaver...
    Quote Originally Posted by elserj
    The locking by default does not start immediately when the screen saver starts, it waits a minute or so just in case you are there, not active on the screen, but don't want it to lock. To turn off this behavior, click on the K-menu->Configure Desktop, then under Look & Feel, select Desktop-> Screen Saver. At the bottom here will be an option that says "Require password to stop". If you uncheck this, locking will be disabled.
    Well, to clarify: The password option is NOT set. First ahead, the screensaver appears. Way later (10 to 20 minutes) the screen first turns off its light (screensaver running in the background). Then it completely blacks out - and by that time its locked. Now if I move the mouse, the mentioned error message appears while the screensaver is shown in the background.

    TheMask.
    CHECK OUT THESE GitHub PROJECTS!

    https://secupwn.github.io/Android-IMSI-Catcher-Detector/
    https://github.com/SecUpwN/Spotify-AdKiller

  4. #4
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: Unlocking screen - unlocking failed.

    Well, I have two more ideas. But first, are you saying you get the error without ever actually typing your password? Meaning, immediately after moving the mouse it errors. That may mean you have a much bigger problem. With that said, try the below to see if it helps.

    I think it may be the power management that is causing it then. Try going to K Menu-> Configure Desktop, choosing the Advanced tab, then selecting power management. Under General settings there should be an option that says "Lock screen on resume". Try unchecking this box and see if that fixes it.

    A more permanent and drastic solution is to rename the desktop locking program. I haven't tested this under KDE4, but I have done it in KDE3 (for a bunch of student lab machines where we wanted locking disabled completely). Just do
    Code:
    sudo mv /opt/kde3/bin/kdesktop_lock /opt/kde3/bin/kdesktop_lock.orig
    There should be something similar for KDE4, but I'm not sure what executable is running that does the locking.

    However, I believe the first solution in this post will probably fix what you are looking for.

  5. #5
    Join Date
    Jan 2009
    Location
    PARADISE
    Posts
    929

    Default Re: Unlocking screen - unlocking failed.

    Quote Originally Posted by elserj
    I think it may be the power management that is causing it then. Try going to K Menu-> Configure Desktop, choosing the Advanced tab, then selecting power management. Under General settings there should be an option that says "Lock screen on resume". Try unchecking this box and see if that fixes it.
    Thanks for your suggestion... apparently it didn't work.
    Any other hints I might try? THANK YOU so much for supporting me guys - my experience in this forum has been just great.

    TheMask.
    CHECK OUT THESE GitHub PROJECTS!

    https://secupwn.github.io/Android-IMSI-Catcher-Detector/
    https://github.com/SecUpwN/Spotify-AdKiller

  6. #6
    Join Date
    Jun 2008
    Location
    wichita
    Posts
    921

    Default Re: Unlocking screen - unlocking failed.

    TheMask said:

    "the mentioned error message appears while the screensaver is shown in the background."

    Sorry if I missed it, but I didn't see you mention an error message above. What is it?

  7. #7
    Join Date
    Jan 2009
    Location
    PARADISE
    Posts
    929

    Default Re: Unlocking screen - unlocking failed.

    Actually its the thread title. It tells me the message in german, but I assume it is about the same in english.

    Unlocking Sceen - unlocking the screen failed.
    As I said before: i dont have the password option set. But why does the screen lock anyway?And in the background everything runs perfectly (even the screensaver is happy)..

    TheMask.
    CHECK OUT THESE GitHub PROJECTS!

    https://secupwn.github.io/Android-IMSI-Catcher-Detector/
    https://github.com/SecUpwN/Spotify-AdKiller

  8. #8
    Join Date
    Jan 2009
    Location
    PARADISE
    Posts
    929

    Default Re: Unlocking screen - unlocking failed.

    UPDATE!

    Guys, I may have completely misread the error message I postet. THIS is the right one (and I jope someone will remember a fix)...

    The SESSION is locked. Unlocking the SESSION failed.
    It's about the SESSION and not the screen - therefore the error has nothing to do with the screensaver...

    TheMask.
    CHECK OUT THESE GitHub PROJECTS!

    https://secupwn.github.io/Android-IMSI-Catcher-Detector/
    https://github.com/SecUpwN/Spotify-AdKiller

  9. #9
    Join Date
    Jun 2008
    Location
    Oregon, US
    Posts
    109

    Default Re: Unlocking screen - unlocking failed.

    Ok, I have two more ideas.

    It looks like there is a bug with the new KDE and PAM. See http://="https://bugzilla.novell.com....cgi?id=353531. If I'm reading it right, you just need to do
    Code:
    sudo ln -s /etc/pam.d/xdm /etc/pam.d/kde
    You may find more info reading through those bug reports. Just out of curiosity, does using your root password unlock it?

    The other idea is an extension of the one I had earlier. To permanently disable locking, do
    Code:
    sudo mv /usr/lib64/kde4/libexec/krunner_lock /usr/lib64/kde4/libexec/krunner_lock.old
    Note that if you are on 32 bit, it is probably in /usr/lib/ instead of lib64.

    Let us know if you find out more.

  10. #10
    Join Date
    Jan 2009
    Location
    PARADISE
    Posts
    929

    Default Re: Unlocking screen - unlocking failed.

    Code:
    sudo ln -s /etc/pam.d/xdm /etc/pam.d/kde
    Although I don't really know what the above code did - it did NOT work.

    Now if I'd try your second code, will I be able to enable it some day again by just renaming the file again to 'krunner_lock'? If so, I'll try that one.

    TheMask.
    CHECK OUT THESE GitHub PROJECTS!

    https://secupwn.github.io/Android-IMSI-Catcher-Detector/
    https://github.com/SecUpwN/Spotify-AdKiller

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •