Results 1 to 8 of 8

Thread: opensuse 11.1 - kupdateapplet

Hybrid View

  1. #1
    pablo2525 NNTP User

    Default opensuse 11.1 - kupdateapplet

    Hi,

    I have two machines, one running openSUSE 11.0 and the other 11.1

    I've configured the `kupdateapplet' the same on the 11.1 machine as the 11.0. One specific feature is `Show available upgrades when backend provides them (for experts only).'

    On the 11.0 box, `kupdateapplet' presents to tabs: Patches and Upgrades.

    On the 11.1 box, I only see `Patches', not `Upgrades'

    Another issue, and more important, I never see any updates on the 11.1 via the applet. I must always run `YaST' to get the latest upgrades.

    Any ideas?

    Thank you.

  2. #2

    Default Re: opensuse 11.1 - kupdateapplet

    I had noted the same thing with regard to the loss of the "Upgrades" tab.

    I do get updates in the applet, though. I have a vague recollection of having to go through the Add/Remove Update Sources a couple of times before that started working, though.

  3. #3
    pablo2525 NNTP User

    Default Re: opensuse 11.1 - kupdateapplet

    Hi Steve,

    Thank you for your reply.

    Do you recall what type of jigging you did to your repository? It sounds like a bug so I may need to report a bug. (I did check the bug database first and didn't find anything related to my issue).

  4. #4

    Default Re: opensuse 11.1 - kupdateapplet

    http://bugzilla.novell.com/418277

    Use the ZYpp backend or...

  5. #5
    pablo2525 NNTP User

    Default Re: opensuse 11.1 - kupdateapplet

    Quote Originally Posted by RedDwarf View Post
    Use the ZYpp backend or...
    Hi RedDwarf,

    Thank you! That solved the issue. I installed kde4-kupdateapplet-zypp and now I have my beloved `Upgrade' tab along with updates working as before.

    For other folks, here's what I did:
    1. Used YaST to install the above RPM
    2. Quit `kupdateapplenet'
    3. In a shell, started `kupdateapplet'
    4. Right-click on the applet in my systra and pick `Configure Applet...'
    5. Change `Backend:' from `PackageKit Plugin' to `ZYpp Plugin'
    6. Open the updater and notice the `Upgrades' tab appears!

  6. #6
    pablo2525 NNTP User

    Default Re: opensuse 11.1 - kupdateapplet

    Correction: Quit `kupdateapplet'

  7. #7

    Default Re: opensuse 11.1 - kupdateapplet

    Hi, Pablo.

    I didn't do anything in particular, just had to go through the "Add/Remove Update Sources" function a couple of times before it seemed to start showing me updates.

    I should note that this is on my 64-bit machine, which is the only one I upgraded -- it's been through every release since 9-something. My other two machines are 32-bit and are both clean installs of 11.1, and the update applet worked fine on both immediately.

    Will try the zypper too. I want that Upgrades tab back!

  8. #8

    Default Re: opensuse 11.1 - kupdateapplet

    I've followed your steps, but i can not change `Backend:' from `PackageKit Plugin' to `ZYpp Plugin', eventhough the kde4-kupdateapplet-zypp is installed

    What did i do wrong?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •