Results 1 to 2 of 2

Thread: openSUSE ver11.1 trying to join a Windows 2003 Domain

  1. #1
    bhowerton1 NNTP User

    Question openSUSE ver11.1 trying to join a Windows 2003 Domain

    Hello,
    This is what I am attempting to do:
    I would like to setup a Linux machine to act as a proxy using Squid and Dansguardian. I have about 200 pcs that all have Windows XP Pro with SP3. I would like this proxy to monitor and track the network activity on each of the 200 Windows pcs. I would like it to be setup in a way that all of the user's pcs must go through the proxy to get to the Internet (Tools/Internet Opotions/Connections/Lan Settings/Proxy Server). I do not want the users to have to enter a username and/or password to get on the internet. Everything needs to be done behind the scenes without the user knowing.

    I am using openSuse 11.1. I have installed the following software: Squid (2.x), yast2-squid, Dansguardian, Samba-Winbind, KRB5, KRB5-Client.

    My current problem is: I am having trouble getting this Linux Machine to Join a Windows 2003 Server. This server is the Primary Domain Controller with Active Directory.

    Does this Linux machine have to be a member of the Windows domain to do this?

    I have used 2 tutorial-type documents. Here are the URL for those documents (they are active hyperlinks...you can click them:
    1)Setting up Squid NTLM DansGuardian Sarg - openSUSE

    2) http://susewiki.org/index.php?title=...directory_2003. Everything is now setup according to this tutorial.

    Following both tutorials everything is perfect up to the step when you join the domain (i.e.
    net join -S PDC -UAdministrator or
    net ads join -U domainadminuser@DOMAIN.INTERNAL).

    When I execute either of the "net join" statements above...This is the error I get:

    Failed to join domain. Invalid configuration and configuration modification was not requested.

    Could someone please provide some help or insight into the problem and a possible solution?


    Thanks,
    Bobby Howerton
    Last edited by bhowerton1; 20-Feb-2009 at 13:44. Reason: trying to remove an e-mail hyperlink...domainadminuser does not exist

  2. #2
    PV NNTP User

    Default Re: openSUSE ver11.1 trying to join a Windows 2003 Domain

    On Fri February 20 2009 02:46 pm, bhowerton1 wrote:

    >
    > hello,
    > this is what i am attempting to do:
    > i would like to setup a linux machine to act as a proxy using squid and
    > dansguardian. i have about 200 pcs that all have windows xp pro with
    > sp3. i would like this proxy to monitor and track the network activity
    > on each of the 200 windows pcs. i would like it to be setup in a way
    > that all of the user's pcs must go through the proxy to get to the
    > internet (tools/internet opotions/connections/lan settings/proxy
    > server). i do not want the users to have to enter a username and/or
    > password to get on the internet. everything needs to be done behind the
    > scenes without the user knowing.
    >
    > i am using opensuse 11.1. i have installed the following software:
    > squid (2.x), yast2-squid, dansguardian, samba-winbind, krb5,
    > krb5-client.
    >
    > my current problem is: i am having trouble getting this linux machine
    > to join a windows 2003 server. this server is the primary domain
    > controller with active directory.
    >
    > does this linux machine have to be a member of the windows domain to do
    > this?
    >
    > i have used 2 tutorial-type documents. here are the url for those
    > documents (they are active hyperlinks...you can click them:
    > 1)'setting up squid ntlm dansguardian sarg - opensuse'
    > (http://en.opensuse.org/setting_up_sq...sguardian_sarg)
    >
    > 2) http://tinyurl.com/budls5. everything is now setup according to
    > this tutorial.
    >
    > following both tutorials everything is perfect up to the step when you
    > join the domain (i.e. net join -s pdc -uadministrator or
    > net ads join -u
    > domainadminuser@domain.internal).
    >
    > when i execute either of the \"net join\" statements...this is the
    > error i get:
    >
    > failed to join domain. invalid configuration and configuration
    > modification was not requested.
    >
    > could someone please provide some help or insight into the problem and
    > a possible solution?
    >
    > Thanks,
    > Bobby Howerton
    >
    >

    Bobby;

    Does this apply:

    http://www.mail-archive.com/samba%40.../msg97460.html
    --
    P. V.
    "We're all in this together, I'm pulling for you." Red Green

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •