Results 1 to 8 of 8

Thread: can't access console (F1 - F6)

  1. #1
    Join Date
    Jun 2008
    Location
    Smithville, TN
    Posts
    16

    Question can't access console (F1 - F6)

    I seem to have a problem switching to the virtual consoles. I can't. Whenever I press any combination of Ctl-Alt-F*, gnome stays active. Anybody know why my virtual consoles are disabled or not accessible?

    Running openSUSE 11.1.

  2. #2
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Re: can't access console (F1 - F6)

    Check your inittab located in the /etc folder and look for the section under "# Run gettys in standard runlevels". Look to see if any of the gettys are commented out. If so just uncomment the ones you need. Make sure you do it as root though or you won't be able to modify the file. Then reboot and you should have your virtual consoles back. If not I don't know where else to look, unfortunately I'm no expert. Hope that helps.

  3. #3
    Join Date
    Jun 2008
    Location
    Smithville, TN
    Posts
    16

    Default Re: can't access console (F1 - F6)

    Is this the section you were talking about? All the lines (1 - 6) are uncommented.

    Code:
    # getty-programs for the normal runlevels
    # <id>:<runlevels>:<action>:<process>
    # The "id" field  MUST be the same as the last
    # characters of the device (after "tty").
    1:2345:respawn:/sbin/mingetty --noclear tty1
    2:2345:respawn:/sbin/mingetty tty2
    3:2345:respawn:/sbin/mingetty tty3
    4:2345:respawn:/sbin/mingetty tty4
    5:2345:respawn:/sbin/mingetty tty5
    6:2345:respawn:/sbin/mingetty tty6

  4. #4
    Join Date
    Jan 2009
    Location
    Pittsburgh, PA
    Posts
    39

    Default Re: can't access console (F1 - F6)

    Yes that is the section and it looks fine. The only other thing I would know to check would be the hotkeys setup in your system settings. That or try just using the Alt+Fn and see if that works. Sorry I couldn't help anymore!

  5. #5
    Join Date
    Jun 2008
    Location
    Smithville, TN
    Posts
    16

    Default Re: can't access console (F1 - F6)

    I went into the keyboard settings in control panel and in sax, and nothing is checked. Thanks for the suggestions JeremiahMosser.

    Any other suggestions or troubleshooting ideas?

  6. #6
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,006
    Blog Entries
    1

    Default Re: can't access console (F1 - F6)

    Somehow, your key bindings are not working as expected. Do you have compiz enabled by chance? I have read of user problems with compiz enabled.

  7. #7

    Default Re: can't access console (F1 - F6)

    Do you have a Microsoft branded keyboard (or another model that has a function lock "feature")? If so, try checking to see if the function lock is on/off (MS branded keyboards have a nasty tenancy to disable the function keys in favor of launching custom apps, such as f1 might launch a web browser by default). Does Control + F1-F4 switch virtual desktops? Does the Alt button work fine? If you hit F1 by itself, does that launch a help window of some kind?

  8. #8
    Join Date
    Jun 2008
    Location
    Smithville, TN
    Posts
    16

    Default Re: can't access console (F1 - F6)

    deano_ferrari, I didn't install compiz.

    falcon119, The keyboard is a Logitech EX110. The Alt key works fine for key combinations such as Alt-F to open the file menu. The Ctl key works for key combinations such as Copy, Cut, Paste and Undo. F1 - F12 don't appear to do anything on their own.

    Dang. I just found an F-mode key. After pressing it, F1 - F12 "does stuff" and the Ctl-Alt-F* combinations work. I'm fairly new to this keyboard and didn't realize there was an F-mode key.

    Thanks to everyone for their helpful suggestions.
    Last edited by jnewby; 21-Feb-2009 at 07:04. Reason: Found the culprit key after posting.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •