Page 1 of 4 123 ... LastLast
Results 1 to 10 of 40

Thread: Problem with Yast2 and KDE4 openSUSE 11.0

  1. #1

    Default Problem with Yast2 and KDE4 openSUSE 11.0

    Hello all!
    I was upgrading to KDE 4.2 via one-click install last night and before it was finished I aborted it as it was getting late. Today I attempted to do it again and yast gave this error:

    terminate called after throwing an instance of 'YUIPluginException'
    what(): Couldn't load plug-in qt
    YaST got signal 6 at YCP file SlideShow.ycp:76
    /sbin/yast2: line 421: 6656 Aborted $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    I then started yast2 with gtk and managed to complete the installation but when I try to log in to KDE 4.2 i get this error: "Couldn't load kdeinit4. Check your installation."
    I have tried and googled everything I could think of and can't figure out how to fix it.

    Could somebody please help me? Any help is much appreciated!

  2. #2
    vpoqol5 NNTP User

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Are you now in suse?
    if you are (I suppose gnome then) reinstall kde4. First delete it through yast (it will be pain in the ass because of all those dependencies) and then install it by one click install from opensuse page KDE/KDE4 - openSUSE

    i would also recommend doing update of all packages (Package-> All packages -> Update if newer version is avaible)

    it's the best thing to do after everything and is no problem since you're not on dialup

  3. #3
    Join Date
    Jun 2008
    Location
    Warsaw, Poland
    Posts
    20

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Hi,
    I got very similar problem, but I was doing a "normal" update. I read somewhere in the forums to downgrade the packages from KDE Qt repository and, well, it helped
    Hope, it'll fix your case
    Bert @ SLS

    HP Pavilion dv6530ew
    Intel Core 2 Duo T5450 1,67Ghz; 1GB DDR2 RAM; 120GB SATA HDD; Nvidia GeForce 8400M
    openSUSE 11 x86_64

  4. #4

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Thanks for the replies

    Quote Originally Posted by vpoqol5 View Post
    Are you now in suse?
    if you are (I suppose gnome then) reinstall kde4. First delete it through yast (it will be pain in the ass because of all those dependencies) and then install it by one click install from opensuse page KDE/KDE4 - openSUSE

    i would also recommend doing update of all packages (Package-> All packages -> Update if newer version is avaible)

    it's the best thing to do after everything and is no problem since you're not on dialup
    Actually I am on dialup I just went to my brother's house to download it. I also found that sax2 doesn't work either so I tried sax2 --ignoreprofile and I got:

    Cannot mix incompatible Qt libraries
    terminate called after throwing an instance of 'std::logic_error'
    what(): basic_string::_S_construct NULL not valid

    I'm going to try updating anything installed related to qt and see what happens.
    Will post back afterwards

  5. #5

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Ok guys I updated 3 qt related packages with yast --gtk and yast2 mostly works now! Also KDE 4.2 is now working and sax2 works aswell but complains of missing packages! So i'm sure I can figure it out from here. Many Thanks for the help guys!!//forums.opensuse.org/images/sm...snew/smile.png

  6. #6

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Ok i've got one last problem. Whenever I start yast software management, after the repositories have loaded it closes and gives this error:

    YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp:36
    /sbin/yast2: line 421: 3455 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    Again I have googled it and couldn't find a solution.
    Any help is much appreciated!!

  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,287
    Blog Entries
    1

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Actually I have seen a number of threads on the internet (after googling), but I'm not sure how useful they would be. The 1-click install can cause problems with the repo configuration, so maybe start by looking at these first.

    Open a console (su to root) and do

    zypper lr
    It may be necessary to delete any recently added (problematic repos) first. You can also launch the ncurses (text mode) version of yast via a console as well if required.

  8. #8

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Quote Originally Posted by deano_ferrari View Post
    Actually I have seen a number of threads on the internet (after googling), but I'm not sure how useful they would be. The 1-click install can cause problems with the repo configuration, so maybe start by looking at these first.

    Open a console (su to root) and do



    It may be necessary to delete any recently added (problematic repos) first. You can also launch the ncurses (text mode) version of yast via a console as well if required.
    Ok I did that and yast still does:

    YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp:36
    /sbin/yast2: line 421: 4076 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS

    Any further ideas? Thanks for replying!!

  9. #9

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Ok I pasted this: /usr/share/YaST2/clients/inst_packages.ycp into a terminal and forgot to type vim in first and got this:

    YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp
    No such client module got
    The search path follows. It does not include the current directory.
    /y2update/clients
    /root/.yast2/clients
    /usr/share/YaST2/clients

    I think I'm close to figuring it out!
    Any ideas?

  10. #10

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    I fixed it!!
    Here is what I did:
    1. Deleted all repositories from yast except the opensuse 11.0 DVD.
    2. Deleted all yast packages from system. (Might not have needed to do that but just to be sure...)
    3. Rebooted then re-installed all the deleted yast packages then rebooted again.
    And thats it, all working again!!
    Many thanks everyone!!! Hope this helps others!!

Page 1 of 4 123 ... LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •