Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 40

Thread: Problem with Yast2 and KDE4 openSUSE 11.0

  1. #11
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,292
    Blog Entries
    1

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Glad you got it sorted. Thanks for the update.

  2. #12
    Freek NNTP User

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    seadisk wrote:

    >
    > I fixed it!!
    > Here is what I did:
    > 1. Deleted all repositories from yast except the opensuse 11.0 DVD.
    > 2. Deleted all yast packages from system. (Might not have needed to do
    > that but just to be sure...)
    > 3. Rebooted then re-installed all the deleted yast packages then
    > rebooted again.
    > And thats it, all working again!!
    > Many thanks everyone!!! Hope this helps others!!


    I changed the KDE4.2 Qt repository from
    http://download.opensuse.org/reposit...openSUSE_11.0/ to
    http://download.opensuse.org/reposit...openSUSE_11.0/
    and refreshed (update unconditonally) all packages in the KDE4.2 Qt
    repository.
    --
    Freek

  3. #13

    Smile Re: Problem with Yast2 and KDE4 openSUSE 11.0

    I saw this solution on the German forums (thanks Google translate) and successfully resolved it on my laptop. It should be posted here too for the non-German crowd.

    If you are using Factory repos, and if you still want to have Qt4.5 and be able to use YaST2, the solution is to downgrade yast2-qt-pkg to the original version. It looks like one of the official updates changed/broke something that's not compatible with Qt4.5. This worked on my 11.0, and I suspect will work on 11.1 also.

    The other option is, of course, to downgrade to Qt4.4, which will result in you losing some of the coolness status points.

    Link to German forum mentioning this solution: LINUX • openSUSE - Wie kann die zypp.db gelöscht werden?

  4. #14
    cbaltar2 NNTP User

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    I'm also running Qt 4.5 and downgrading YaST fixed the "signal 11 at ycp" problem for me - thanks.

  5. #15

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    YaST got signal 11 at YCP file /usr/share/YaST2/clients/inst_packages.ycp:36
    /sbin/yast2: line 421: 4076 Segmentation fault $ybindir/y2base $module "$@" "$SELECTED_GUI" $Y2_GEOMETRY $Y2UI_ARGS
    I've struggled with this same error message when trying to use YaST2 for software management. When it occurs I can't even copy and paste the X-message that is displayed!
    Has your fix reliably worked? For me I can select repositories but not install any software so I'm using rpm instead of YaST for the moment.
    I think it might be another instance of Novell's bug # 461136 filed on the Bugzilla system.:

    https://bugzilla.novell.com/show_bug.cgi?id=461136

    If your install is still suffering then add your vote to the bug on bugzilla! Maybe it will help to get it resolved sooner.

  6. #16

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    This update-development version solve problem
    http://software.opensuse.org/ymp/dev...st2-qt-pkg.ymp
    Thanks for help

  7. #17

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    This update-development version solve problem
    http://software.opensuse.org/ymp/dev...st2-qt-pkg.ymp
    This didn't fix the YaST2 segfault problem on my system but I have seen on Bugzilla that bug #461136 is now marked as "resolved". Sadly however, "resolved" doesn't mean it is "fixed" just that it has been merged with #464214 so please, all move your votes to that newer one on the Novell Bugzilla site. It looks as though the problem is down to a fonts issue with "qt" but I'm not sure I understand the full story since it certainly used to work for well over a year on my system and has only broken since the start of 2009.

    It has become something of an embarrassment as I try to use the machine as a demo platform when advocating the use of Linux. I've come to the point that I have to fudge over any demo where I'm asked about adding extra software.

    Embarrassed Penguin!

  8. #18

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Yes, it's now definitely being treated as bug #464214 on Novell Bugzilla, and looks like it is being pondered by far greater minds than mine so I'm watching that space in hope!
    Last edited by dave_cass; 18-Mar-2009 at 07:37. Reason: Fixed typo

  9. #19
    mpyama250 NNTP User

    Exclamation Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Quote Originally Posted by seadisk View Post
    I fixed it!!
    Here is what I did:
    1. Deleted all repositories from yast except the opensuse 11.0 DVD.
    2. Deleted all yast packages from system. (Might not have needed to do that but just to be sure...)
    3. Rebooted then re-installed all the deleted yast packages then rebooted again.
    And thats it, all working again!!
    Many thanks everyone!!! Hope this helps others!!

    I am having this same problem and it is killing me. I removed and readded the repos but still have the problem. I can't load the software mgmnt page like you stated and can't figure out how delete/re-add/edit the YAST packages. Can someone please help me?

    Thanks,
    Michael

  10. #20
    mpyama250 NNTP User

    Default Re: Problem with Yast2 and KDE4 openSUSE 11.0

    Quote Originally Posted by Freek View Post
    seadisk wrote:

    >
    > I fixed it!!
    > Here is what I did:
    > 1. Deleted all repositories from yast except the opensuse 11.0 DVD.
    > 2. Deleted all yast packages from system. (Might not have needed to do
    > that but just to be sure...)
    > 3. Rebooted then re-installed all the deleted yast packages then
    > rebooted again.
    > And thats it, all working again!!
    > Many thanks everyone!!! Hope this helps others!!


    I changed the KDE4.2 Qt repository from
    Index of /repositories/KDE:/Qt/openSUSE_11.0 to
    Index of /repositories/KDE:/Qt44/openSUSE_11.0
    and refreshed (update unconditonally) all packages in the KDE4.2 Qt
    repository.
    --
    Freek
    How did you downgrade with Yast broken? I can't load the software mgmnt screen to do anything. Any help would be greatly appreciated as I have searched all over the web for a solution (step by step) and can't find any. I have never ran into anything like this on Suse either....

Page 2 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •