Results 1 to 5 of 5

Thread: Searching for eclipse CDT Plugin

  1. #1
    neuba_ge NNTP User

    Default Searching for eclipse CDT Plugin

    Hi all,

    is there anywhere an openSuse repository that provides the CDT plugin for eclipse?

    I've already tried to find on using google, rpmseek, forum search and others, but haven't found one.

    Can you please help me?

    Thx in advanced

  2. #2

    Default Re: Searching for eclipse CDT Plugin

    There is no opensuse site maybe because eclipse things are already very well packaged ! ;-)
    My advice is to download the full package (third line on Eclipse Downloads
    I did that and it works quite well.
    Otherwise, if you have an already installed eclipse (Ganymede version) click on Help/Software Updates/Add sites... and add CDT Ganymede Releases Update Site
    or CDT 5.0.2 Build I200902060802
    (cf. CDT Downloads Page)
    However, from time to time, I have encountered some missing requirements blocking the installation with these cdt-only packages.

    Please report result of your trials here.

  3. #3
    Join Date
    Jun 2008

    Default Re: Searching for eclipse CDT Plugin

    This is the official update site for Ganyamede:
    I'm installing addons from this repository, there are no missing dependencies.

  4. #4
    neuba_ge NNTP User

    Default [solved] Re: Searching for eclipse CDT Plugin

    Thanks for reply,

    that's really bad that there is no repo containing it.
    For example for Ubuntu/gentoo/archLinux and others the CDT is in the mainrepo or in an extended.

    My solution is now:
    Going to the YOXOS homepage and create a full distribution of eclipse there and install it to my home folder.

  5. #5
    idryl NNTP User

    Thumbs down Re: Searching for eclipse CDT Plugin

    I also think it's really bad that there is no CDT or other eclipse plugins available through the SuSE package management system.

    Installing these is a pain in the arse when, like me you're behind a proxy server and eclipse apparently contains a bug where the software updater ignores the eclipse / system proxy settings.

    The only way to install the plugins is to manually download them and extract them; not particularly difficult but why should such an important part of the system require learning how to install them when everything else is via the yast repositories?

    Finding documentation on how to install eclipse components is also quite annoying because eclipse is such a big project and changes so frequently; all of the information I found about how to add new repositories was out of date.

    All of this is a real pain, and I do not see why components such as CDT should not be in the yast repos like everything else, as it is with other distros.

    I'm just going to use netbeans instead!

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts