Results 1 to 9 of 9

Thread: Conflicts trying to install Amarok 2

  1. #1

    Default Conflicts trying to install Amarok 2

    I have openSUSE 11.1 with KDE 4.2. When trying to install Amarok 2 through YaST I get a message about conflicts:
    Code:
    kde4-amarok-2.0.1.1-3.1.1.x86_64 requires kdebase4-runtime < 4.1.60, but this requirement cannot be provided
    As solution to the conflicts YaST offers to downgrade 83 packages to KDE 4.1.3.
    Is there a way to install Amarok 2 in KDE 4.2?

    Thanks for your help.

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Conflicts trying to install Amarok 2

    You need to post the whole dependency info. You can save it to a file from the error box
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: Conflicts trying to install Amarok 2

    I have amarok 2.0.1.1 running in kde 4.2 but had to install the version from factory to get it to work.

  4. #4

    Default Re: Conflicts trying to install Amarok 2

    This is the complete dependency info. Hope you understand it even in german.

    Code:
    #### YaST2 conflicts list - generated 2009-02-19 04:28:59 ####
    
    kde4-amarok-2.0.1.1-2.1.1.x86_64 bentigt kdebase4-runtime < 4.1.60, was aber nicht angeboten werden kann
    Nicht installierbare Anbieter: kdebase4-runtime-4.1.3-4.1.i586[repo-oss]
                       kdebase4-runtime-4.1.3-4.1.x86_64[repo-oss]
        [ ] kde4-amarok-2.0.1.1-2.1.1.x86_64 nicht installieren
    
        [ ] Folgende Aktionen werden ausgefhrt:
    Downgrade von kdebase4-runtime-4.2.0-76.20.x86_64 zu kdebase4-runtime-4.1.3-4.1.x86_64
    Downgrade von PolicyKit-kde-0.2-20.48.x86_64 zu PolicyKit-kde-0.2-6.4.x86_64
    Downgrade von kde4-akregator-4.2.0-89.12.x86_64 zu kde4-akregator-4.1.3-3.11.x86_64
    Downgrade von kde4-ark-4.2.0-45.16.x86_64 zu kde4-ark-4.1.3-2.9.x86_64
    Downgrade von kde4-dolphin-4.2.0-70.13.x86_64 zu kde4-dolphin-4.1.3-3.5.x86_64
    Downgrade von kde4-gwenview-4.2.0-71.12.x86_64 zu kde4-gwenview-4.1.3-4.6.x86_64
    Downgrade von kde4-kaddressbook-4.2.0-89.12.x86_64 zu kde4-kaddressbook-4.1.3-3.11.x86_64
    Downgrade von kde4-kcalc-4.2.0-45.16.x86_64 zu kde4-kcalc-4.1.3-2.9.x86_64
    Downgrade von kde4-kcolorchooser-4.2.0-71.12.x86_64 zu kde4-kcolorchooser-4.1.3-4.6.x86_64
    Downgrade von kde4-kdepasswd-4.2.0-70.13.x86_64 zu kde4-kdepasswd-4.1.3-3.5.x86_64
    Downgrade von kde4-kdialog-4.2.0-70.13.x86_64 zu kde4-kdialog-4.1.3-3.5.x86_64
    Downgrade von kde4-kdm-4.2.0-200.1.x86_64 zu kde4-kdm-4.1.3-10.1.x86_64
    Downgrade von kde4-kdnssd-4.2.0-58.11.x86_64 zu kde4-kdnssd-4.1.3-4.11.x86_64
    Downgrade von kde4-keditbookmarks-4.2.0-70.13.x86_64 zu kde4-keditbookmarks-4.1.3-3.5.x86_64
    Downgrade von kde4-kfind-4.2.0-70.13.x86_64 zu kde4-kfind-4.1.3-3.5.x86_64
    Downgrade von kde4-kgamma-4.2.0-71.12.x86_64 zu kde4-kgamma-4.1.3-4.6.x86_64
    Downgrade von kde4-kget-4.2.0-58.11.x86_64 zu kde4-kget-4.1.3-4.11.x86_64
    Downgrade von kde4-kgpg-4.2.0-45.16.x86_64 zu kde4-kgpg-4.1.3-2.9.x86_64
    Downgrade von kde4-kgreeter-plugins-4.2.0-200.1.x86_64 zu kde4-kgreeter-plugins-4.1.3-10.1.x86_64
    Downgrade von kde4-kio_audiocd-4.2.0-41.26.x86_64 zu kde4-kio_audiocd-4.1.3-4.11.x86_64
    Downgrade von kde4-kio_kamera-4.2.0-71.12.x86_64 zu kde4-kio_kamera-4.1.3-4.6.x86_64
    Downgrade von kde4-kio_sysinfo-11.1.1-68.16.x86_64 zu kde4-kio_sysinfo-11.1-66.4.x86_64
    Downgrade von kde4-kmahjongg-4.2.0-41.20.x86_64 zu kde4-kmahjongg-4.1.3-3.9.x86_64
    Downgrade von kde4-kmail-4.2.0-89.12.x86_64 zu kde4-kmail-4.1.3-3.11.x86_64
    Downgrade von kde4-kmines-4.2.0-41.20.x86_64 zu kde4-kmines-4.1.3-3.9.x86_64
    Downgrade von kde4-kmix-4.2.0-41.26.x86_64 zu kde4-kmix-4.1.3-4.11.x86_64
    Downgrade von kde4-knotes-4.2.0-89.12.x86_64 zu kde4-knotes-4.1.3-3.11.x86_64
    Downgrade von kde4-konqueror-4.2.0-70.13.x86_64 zu kde4-konqueror-4.1.3-3.5.x86_64
    Downgrade von kde4-konqueror-plugins-4.2.0-39.27.x86_64 zu kde4-konqueror-plugins-4.1.3-2.8.x86_64
    Downgrade von kde4-konsole-4.2.0-70.13.x86_64 zu kde4-konsole-4.1.3-3.5.x86_64
    Downgrade von kde4-kontact-4.2.0-89.12.x86_64 zu kde4-kontact-4.1.3-3.11.x86_64
    Downgrade von kde4-kopete-4.2.0-58.11.x86_64 zu kde4-kopete-4.1.3-4.11.x86_64
    Downgrade von kde4-korganizer-4.2.0-89.12.x86_64 zu kde4-korganizer-4.1.3-3.11.x86_64
    Downgrade von kde4-kpat-4.2.0-41.20.x86_64 zu kde4-kpat-4.1.3-3.9.x86_64
    Downgrade von kde4-krdc-4.2.0-58.11.x86_64 zu kde4-krdc-4.1.3-4.11.x86_64
    Downgrade von kde4-kreversi-4.2.0-41.20.x86_64 zu kde4-kreversi-4.1.3-3.9.x86_64
    Downgrade von kde4-krfb-4.2.0-58.11.x86_64 zu kde4-krfb-4.1.3-4.11.x86_64
    Downgrade von kde4-kscd-4.2.0-41.26.x86_64 zu kde4-kscd-4.1.3-4.11.x86_64
    Downgrade von kde4-ksnapshot-4.2.0-71.12.x86_64 zu kde4-ksnapshot-4.1.3-4.6.x86_64
    Downgrade von kde4-ksudoku-4.2.0-41.20.x86_64 zu kde4-ksudoku-4.1.3-3.9.x86_64
    Downgrade von kde4-kwalletmanager-4.2.0-45.16.x86_64 zu kde4-kwalletmanager-4.1.3-2.9.x86_64
    Downgrade von kde4-kwin-4.2.0-200.1.x86_64 zu kde4-kwin-4.1.3-10.1.x86_64
    Downgrade von kde4-kwrite-4.2.0-70.13.x86_64 zu kde4-kwrite-4.1.3-3.5.x86_64
    Downgrade von kde4-okular-4.2.0-71.12.x86_64 zu kde4-okular-4.1.3-4.6.x86_64
    Downgrade von kde4-plasma-addons-4.2.0-55.9.x86_64 zu kde4-plasma-addons-4.1.3-5.16.x86_64
    Downgrade von kdeartwork4-screensaver-4.2.0-27.12.x86_64 zu kdeartwork4-screensaver-4.1.3-1.22.x86_64
    Downgrade von kdebase4-4.2.0-70.13.x86_64 zu kdebase4-4.1.3-3.5.x86_64
    Downgrade von kdebase4-workspace-4.2.0-200.1.x86_64 zu kdebase4-workspace-4.1.3-10.1.x86_64
    Downgrade von kdegames4-4.2.0-41.20.x86_64 zu kdegames4-4.1.3-3.9.x86_64
    Downgrade von kdemultimedia4-4.2.0-41.26.x86_64 zu kdemultimedia4-4.1.3-4.11.x86_64
    Downgrade von kdenetwork4-filesharing-4.2.0-58.11.x86_64 zu kdenetwork4-filesharing-4.1.3-4.11.x86_64
    Downgrade von kdepim4-4.2.0-89.12.x86_64 zu kdepim4-4.1.3-3.11.x86_64
    Downgrade von kdepim4-wizards-4.2.0-89.12.x86_64 zu kdepim4-wizards-4.1.3-3.11.x86_64
    Downgrade von krename-3.9.2-4.51.x86_64 zu krename-3.9.2-1.30.x86_64
    Downgrade von ktorrent-3.2-24.1.x86_64 zu ktorrent-3.1.5-0.pm.2.x86_64
    ktorrent-3.1.5-0.pm.2.x86_64 installieren (mit Anbieterwechsel)
      openSUSE Build Service
    -->
      packman.links2linux.de
    Deinstallation von plasmoid-flickr-0.4-3.13.x86_64
    Deinstallation von plasmoid-yasp-0.7.1-2.9.x86_64
    Deinstallation von plasmoid-yawp-0.1.65-3.30.x86_64
    Downgrade von skanlite-0.2.kde4.2.0-9.23.x86_64 zu skanlite-0.2-3.15.x86_64
    Downgrade von kde4-konqueror-plugins-lang-4.2.0-39.27.x86_64 zu kde4-konqueror-plugins-lang-4.1.3-2.8.x86_64
    Downgrade von kdebase4-nsplugin-4.2.0-70.13.x86_64 zu kdebase4-nsplugin-4.1.3-3.5.x86_64
    Downgrade von kdebase4-session-4.2.0-32.3.x86_64 zu kdebase4-session-4.1.3-2.2.x86_64
    Downgrade von kdebluetooth4-0.3-9.1.x86_64 zu kdebluetooth4-0.2-12.33.x86_64
    Downgrade von ktorrent-lang-3.2-24.1.x86_64 zu ktorrent-lang-3.1.5-0.pm.2.x86_64
    ktorrent-lang-3.1.5-0.pm.2.x86_64 installieren (mit Anbieterwechsel)
      openSUSE Build Service
    -->
      packman.links2linux.de
    Downgrade von kdebase4-libkonq-4.2.0-70.13.x86_64 zu kdebase4-libkonq-4.1.3-3.5.x86_64
    Downgrade von kdepimlibs4-4.2.0-2.8.x86_64 zu kdepimlibs4-4.1.3-5.1.x86_64
    Downgrade von libkcddb4-4.2.0-41.26.x86_64 zu libkcddb4-4.1.3-4.11.x86_64
    Downgrade von libkcompactdisc4-4.2.0-41.26.x86_64 zu libkcompactdisc4-4.1.3-4.11.x86_64
    Downgrade von libkdegames4-4.2.0-41.20.x86_64 zu libkdegames4-4.1.3-3.9.x86_64
    Downgrade von libkdepim4-4.2.0-89.12.x86_64 zu libkdepim4-4.1.3-3.11.x86_64
    Downgrade von libkdepimlibs4-4.2.0-2.8.x86_64 zu libkdepimlibs4-4.1.3-5.1.x86_64
    Downgrade von kdegames4-carddecks-default-4.2.0-41.11.noarch zu kdegames4-carddecks-default-4.1.3-3.9.noarch
    Downgrade von libakonadi4-4.2.0-2.8.x86_64 zu libakonadi4-4.1.3-5.1.x86_64
    Downgrade von libkonq5-4.2.0-70.13.x86_64 zu libkonq5-4.1.3-3.5.x86_64
    Downgrade von kdegames4-carddecks-other-4.2.0-41.11.noarch zu kdegames4-carddecks-other-4.1.3-3.9.noarch
        [ ] Einige Abhngigkeiten von kde4-amarok ignorieren
    
    #### YaST2 conflicts list END ###

  5. #5
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Conflicts trying to install Amarok 2

    Can you post output from terminal of:

    zypper lr
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  6. #6

    Default Re: Conflicts trying to install Amarok 2

    There you go:
    # | Alias | Name | Aktiviert | Aktualisierung
    ---+------------------------------------+------------------------------------+-----------+---------------
    1 | Extra_Apps | Extra Apps | Ja | Ja
    2 | KDE:KDE4:Community | KDE:KDE4:Community | Ja | Ja
    3 | KDE:KDE4:Factory:Desktop | KDE:KDE4:Factory:Desktop | Ja | Ja
    4 | KDE:KDE4:STABLE:Desktop | KDE:KDE4:STABLE:Desktop | Nein | Ja
    5 | KDE:Qt | KDE:Qt | Nein | Ja
    6 | NVIDIA Repository | NVIDIA Repository | Nein | Ja
    7 | Packman | Packman | Ja | Ja
    8 | Videolan | Videolan | Nein | Ja
    9 | openSUSE 11.1-0 | openSUSE 11.1-0 | Nein | Nein
    10 | openSUSE_11.1_KDE4_Factory_Desktop | openSUSE_11.1_KDE4_Factory_Desktop | Ja | Ja
    11 | repo-debug | openSUSE-11.1-Debug | Nein | Ja
    12 | repo-non-oss | openSUSE-11.1-Non-Oss | Ja | Ja
    13 | repo-oss | openSUSE-11.1-Oss | Ja | Ja
    14 | repo-source | openSUSE-11.1-Source | Nein | Ja
    15 | repo-update | openSUSE-11.1-Update | Ja | Ja

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Conflicts trying to install Amarok 2

    Struggling a little with all the German but can you remove all instances of kde4 and QT repos that you have and then add back these:

    Index of /repositories/KDE:/KDE4:/Factory:/Desktop/openSUSE_11.1

    Index of /repositories/KDE:/KDE4:/Community/openSUSE_11.1_KDE4_Factory_Desktop

    Index of /repositories/KDE:/Qt44/openSUSE_11.1

    You might want to make Nvidia set to Yes|Yes (not that it is related to this though)

    Now check and do update all so you don't have red or blue packages

    Now try amarok
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: Conflicts trying to install Amarok 2

    kde4-amarok-2.0.1.1-2.1.1 is a package from the repo-update repository. It is compiled against the KDE version from openSUSE 11.1: 4.1.3.
    kde4-amarok-2.0.1.1-20.55 is the same package, but compiled against KDE 4.2.

    If you want to install -2.1.1 you will need to install KDE 4.1.3. If you want to mantain KDE 4.2 just install amarok from the same repo... package version -20.55.


    You probably want to increase the priority of the KDE:KDE4:Factory:Desktop repository...

  9. #9

    Default Re: Conflicts trying to install Amarok 2

    Thanks guys!

    Cleaning up the repos and then choosing the right version in YaST did the trick.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •