Results 1 to 9 of 9

Thread: Desktop Cube won't rotate - Suse 11.1, 64-bit

  1. #1

    Question Desktop Cube won't rotate - Suse 11.1, 64-bit

    Hello. I enabled 3D effects a few minutes ago (new install - using online repository and not the DVD). Most effects work, but when dragging a window to the left, the screen flickers black then to the new desktop. No cube animation is present.

    Specs:
    Asus P5Q Deluxe Mobo
    Intel Q9650 CPU
    8GB RAM
    nVidia GTX260 video (PCIe)
    Pinnacle PCTV HD tuner card (PCI)
    SUSE 11.1, 64-bit edition

    Has this happened to anybody else? Or could this be conflicting with any of the enabled effects like opacity?

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    In config desktop - Desktop
    General
    Do you have the effect for desktop switching drop box set to cube?
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    Join Date
    Jul 2008
    Location
    Pottstown PA, US
    Posts
    150

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    you can use the compizconfig-settings-manager command to configure compiz to your hearts desire!


    open a terminal and issue the following command

    compizconfig-settings-manager
    Desktop| opensuse11.3| Core2Q Q9450 | nVidia GeForce 8800 GT
    Server| Arch | mythtv 024 | Core2D E7500| nVidia GT210
    HTPC| opensuse11.3 | mythtv 024| Atom 330 | ASUS AT3IONT-I Deluxe | nVidia ION
    Laptop| System76 | opensuse11.3| Core2D P8600 | nVidia 9300M

  4. #4

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    Thanks. I opened up a terminal...

    And apart from reading a hostname that wasn't what I set up my machine as (grr),I find that Desktop Cube is already selected.

    I did see "No sexy-python package found". I will hunt down and install that.

    Between my OP and now, I've had compiz crash several times. It was never this flaky under Fedora. (Ironic, Fedora's software packaging system is very flaky... )

  5. #5
    Join Date
    Jul 2008
    Location
    Pottstown PA, US
    Posts
    150

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    the sexy python package is just to make the configuration utility look pretty. You can get into some pretty advanced options in that utility, play with it some more. Maybe it has to do with the rotation speed?
    Desktop| opensuse11.3| Core2Q Q9450 | nVidia GeForce 8800 GT
    Server| Arch | mythtv 024 | Core2D E7500| nVidia GT210
    HTPC| opensuse11.3 | mythtv 024| Atom 330 | ASUS AT3IONT-I Deluxe | nVidia ION
    Laptop| System76 | opensuse11.3| Core2D P8600 | nVidia 9300M

  6. #6

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    Nope. Turns black until I finish moving my mouse to the left, then desktop #2 appears.

    I've had other issues with the desktop itself not refreshing; making firefox a chore. I will turn off 3D and see if that improves.

    I've nvidia 180.29 (x86_64)

  7. #7
    ghostdancer84 NNTP User

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    Now, I don't know if anybody else has figured this out, but, if you hit the alt-F2 key, it'll bring up a run box. Type in compiz, and an icon will come up. You actually have to tell kde to run compiz. You can just go to settings manager and it happen. I hope this helps.

  8. #8
    stefanwolf NNTP User

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    Hi,
    i got a similar problem:
    when i first turn desktop effects on, the cube rotates and everything is ok. After the screensaver came up once, the cube still rotates ok when switching workspaces using the workspace switcher, but not when switching desktops by moving a window with the mouse pointer to the screens edges. When i edit desktop effects (turn on or off one of them) everything is ok again, until the screensaver comes up again.
    Bye.

  9. #9
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,845
    Blog Entries
    14

    Default Re: Desktop Cube won't rotate - Suse 11.1, 64-bit

    From Systemsettings - Default Apps -Windowmanager, pick Compiz. Apply, and from now on Compiz will be your default.

    From Systemsettings - Desktop - Desktop Effects - pick the Tab 'all effects', select Cube from list, there's a tool-icon to configure some things.

    One question: what kind of graphics card/onboard do you have, which drivers did you install and how?
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •