Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

  1. #1

    Unhappy OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    Hi,

    I have a P4 with 750 Megs RAM and an Nvidia 7300 Card.

    I installed OpenSuse 11.1 last week and it came with KDE 4.1.3. Though the desktop looked clean I was unable to run 3D on it...at least thats what I thought because I could not see the Desktop Cube (when I pressed ctrl-F11) and I should mention, I had uninstalled Compiz when I did that so the KDE's composite effects were turned on.

    Then I upgraded to KDE4.2 last night and I still don't see the 3D effects. I have updated Nvidia drivers for my graphic card but it doesn't seem to have helped. I think I am missing something here in OpenSuse because before this I had ubuntu and I was able to see the 3D effects there.

    Can someone help please?

    Thanks in advance!

    Aditya

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    compiz and compiz-kde4 need to be installed from the 4.2 desktop repo

    enable cube in all effects
    and under the main window for effects - General - Common settings - set desktop switching to cube
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    Thanks for the reply.

    I have not tried this yet as I don't have access to my system but isn't it that if Compiz is enabled, one cannot enable the "KDE Desktop Effects"? When I was using KDE 4.1.3, I had compiz (for a few hours) and as far as I remember, the "Enable Desktop Effects" in KDE was greyed out. It was not available. Please correct me if I am wrong.

  4. #4
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    There is no need to install 'Compiz' as was the case in the past adding repo's or OneClick installs.
    Compiz packages are in the kde4 desktop repo and should be installed as I said earlier. You don't set compiz as the window manager as was the case in the past - But rather use kwin, kde's default window manager.

    If desktop effects are greyed out. Post your /etc/X11/xorg.conf
    here:
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  5. #5
    Join Date
    Aug 2008
    Location
    BUD, Hungary
    Posts
    36

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    Can we see the result of 'glxgears' command?

  6. #6

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    kistej: Here's the output:
    1716 frames in 5.0 seconds = 342.970 FPS
    1666 frames in 5.0 seconds = 333.183 FPS
    2061 frames in 5.0 seconds = 411.896 FPS
    2072 frames in 5.0 seconds = 414.189 FPS
    2068 frames in 5.0 seconds = 413.579 FPS
    2060 frames in 5.0 seconds = 411.737 FPS
    2069 frames in 5.0 seconds = 413.728 FPS


    caf4926: I uninstalled Compiz when I was with KDE 4.1.3. I upgraded from that point to KDE 4.2 and I can tell you that I do not have Compiz right now. I don't see it installed in the package manager. It would be handy to know how to install Compiz in KDE 4.2, I think...

    Thanks!

  7. #7
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    Open Yast Software Management
    filter by repo
    look at kde4 factory 4.2 repo for compiz-kde and compiz-kde4, they should bring in any dependencies.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  8. #8

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    Okay, I **think** its working as it should now.

    I didn't do any change apart from choosing "OpenGL" in Compositing Type. I remember KDE 4.3.1 was not letting me choose this for whatever reason (Maybe the default Nvidia driver didn't support it) but after an upgrade of the driver and after the upgrade to KDE 4.3.2 it let me choose OpenGL and it seems that has fixed this.

    I should mention, though, that in Yast, I still see as Compiz not installed in my box. Is it supposed to be there? Is this KWin working for me now? I tried choosing Compiz and installing it through Yast but it asks for a downgrade to several KDE packages (downgrade to 4.3.1, which was the version which I upgraded from). Any ideas there? Or is this the best I could have? If I am to install Compiz how should I go about it, with all this downgrade thing?

  9. #9
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    give us the result of :

    zypper lr
    ============

    also - when you get an error in Yast with dependencies, save it to a file. The error box has an expert option to do that - then post it here.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  10. #10
    Join Date
    Feb 2009
    Location
    Sweden
    Posts
    7

    Default Re: OpenSuse 11.1 - KDE 4.2 -- Not sure if 3D working

    Try typing glxgears in a terminal. You should get a window with some gear wheels and a framerate read out in the terminal window. This is the first thing you should try beacause if this doesn't work you won't get any further till it does.

Page 1 of 2 12 LastLast

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •