Results 1 to 2 of 2

Thread: I've broken my vmware player - no /dev/vmmon

  1. #1
    kfar NNTP User

    Unhappy I've broken my vmware player - no /dev/vmmon

    I'm really new to posting questions, so my apologies right now if I don't put this properly...

    I have previously used VMWare Player in Hardy Heron for the few remaining things I couldn't do in OSS. It used to break every time the kernel updated, but it was just a matter of running
    "sudo /usr/bin/"
    and it would put itself more or less right.

    However, I like Suse, I prefer KDE, and Hardy began to be dangerous with my usb stick - the only way in and out of the VMWare Player.

    So, I was delighted with Suse 11.1 (even the sound worked!)
    But, the day after installing VMWare Player, I restarted it and saw this:

    Could not open /dev/vmmon: No such file or directory.
    Please make sure that the kernel module `vmmon' is loaded.

    I can't find out what to do.
    I've read that uninstalling VMWare Player is no good because it will refuse to reinstall - something is left, and I'm not clever enough to find it.

    Also, the Hardy repair is no good: there is no

    I must be running a newer version of player (2.5.1 build-126130) and it builds differently. Anyway, it was Hardy kernel updates that used to break it, and I do not remember ever getting the "vmmon" message then.

    Has anyone else met this "/dev/vmmon" problem with VMWare Player?
    Is there a repeatable fix?
    Or a way to uninstall an application thoroughly enough to be sure it can reinstall?

  2. #2
    kfar NNTP User

    Default Re: I've broken my vmware player - no /dev/vmmon

    On reflection, the emergence of re-usable knowledge...

    I have reluctantly installed a 500+MB download of VMware server.
    It didn't feel intuitive.
    The server uses Firefox for control and output.
    (There was a bug with FF 3.0.0, but it looks like it is fixed now, in 3.0.6.)
    So, the server can be started from CLI.
    Server GUI is via Firefox.
    Multi-paned, tabbed interface.
    One tab is for a Firefox add-on, provided by VMware.
    It should show VM desktop in an add-on "console" window.
    The add-on won't work for me.
    (Or several others.)
    Firefox Konsole stderror sez:
    terminate called after throwing an instance of 'Gio::Error'

    So, I had an unworkable Player and now I also have a working Server with an unusable VM Desktop.

    I did find this article in VMware's Knowledge Base:
    "Incomplete Uninstallation Prevents Installing an Update"
    It *might* clean out my Suse 11.1 for a fresh load of VMware Player.

    As is, I have already had to do a simple uninstall of Player.
    I have installed & can start and stop the VMwareServer.
    I can see the server GUI in Firefox.
    It tends to grind away "loading", but "refresh" sorts that.
    I seem to have loaded the "console" add-on, but can't see it.
    The virtual machine starts and stops.
    I can hear it load via the on-board sound.
    I can't see or use the VM - the add-on gives no VM desktop.

    Why this?
    terminate called after throwing an instance of 'Gio::Error'
    One suggested explanation is broken symlink(s).
    What have I got myself into? Are they human-findable? In my life-time?

    Apparent Reasonable Options:
    1) Persist with Server add-on, at edge of my comprehension. (Is Server even secure?)
    2) Try to reinstall current release of Player (Hoping presence of Server helps it...)
    3) Try an install of old Player version, archived from Hardy (hitherto reliably repairable....)

    If I knew then what I know now...
    a) I would have tried the old version of Player first.
    b) I would have seen the new Player's problem as a VMware issue, not a Suse11.1 issue.

    Back in the days when songs had simple lyrics,
    someone wrote:
    "your wise men don't know how it feels to be thick as a brick".
    I suspect people who know their Linux stuff
    might find it hard to imagine just how obscure the seemingly obvious can be to a stranger.
    But, obviously, I wouldn't personally be knowing

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts