Results 1 to 2 of 2

Thread: Please help: rasmol crashes on startup

  1. #1
    mboehm NNTP User

    Default Please help: rasmol crashes on startup

    I installed the rasmol package under OpenSUSE 11. The program crashes on startup with a segmentation fault. Using gdb I got the following:

    Program received signal SIGSEGV, Segmentation fault.
    0xb7eaad69 in XCopyArea () from /usr/lib/
    (gdb) backtrace
    #0 0xb7eaad69 in XCopyArea () from /usr/lib/
    #1 0x080c9922 in DrawXScroll () at x11win.c:1327
    #2 0x080ccdf0 in ReSizeWindow (wide=0, high=<value optimized out>) at x11win.c:2556
    #3 0x080b7399 in SwitchLang (lang=English) at langsel_unix.c:2342
    #4 0x080cd289 in OpenDisplay () at x11win.c:2714
    #5 0x0804d5bc in main (argc=1, argv=0xbfd25934) at rasmol.c:2332
    (gdb) up
    #1 0x080c9922 in DrawXScroll () at x11win.c:1327
    1327 XCopyArea(dpy,rgpix,XScrlWin,gcon,0,0,16,16,XRange-16,0);
    (gdb) print dpy
    $1 = (Display *) 0x8154008
    (gdb) print rgpix
    $2 = 0
    (gdb) print XScrlWin
    $3 = 0
    (gdb) print gcon
    $4 = (GC) 0x0

    The program works fine if I start it from my Ubuntu box via ssh -X, but it crashes when run directly from within OpenSUSE 11.

    I also tried installing the latest rasmol rpm ( from as well as a previous version (2.7.3). I even tried compiling it from source myself. The result is always the same: rasmol segfaults on startup.

    I'm running out of ideas. Please help!

  2. #2
    mboehm NNTP User

    Talking Re: Please help: rasmol crashes on startup

    Fixed. Install the xorg-x11-fonts package, open a terminal and write:

    xset fp rehash
    /etc/init.d/xfs restart

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts