Results 1 to 2 of 2

Thread: Bad performance in some 3d apps

  1. #1
    ordinarylife NNTP User

    Unhappy Bad performance in some 3d apps

    Hello,

    I got some weird performance bugs in 3d apps.
    For example in: GoogleEarth, glxgears, sauerbraten

    If i start glxgears, my frames seem to be quite ok:

    PHP Code:
    12356 frames in 5.0 seconds 2471.183 FPS
    12907 frames in 5.0 seconds 
    2564.860 FPS 
    But the problem is that the visualisation isnt fluently running.
    So its kinda studdering the whole time.
    Same goes for the other Apps mentioned above.

    The weird thing is, that Kwin works without any problems.

    Hardware: AMD 4200 x2 64bit, 2x 512 Corsair XMS, k8n-neo4 (MSI), 9800GT NVIDIA
    OSS: Opensuse 11.1 + KDE 4.1


    I hope you can help me

    PS: Rendering is ofcourse enabled and the drivers are also correctly installed.

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,872
    Blog Entries
    15

    Default Re: Bad performance in some 3d apps

    Quote Originally Posted by ordinarylife
    Hello,

    I got some weird performance bugs in 3d apps.
    For example in: GoogleEarth, glxgears, sauerbraten

    If i start glxgears, my frames seem to be quite ok:


    PHP code:
    --------------------
    12356 frames in 5.0 seconds = 2471.183 FPS
    12907 frames in 5.0 seconds = 2564.860 FPS
    --------------------


    But the problem is that the visualisation isnt fluently running.
    So its kinda studdering the whole time.
    Same goes for the other Apps mentioned above.

    The weird thing is, that Kwin works without any problems.

    Hardware: AMD 4200 x2 64bit, 2x 512 Corsair XMS, k8n-neo4 (MSI), 9800GT
    NVIDIA
    OSS: Opensuse 11.1 + KDE 4.1


    I hope you can help me

    PS: Rendering is ofcourse enabled and the drivers are also correctly
    installed.
    Hi
    Have you tweaked your xorg file? I'm running Gnome, there may be others
    that are KDE centric;

    Add these settings in the device section;

    Code:
    Option "AllowGLXWithComposite" "True"
    Option "DisableGLXRootClipping" "True"
    Option "RenderAccel" "True"
    Option "AddARGBGLXVisuals" "True"
    My xorg.conf file is here;
    <http://nopaste.com/p/ai0teWZXab>
    and this is the dual monitor setup on a 4400+ X2;
    <http://www.nopaste.com/p/a9J8lbnHE>

    --
    Cheers Malcolm (Linux Counter #276890)
    openSUSE 11.1 x86 Kernel 2.6.27.7-9-default
    up 2:42, 1 user, load average: 0.42, 0.18, 0.12
    GPU GeForce 6600 TE/6200 TE - Driver Version: 180.29


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •