Results 1 to 4 of 4

Thread: "Permission denied" when enabling wireless channels 12-13-14

  1. #1
    MistaXFrye NNTP User

    Exclamation "Permission denied" when enabling wireless channels 12-13-14

    I used the code from the "Tracking down wireless problems" page in the openSUSE forums, but to no avail.

    echo "options cfg80211 ieee80211_regdom=EU" > /etc/modprobe.d/cfg80211

    It said "Permission denied," which seems ridiculous because there is only one account - my root account.

    Any ideas on how to get around this issue? I'm a Linux noob, but try me.

    Thanks!

  2. #2
    Join Date
    Jun 2008
    Location
    Kansas City Area, Missouri, USA
    Posts
    7,235

    Default Re: "Permission denied" when enabling wireless channels 12-13-14

    MistaXFrye wrote:
    > I used the code from the "Tracking down wireless problems" page in the
    > openSUSE forums, but to no avail.
    >
    > echo "options cfg80211 ieee80211_regdom=EU" > /etc/modprobe.d/cfg80211
    >
    >
    > It said "Permission denied," which seems ridiculous because there is
    > only one account - my root account.
    >
    > Any ideas on how to get around this issue? I'm a Linux noob, but try
    > me.


    Are you telling us that you only log into your computer as root? If so, you are
    not only endangering your computer system, but also the rest of us! You should
    have a user with normal privilege and use "sudo" when you need the extra privilege.

    What I suspect is that you created a username "root" with normal privilege. You
    can check that with the "id" command. The critical point will be the uid and gid
    numbers.

    To properly complete the above command, preface it with "sudo".

    Larry


    Larry

  3. #3
    MistaXFrye NNTP User

    Thumbs up Re: "Permission denied" when enabling wireless channels 12-1

    I apologize for the dumb move!

    Thanks Larry, I'll give that a shot right now.

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,124

    Default Re: "Permission denied" when enabling wireless channels 12-1

    As lwfinger explains there should be only one user root with uid 0 (zero). Read this on how to use it:
    SDB:Login as root - openSUSE
    Henk van Velden

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •