Results 1 to 4 of 4

Thread: Not able to play .rm or .rmvb files at all in openSUSE 11.0

  1. #1
    rahul66 NNTP User

    Default Not able to play .rm or .rmvb files at all in openSUSE 11.0

    I'm using openSUSE 11.0 with KDE 3.5

    I installed all the codecs required for mplayer(from the Packman repository and all-codecs-package from mplayer homepage). but still, i'm not able to play .rm, .rmvb and .amr files with mplayer.

    The command line output when I tried to play a .rm file is as follows. I get the audio, but no video.

    -----------------------------------------------------------------
    rahul@linux-ac4a:~> mplayer '/stuff2/grahanam.rm'
    MPlayer dev-SVN-r27637-4.3-openSUSE Linux 11.0 (x86_64)-Packman (C) 2000-2008 MPlayer Team
    CPU: Intel(R) Core(TM)2 Duo CPU T5270 @ 1.40GHz (Family: 6, Model: 15, Stepping: 13)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.

    Playing /stuff2/grahanam.rm.
    REAL file format detected.
    Stream description: audio/x-pn-multirate-realaudio logical stream
    Stream mimetype: audio/x-pn-realaudio
    [real] Audio stream found, -aid 0
    Stream description: video/x-pn-multirate-realvideo logical stream
    Stream mimetype: video/x-pn-realvideo
    [real] Video stream found, -vid 1
    VIDEO: [RV40] 320x240 24bpp 25.000 fps 0.0 kbps ( 0.0 kbyte/s)
    Clip info:
    name: teluguone.com
    author: teluguone.com
    copyright: teluguone.com(C) 2006
    ==========================================================================
    Opening video decoder: [realvid] RealVideo decoder
    Error: /usr/lib64/RealPlayer10/codecs/drvc.so: cannot open shared object file: No such file or directory
    ERROR: Could not open required DirectShow codec drvc.so.
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Opening video decoder: [realvid] RealVideo decoder
    ERROR: Could not open required DirectShow codec drvc.dll.
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Opening video decoder: [realvid] RealVideo decoder
    Error: /usr/lib64/RealPlayer10/codecs/drv4.so.6.0: cannot open shared object file: No such file or directory
    ERROR: Could not open required DirectShow codec drv4.so.6.0.
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Opening video decoder: [realvid] RealVideo decoder
    ERROR: Could not open required DirectShow codec drv43260.dll.
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Opening video decoder: [realvid] RealVideo decoder
    Error: /usr/lib64/RealPlayer10/codecs/drvc.bundle/Contents/MacOS/drvc: cannot open shared object file: No such file or directory
    ERROR: Could not open required DirectShow codec drvc.bundle/Contents/MacOS/drvc.
    Read the RealVideo section of the DOCS!
    VDecoder init failed
    Cannot find codec matching selected -vo and video format 0x30345652.
    Read DOCS/HTML/en/codecs.html!
    ==========================================================================
    ==========================================================================
    Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
    AUDIO: 44100 Hz, 2 ch, s16le, 64.1 kbit/4.54% (ratio: 8010->176400)
    Selected audio codec: [ffcook] afm: ffmpeg (FFmpeg COOK audio decoder)
    ==========================================================================
    [AO OSS] audio_setup: Can't open audio device /dev/dsp: Device or resource busy
    AO: [alsa] 48000Hz 2ch s16le (2 bytes per sample)
    Video: no video
    ===== PAUSE =====
    A: 4.3 (04.2) of 5533.0 ( 1:32:13.0) 2.2%
    -----------------------------------------------------------------


    amr plays with realplayer, but with very bad quality(the sound gets constantly interrupted every 2-3 seconds).

    And realplayer is being pathetic, it doesn't play anything except those .amr and .mp3 files. When I try to play avi or non-real files, it gives me the message

    The following components are required:
    avi

    And when I try to play .rm or .rmvb files, it just crashes. The command line output for realplayer for a .rm file is as follows.

    -----------------------------------------------------------------
    rahul@linux-ac4a:~> realplay '/stuff2/grahanam.rm'
    The program 'realplay.bin' received an X Window System error.
    This probably reflects a bug in the program.
    The error was 'BadMatch (invalid parameter attributes)'.
    (Details: serial 32 error_code 8 request_code 140 minor_code 13)
    (Note to programmers: normally, X errors are reported asynchronously;
    that is, you will receive the error a while after causing it.
    To debug your program, run it with the --sync command line
    option to change this behavior. You can then get a meaningful
    backtrace from your debugger if you break on the gdk_x_error() function.)
    -----------------------------------------------------------------

    Thanks in advance,
    Rahul

  2. #2
    Join Date
    Jun 2008
    Location
    The English Lake District. UK - GMT/BST
    Posts
    36,733
    Blog Entries
    20

    Default Re: Not able to play .rm or .rmvb files at all in openSUSE 1

    Un-install RealPlayer if it's the one from the repo

    Download the .rpm
    http://www.real.com/realcom/R?href=h...ayer11GOLD.rpm

    Open a terminal in the directory you saved it and go su, then do:

    rpm -ihv RealPlayer11GOLD.rpm

    N.B. You will find if you just type the R of the package name above and then hit TAB it should auto complete.
    Leap 15.1_KDE
    My Articles Was I any help? If yes: Click the star below

  3. #3
    rahul66 NNTP User

    Default Re: Not able to play .rm or .rmvb files at all in openSUSE 1

    I got this error

    linux-ac4a:/stuff2/opensuseall/Documents # rpm -ihv RealPlayer11GOLD.rpm
    Preparing... ########################################### [100%]
    1:RealPlayer ########################################### [100%]
    *** NSPlugin Viewer *** ERROR: /usr/lib64/browser-plugins/opensc-signer.so: wrong ELF class: ELFCLASS64

  4. #4
    Join Date
    Feb 2009
    Location
    Medellin, Colombia
    Posts
    19

    Default Re: Not able to play .rm or .rmvb files at all in openSUSE 1

    Quote Originally Posted by rahul66 View Post
    ==========================================================================
    Opening video decoder: [realvid] RealVideo decoder
    Error: /usr/lib64/RealPlayer10/codecs/drvc.so: cannot open shared object file: No such file or directory

    i used to had the same problem, but i'm using 32
    bit version

    so what i did was: go to /usr/lib, there should be a folder called codecs, copy this folder, then go to /usr/lib64 and look for a folder called RealPlayer10, in case you dont have it, create it... then inside this folder paste the codecs folder and try to open a rmvb, it should play now.

    i know thats a silly solution, but it worked for me...

    hope this can help you

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •