Results 1 to 2 of 2

Thread: OpenOffice crashing

  1. #1
    stan80 NNTP User

    Default OpenOffice crashing

    Hi guys,

    I hope someone here can help me.
    When trying to run any OpenOffice application, it is crashing immediately.

    When using the backtrace function within the KDE Crash Handler, I get:
    --------------------------------------------------------------
    System configuration startup check disabled.

    [?1034h(no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    [Thread debugging using libthread_db enabled]
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    (no debugging symbols found)
    [KCrash handler]
    #6 0xffffe430 in __kernel_vsyscall ()
    #7 0xb7bd6990 in raise () from /lib/libc.so.6
    #8 0xb7bd82c8 in abort () from /lib/libc.so.6
    #9 0xb7bcf78e in __assert_fail () from /lib/libc.so.6
    #10 0xb622e8b1 in _XReply () from /usr/lib/libX11.so.6
    #11 0xb6209df9 in XAllocColor () from /usr/lib/libX11.so.6
    #12 0xb3f71367 in SalColormap::GetXPixel(XColor&, int, int, int) const ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #13 0xb3f6ba0a in SalColormap::SalColormap(SalDisplay const*, unsigned long, int) () from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #14 0xb3f7025e in SalDisplay::initScreen(int) const ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #15 0xb3f466be in SalDisplay::getDataForScreen(int) const ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #16 0xb3f7887f in vcl_sal::WMAdaptor::WMAdaptor(SalDisplay*) ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #17 0xb3f7987a in vcl_sal::NetWMAdaptor::NetWMAdaptor(SalDisplay*) ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #18 0xb3f79d0b in vcl_sal::WMAdaptor::createWMAdaptor(SalDisplay*) ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #19 0xb3f709ec in SalDisplay::Init() ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #20 0xb3f70e99 in SalX11Display::SalX11Display(_XDisplay*) ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_genli.so
    #21 0xb7e1d7d6 in SalKDEDisplay::SalKDEDisplay(_XDisplay*) ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_kdeli.so
    #22 0xb7e1db47 in KDEXLib::Init() ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_kdeli.so
    #23 0xb7e1d45c in KDEData::Init() ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_kdeli.so
    #24 0xb7e1d3cc in create_SalInstance ()
    from /usr/lib/ooo3/basis3.0/program/libvclplug_kdeli.so
    #25 0xb6be1010 in tryInstance(rtl::OUString const&) ()
    from /usr/lib/ooo3/program/../basis-link/program/libvclli.so
    #26 0xb6be1393 in CreateSalInstance() ()
    from /usr/lib/ooo3/program/../basis-link/program/libvclli.so
    #27 0xb6a07d72 in InitVCL(com::sun::star::uno::Reference<com::sun::star::lang::XMultiServiceFactory> const&) ()
    from /usr/lib/ooo3/program/../basis-link/program/libvclli.so
    #28 0xb6a0814c in ImplSVMain() ()
    from /usr/lib/ooo3/program/../basis-link/program/libvclli.so
    #29 0xb6a08305 in SVMain() ()
    from /usr/lib/ooo3/program/../basis-link/program/libvclli.so
    #30 0xb7e6c824 in soffice_main ()
    from /usr/lib/ooo3/program/../basis-link/program/libsofficeapp.so
    #31 0x08048c44 in main ()
    -----------------------------------------------------------------


    I am not sure, how this can help me, so maybe you have got an idea?

  2. #2
    assistant NNTP User

    Default Re: OpenOffice crashing

    1. which version of openSUSE are you using?

    2. you mention KDE, but don't tell us which version you use--which?

    3. what version of OpenOffice?

    4. is it as it was default installed, or have you 'updated' or
    changed it in any way..

    5. did you install from DVD or Live CD?

    6. did you do an md5sum check of the iso prior to burning the disk,
    and then a media check prior to the install?

    7. has any OpenOffice app ever worked correctly on this install?

    8. open a terminal, type in oowriter and press enter...the
    OpenOffice word processor _should_ pop up....if it does not there
    might be an error message written to the still open terminal...if
    there is, copy and paste it back to this thread..

    --
    assistant

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •