Directories on my desktop open with Konqueror. In order to open them with Dolphin by default:

Open Konqueror, Settings, Cofigure Konq. Go to "File associations" search for "directory". Go down to "inode" and move Dolphin to the top of the list.